Page 2 of 2 FirstFirst 12
Results 21 to 31 of 31
  1. #21  
    Quote Originally Posted by Alienwhere View Post
    I don't see "VMailNumber" when I'm in there looking in that location. Should I be clicking on the vmail folder? Is it missing on my phone and that's why it's not connecting? I can still dial 1 and get it, but the softkey is not working as I said...

    If it's supposed to be there, and it's not, would I then have to create it? And if so, since I'm not the strongest reg editor, which kind of value would I create (using PHM)...?
    Yes, you should be looking inside the vmail folder, it should be one the keys there.
  2. #22  
    Quote Originally Posted by Littlepat View Post
    Yes, you should be looking inside the vmail folder, it should be one the keys there.
    Ok then - if it's not there, can I create it? If so, I'm using PHM, what am I selecting to create?

    I'm good at a lot of things, but I get a little wary with the registry, ya know?
  3. #23  
    Quote Originally Posted by Alienwhere View Post
    Ok then - if it's not there, can I create it? If so, I'm using PHM, what am I selecting to create?

    I'm good at a lot of things, but I get a little wary with the registry, ya know?
    I don't think you should add it if it is not there. Its not in my registry either by the way, I just checked. You might have to call Sprint/Verizon and re-program your phone. Sounds like there is an error in there
  4. #24  
    Interesting... it was there, now it's not. Because my phone was working for quite a while before the last hard reset. Perhaps I will suck it up, do another one, and see the difference... because the VM number is correct, and in the first 700wx I had, it wasn't (as is talked about in another thread). I exchanged the first one and the second one was fine... the plot thickens.
  5. #25  
    Just thought I'd mention this...

    I was all ready to hard reset, so I did one more current backup just prior. I did the HR, and was looking in the registry to see if the key was there. It was indeed. I then decided I was going to try and re-create the missing key in my former system by restoring the backup I had just made.

    When I restored the backup, the key was in the registry already.

    Now, how could a key be completely gone one minute and return the next, without any interaction on my part directly? Not that I'm complaining, because my voicemail softkey is working again the way I wanted it to in the first place, but it was just bizarre. Wanted to share it.
  6. #26  
    Quote Originally Posted by Dome View Post
    I had a similar problem on my 700wx. My problem was slightly different, in that it originally worked, but after swapping phone numbers, the old number stayed in place. Here is how I fixed it:

    First, get yourself a registry editor like PHM RegEdit. Once you have installed the registry editor, browse to the following registry location:


    Then, change the value for the REG_SZ parameter "VMailNumber" to your current phone number. This should be the only parameter present in this registry key (on the 700wx anyways). No reset was required after making this change on my 700wx.

    Thanks. I just got my new VZW 700wx and it was dialing some messed up number. Editing this value did the trick. Thanks.
  7. #27  
    I'm having the same problem. I.e., when I get a new voicemail, the soft-button on the lower left gives me the option to choose voicemail, but when I get the point of clicking on "Listen" absolutely nothing happens. It doesn't even try to dial a weird number or connect to a call or even give an error message. It just sort of goes away and leaves me staring at the Today screen.

    The weird thing is, this all happened to me AFTER a hard-reset. I had been trying out tons of random programs and tweaks to get my WX "just right." I seemed to have settled on what I wanted to keep on my phone, and decided to load up just the things that I wanted from scratch... but now I'm sitting with a stock WX with only the SMS-threading applied, and am stuck with this weird voicemail issue. Sure... holding down "1" works, but its still annoying to have lost this soft-button functionality. Given that several of us are running into this problem, surely SOMEONE has a suggestion (other than the obligatory hard-reset, or course)????
  8. #28  
    Great. Now this is happening to me too. Nothing like bringing back an old thread where there's no solution, right?

    I did a hard reset then a restore to no avail, so something's got to be interferring with it.
  9. #29  
    kaiguy - mine is never there after a hard reset - if you're referring to the "listen" button not working, try this:

    Download PHM Registry Editor

    open it and navigate to HKEY_CURRENT_USER/System/State/Messages/vmail

    If you click on vmail, you should see a value in the window on the bottom of your screen; something that says VMailNumber. This should be your phone number (1234567890). If there's a different value, click on it, and replace it with your phone number.

    In my case, the key didn't even exist for some reason, so I had to create it. If that's the situation for you, just do this:

    Click edit
    New String Value
    Enter VMailNumber (instead of new value 1 or whatever) and your phone number in the other field
    Click ok

    I keep having to do this. Ugh.

    Hope it helps.
  10. #30  
    Alien! That did the trick. I wonder how this got lost in the mix! I never had this problem before.

    If this always happens to you, what about creating a .reg file to simply load up that value. You could keep it on your SD card and have it at the ready for whenever you need to do a hard reset. Only problem is I don't think PHM Registry editor has that option to incorporate it. Resco does, however. I think I might try to do that myself.

    Thanks again for your help!
  11. #31  
    That is a great idea, kaiguy - I may do that very thing...
Page 2 of 2 FirstFirst 12

Posting Permissions