Results 1 to 6 of 6
  1. socal sxt's Avatar
    1 Posts
    Global Posts
    89 Global Posts
    Is anyone using Copilot live and the 700w yet, I am having a hard time deciding which GPS set up works the best with 700w.
  2. c0w
    c0w is offline
    c0w's Avatar
    21 Posts
    i'm using the Globalsat BT-338 GPS receiver with mapopolis and it works great! check out my review.

    Devices: HTC Mogul, Treo 700wx, Motorola Q, mpx200
    Accessories: Spectec SD Wifi card, Piel Frama case, Globalsat Bluetooth GPS Receiver, Socket Go WiFi! E300
  3. #3  
    Yes, I got CoPilot Live for my 700w a little over a month ago. Works great along with the GPSlim-236.
  4. #4  
    I'm another happy Copilot customer. Just took it to the Smoky Mountains for the weekend and it did great.
  5. #5  
    I think this thread should be merged with this one:

    It's in the WM5 Apps forum, which means Treo 700w only.

    As for Copilot - I have been very disappointed with it, and returned it. The main problem is that it simply failed at the most basic task you expect of a navigation system, i.e. navigation. It routinely directed me the wrong way down one-way streets. The last straw, however, came when I was traveling from Salem, NH to Boston, MA, and it instructed me to (1) take I-93 North, then (2) 1.5 miles later, take a "left exit" onto I-93 South. That turned out to be an emergency-vehicle-only cut in the median.
  6. #6  
    BTW I've also tried TomTom and Mapopolis, and am now using TomTom. Mapopolis does not integrate well at all with the 700w. TomTom is decent, not great. In particular, it does not have text-to-speech capabilities. But at least it works well on the 700w (even mutes itself automatically if you are on a call) and gives accurate directions. I am waiting for version 3 of iGuidance (due in June/July), which from the other thread I mentioned looks like the likely best GPS for the 700w, unless the next version of Mapopolis comes out soon too. Ihave found Mapopolis to have the most accurate navigation of the GPS apps I've tried.

Posting Permissions