Results 1 to 11 of 11
  1.    #1  
    I'm a Sudoku addict and have subscribed to Astraware Sudoku. The problem I am having is that the 5 way scroll stops working. The only way I can find to get it working again is to uninstall the program and install it again. I upgraded to the latest version 1.3 and this seemed to work ok for a while, but now the newer version is doing the same thing. Everything else works fine, just the 5 way stops functioning to move around the puzzle. It works when you go into the menus. I have checked with Astraware and they don't know why the 5 way stops working. Has anyone else experienced problems with the 5 way or more importantly, does anyone have a fix for this short of re-installing the program.

    Also, are there other Sudoku addicts that have found a good Sudoku application that works on the 700W? I like the fact that Astraware has the ability to download daily puzzles, but I am getting tired of this scroll button issue.

  2. #2  
    I am an Astraware Sudoku addict, and I too have run into this issue. Unfortunately I have not found any workaround to fix the 5 way once it stops working - my solution is to keep the cab file on the device and reinstall it directly.

    I don't have any real proof of this, but it Appears that it takes a lot longer for the 5 way to stop working if I install it directly to the device memory instead of to my storage card. So I would suggest trying that if you currently install to an SD card. It also seems like the 5 way stops working if there are a lot of programs loaded (memory issues again) but I haven't found any way to consistently cause it to stop. But once it stops, its stopped - soft resets do nothing for it.

    And, just in case Astraware is monitoring this - I noticed another problem with the latest version. When the previous version would go to get the puzzle of the day, as long as the phone portion was on, the program would connect to the internet automatically and download the puzzle. In the latest version - you have to actually be connected To the internet before it will download the puzzle. So, I end up loading Internet Explorer, let it actually connect to the internet, then bring up Sudoku and have it download the puzzle. (And then go back and close Internet Explorer and hope I didn't do anything to cause the 5 way to stop working! )
  3. #3  
    Just a note that I'm not having any "technical" problems with the Palm version of the program which I have had since release....some minor "playing" issues most of which have been fixed.
  4.    #4  
    Thanks. At least I am not the only one this happens to. I've tried installing it on my card and in memory and the scroll stops both ways. And like you, I have not been able to pin point any one reason why it happens. I did take your suggestion and put the cab file on my storage card and practiced doing an install from there. It works. I also have my reg # saved as a note so I can get to it when I re-install. Guess having to do a reload is going to be a fact of life.

    I have noticed the same thing about downloading the puzzles from the internet. I also have to run IE first and then I can download the puzzle. If I try downloading the puzzle first, it cannot find the connection. Funny, I did not think of that as a problem, but you are right, the older version did not do that. So I guess it is an issue.

    I have tried several other Sudoku programs, but I find that Astraware is the easiest to use one handed, that is, as long as the 5 way doesn't spaz out. (And the fact that I paid for this one, so would really not like to have to pay for another one.)

    Thanks for your reply.
  5. #5  
    I didn't realize you could use the 5 way for Astaware Sudoku, but now see that I have the same problem with that.

    Re: the downloading problem. I emailed Astraware about that back in early April, so they are certainly aware of that problem. Their at that time response was:

    "We are not able to actually test this part ourselves as we do not have a Treo 700w with an actual active Phone Data Connection, So the automatical connection we were unable to confirm upon the puzzle of the day request. Now we do have this information we can try and rectify this problem in the next update to the Sudoku title."
  6. #6  
    stippett - I forgot to mention that I too have my registration number also stored on the device! Although, lately, its taken to knowing who I am without having to enter the number. Weird. (I haven't gone poking through the registry to if it is retained there or not).

    derene - Thanks for the downloading info. Since it Did work on the previous version, hopefully they will be able to figure out what changed in the current version and fix it in the next release.

    The only other problem I've occasionally had with it, is Sometimes I would hit a button (mostly going into "notepad" mode), and the whole program would just close out from under me. I re-launch it, and I'm back at the beginning menu screen - my current puzzle is just Gone. This happened quite a few times with the previous version. When I've noticed it happening (which is rare) in the current version, its generally right around the time that the 5 way stops working. So when it blows out like that, I simply reinstall. I try to do the daily puzzle each day, and I would say I end up reloading it probably once every 3-4 weeks, so at least for me it isn't every day.

    This is the only Sudoku program that I have tried, and I agree, once you actually spend money on it, I'm hard pressed to buy another one! Overall I think its a good product, I hope they can fix these quirks.
  7.    #7  
    Just to let you know, because of the 5 way issue, I have almost given up on AstraWare Sudoku several times. I have downloaded and tried all of the leading SudoKu programs that will work on the Treo700W. If the program did not let me use the 5 way scroll, I deleted it automatically. (I personally hate using the stylis). The only program that came close to AstraWare was Resco Sudoku. The two things I did not like about it was that the pencil marks are tiny, tiny, tiny and very difficult to see. The other thing that has me spoiled is the daily puzzles. Resco does not have anything like that. I'm afraid that once you get used to AstraWare Sudoku, nothing else will do. Hate to sound like a commercial, but that is just the way it is. So, I have been putting up with the re-installing.

    Also, I asked about being a beta tester for AstraWare. Bottom line, to be a beta tester involved way to many hoops and legal forms, so I choose not to pursue it. Besides, I am not playing a bunch of games (to old), I just wanted Sudoku to work.
  8. #8  
    If there are any developers following this forum, would someone write a good sudoku app for the 700w? The current apps just do not make it.
  9. #9  
    Hi folks,

    Having just popped along to the foum today to answer someone else's query on the Treo 700p, I couldn't help noticing this issue as well.

    From the descriptions above, I think I have some ideas on what could be behind the 5-way controls no longer working in Astraware Sudoku, particularly since you mention that the game also keeps forgetting your registration code!

    This has been a fairly knotty problem, around in some form or another since the days of Pocket PC 2002 (which was when I first encountered it), and for what it's worth, the problem is as rare as it is mysterious - for some reason, and with no particular pattern or cause, some Pocket PC devices will suddenly "forget" a portion of the registry associated with a game. It's never been limited to a particular game, device, model, OS version or manufacturer, and there've been cases where it will appear once and never again, and cases where it just won't stop happening. Sometimes, I've been able to track it down to an anti-virus application on the device, but more often than not it has remained a mystery, and either stopped occuring or we have worked out something else acceptable to the customer

    All of this is bad news of course, since it doesn't give any indication of a fix (and strictly, this problem is still a big unknown, despite the amount of time I've spent investigating and trying to reproduce it!). However, while working on some recent projects, we came across a small bug which *could* cause this to occur - the conditions seem about right, and the results which it could cause equally similar to the problems above that we may have stumbled on the cause. The bad news here is that it's not something you can apply directly, but it will be incorporated into the next update to Astraware Sudoku for Pocket PC, and things should "just work" from then on.

    I hope that helps, and if you still have any questions, feel free to drop an email, or I'll try to keep an eye on this thread!

    Warmest regards,
    Technical Support
  10. #10  
    On Friday I downloaded the latest version of Astraware sudoku, Version 1.30.

    It appears to fix the five-way problem and also defaults to num-lock for keyboard use.
  11. #11  
    Quote Originally Posted by jschwartz73 View Post
    On Friday I downloaded the latest version of Astraware sudoku, Version 1.30.

    It appears to fix the five-way problem and also defaults to num-lock for keyboard use.
    Actually Version 1.30 was released before this thread really got going (where the 5-way problem existed). Version 1.30 does default the num-lock which is nice (or maybe accepts the char keys also and treats as numbers, where "r", "R", and "2" are all treated as "2", I'm not sure).

    But - since my last post here, I have Not ran into the 5-way problem. But I attribute that to Really watching my memory usage and routinely cleaning mem, killing apps, and soft-resetting when I get to about 11 Meg left that I can't recover. Hopefully per their last post Astraware has fixed this and from my experience it seems to be memory related somehow.

    My current biggest issue is still the change from the previous version to version 1.30 where I now have to manually make an internet connection on the phone (run IE, run Outlook, etc) before DL'ing the puzzle of the day. This changed between versions so hopefully Astraware will be able to find this fairly easily and put it back.

    While I'm here!, , I'll add one more feature wish!! I like the "notepad" mode so that when I get to where I need to start guessing, I can use the stylus and write in a number, and cross out the associated pencilmarks that number eliminates. That way I work my way down until I either run into a conflict if I guess wrong, or finish the puzzle if I guess right. I then go back to "normal" mode and fill in the puzzle. (I could just use the "flag mistakes" when I guess, but I'd rather figure it out myself). Anyhow - one thing I would like to see is while in "notepad" mode - Still ALSO allow keyboard input. IE, switch modes between "pencil marks" and "normal", and let me use the keyboard to add my guesses on top of the dimmed "real" puzzle. (If That makes any sense at all). And the "clear all" button in notepad mode would still Zap all of these, the "erase" button would allow me to clear individual notepad mode guesses/pencilmarks etc. This way - I could use the "notepad" mode to manually work the puzzle - but Still not have to use the Stylus. Hopefully Astraware is still monitoring this thread, and can make sense of what I just suggested!

Posting Permissions