Results 1 to 9 of 9
  1.    #1  
    Anyone have a clue why I would be having this problem using PDANET with my Treo700?

    Client: Window XP SP2

    My Treo700 loses network conectivity after I successfully installed the Pdanet app on my laptop and Treo700 - with my Treo connected to my laptop. Using the USB cable to connect Treo700 to my laptop. When the cable is connected, my Treo doesn't even attempt to perform the EVDO connection call when I try to access a public internet website. As soon as I disconnect the cable, the problem goes away.

    I tried uninstalling and reinstalling the pdanet software on the Treo, but during the uninstall I receive a prompt stating the "PDANET application was not completely removed from your system, Do you want to remove the application from the Start menu, YES, NO?" I clicked YES.

    I've uninstalled the PDANET software on my laptop and "partially" uninstalled the app on my Treo and I don't lose connectivity on my Treo when connected to my laptop. Very strange problem.... Reinstalling ActiveSync and PDANET doesn't fix the problem.

    Any help appreciated.
  2. Glenn95's Avatar
    56 Posts
    Global Posts
    70 Global Posts
    I had the same problem and there was no fix. I got refunded by June fabrics.
  3. #3  
    I am not having trouble on two laptops as long as all Activesync activity has completed before I connect via PDANet.
  4. #4  
    I tried to replicate the problem.

    I connected via USB, AS started its business and PDANet popped the little window in the lower right corner of my laptop.

    I did not click to connect PDANet.

    I then opened PIE and went to the default Palm page. The 700 did not use EVDO, but connected through AS and my laptop's internet connection (in this case wifi).

    If I disconnect the wifi on the laptop, still with AS connected, the 700 never tries to use EVDO and just reports it can't connect.

    I then tried to kill AS on the 700, which told me it was busy, and it still does not connect using EVDO.

    I pulled the USB cable and then the 700 uses EVDO.

    I then removed PDANet from the 700 and the 700 still tries to use the laptop internet connection when AS is connected. Pull the usb cable and it uses EVDO.

    This seems like an AS issue.

    Is there a setting in connections? I'd like control over this behavior.

    Now I have to put PDANet back....wonder how long that will take!
  5. #5  
    Everything you wrote sounds like the usual USB AS problem. I didn't read that AS finished its business. If you can't get USB AS to connect and finish, PDANet will never work. It is working for me since I don't let AS do anything but connect via USB. Every now and then, I'll go in and enable contacts/tasks/notes for an IR or BT sync but I don't do anything but connect via AS, otherwise, I'll need to do a hard reset to clean up my AS woes.

    Unfortunately, PDANet depends on USB AS working properly.
  6.    #6  
    Beryl, I think you're correct. Let me clarify the problem I'm trying to solve. I'm trying to get my laptop to connect to my Treo 700 using ActiveSync and PDANET for public internet access utilizing the Treo's EVDO/1xRTT access. I had this setup working the first day I installed ActiveSync and PDANET, but something happened the next time I tried to use it and it's been failing ever since. I'm a newbie to Treo's and I thought the fact that I loose connectivity on my Treo when I connect it to my laptop via USB cable was the reason why I couldn't access the internet on my laptop using the Treo. What I found out with JuneFabrics support is the Treo will alway try to use your laptop's network card instead of using its EVDO/1xRTT access. I had all of my laptop's ISP network interfaces disconnected when I was testing and that's why my Treo was not able to access the Internet. When I enabled my laptop's ISP network card, my treo was able to access the internet via my laptop's ISP access. But my real problem is trying to figure out why my laptop can not access the internet using the PDANET on the Treo700. I let ActiveSync connect and click on Cancel to prevent Syncronization. Then I startup up PDANET and make a successful connection. I try to ping a public internet IP address from my laptop without any luck. From IPConfig, windows mobile interface on my laptop is assigned an ip address of and the DHCP Server address is I'm able to ping the .1 address from my laptop. Traceroute to public internet address fails. My routing table looks a little strange. I don't a default route:

    Network Destination Netmask Gateway Interface Metric 1 30 30 30 30 30 30 30 30 4 1 3 1 1 1
    Persistent Routes:

    Not sure if the lack of a default route may be my problem.
  7.    #7  
    Beryl, I think I did attempt to do an AS sync and it disconnected at some point. I think you are correct about the source of the problem. I guess I need to figure out what I need to do to correct my problem.... A hard reset would mean what?
  8. #8  
    Something funky happens with AS over time and only a hard reset seems to clear it up. Right after a hard reset, it should only take a minute for AS to finish "looking for changes" and start syncing.

    It also appears that you can use Sprite to backup first, hard reset and then do a Sprite restore and not loose anything. Sprite is pretty good about putting everything back the way it was except for the USB Activesync problem. A guy named "Frank" explained it best in this thread:

    It is best to avoid doing any USB Activesyncs. I'm about a week away from having to do another hard reset because it takes about 15 minutes for my AS to finish now.

    I think Junefabrics should redesign PDANet so that it doesn't depend on AS.
  9.    #9  
    Thanks Beryl,

    Found some more interesting info:

    For about 2 seconds after the "PDANET Connected!" status appears, my laptop is able access the internet via the Treo700. After that, I lose connectivity. I checked out the routing tables on my laptop immediately after I see the "Connected" status and again when I can't get to the internet. Definitely see a routing table difference..... Not sure what could be causing this. Here's the routing tables:

    Immediately after "PDANET Connected!" status C:\>route print ================================================================
    Active Routes:
    Network Destination Netmask Gateway Interface Metric 1 1 50 50 1 30 30 30 30 30 30 30 30 1 3 1 4 1 150007 1 1 1 1
    Default Gateway:
    Persistent Routes:

    When I lose connectivity, about 7 seconds after the "Connected!" status appears:

    C:\>route print
    Active Routes:
    Network Destination Netmask Gateway Interface Metric 1 30 30 30 30 30 30 30 30 4 1 150007 1 3 1 1 1
    Persistent Routes:

    Going to take your recommenations on the hard reset. My first experience using the Treo has not been a pleasant one:-(

Posting Permissions