I bought an Arkon DM575 GPS Cradle from TreoCentral for my Verizon Treo 700w.

When I plugged it in today and tried Mapopilis and Tomtom, neither recognized the GPS.

There was a piece of paper with the Arkon that said:
GPS Setting
Baud-Rate: 19200
COM-Port: 1

I tried this setting, and many others, to no avail.
I messed around with Windows Mobile 5.0's GPS settings, disabled them, and everything else you could think of.
Mapopolis says that theres is nothing connected to the COM-port's, and lets me do a software reset, but even then it will not work.

I tried to contact Arkon customer support, but all I get is a message machine (great), and there is no more information on their website.

I would assume TreoCentral would test the product before they sold it in their store, so, what am I doing wrong here?

I am going out of town tomorrow and would like to have it up and running by then, but from the looks of it I am going to have to return it and eat the shipping.

Any help is appreciated, im out of ideas.