Results 1 to 4 of 4
Like Tree1Likes
  • 1 Post By Preemptive
  1.    #1  
    Apologies, I see a lot of similar regarding this, but not specific…I’ve been experiencing this for better part of this year. I'm getting 'The security certificate xxxx sent is expired. Connecting to this site might put your confidential information at risk' pop-up when accessing many websites. Most common is ', but getting many others, some of which look very suspicious. I always select 'Do Not Trust', which triggers pop-up again, and when I 'Do Not Trust' again, the pop-up stays until I minimize card. When card is restored, either the page is done, or still loading, and does the routine again and again, until page finishes or I cave (usually 3 or 4 cycles). Should I eventually get onto the site, every time I back and forth through pages have to go through it all again. All Yahoo sites, however, fail to load page when I ‘do not trust’ (not an entirely terrible problem, yahoo being what it has become, but have several email accts I can no longer access from phone). Should I be concerned? Are these attempts to piggyback, or snoop, or simply track for evil marketing purposes? Is there a fix? Thanks in advance…

    p.s. this isn't just an Outlook or Exchange or Server or Corporate or blah blah blah...and it isn't only email, it's most sites I attempt to access, save maybe the most remote (i.e. 400 hits a year on a good year type sites)...if the solution is still the same, please indicate that and accept my sincere apologies for the security certificate ad-nauseum...
  2. #2  
    Same here. There must be something wrong with the certificate "chain" that the browser relies on. The root certificate, or one of the main certificates that the other certificates invoke, may have expired and was not updated by HP.

    This is not the only certificate issue, as you already know, there was a certificate update for Palm cloud cervices (Palm Profile/backups, App Catalog), and a certificate issue with EAS... so the browser issue you and i are seeing seems to be in line with that. I guess we'll have to investigate if all the errors trace back to the same CA (certificate autority, i.e. Verisign, Comodo), and find a replacement cert, perhaps by borrowing from an open source browser
  3. #3  
    I'm not clear if you've tried the solution from Grabber5.0 (not a universal fix). It's step 6 here:
    Guide: Coming (Back) to webOS in 2014, Part 1 | pivotCE

    What email accounts are you having problems with?
    Remy X likes this.
  4. #4  
    Quote Originally Posted by Preemptive View Post
    I'm not clear if you've tried the solution from Grabber5.0 (not a universal fix). It's step 6 here:
    Guide: Coming (Back) to webOS in 2014, Part 1 | pivotCE

    What email accounts are you having problems with?

    You're spot-on! I just didn't know about the existence of this fix...

    Step 6: Install the GlobalSign SSL Update.

    Around January 28, 2014 a core GlobalSign SSL certificate expired, breaking Hotmail and accounts, and causing the webOS browser to stop trusting the certificates on many sites. Patch guru Matt Williams (Grabber5.0 on the webOS nation forums) quickly came up with a fix, putting together an updated certificate package to fix this problem, and making it available for download.

    To install this update:

    Download the package from Matt’s site and save to a location of your choice:
    Plug your device into your computer, and when asked if you want “USB mode” or “Just Charge”, pick “Just Charge”.
    Launch WebOS Quick Install by double-clicking on the file that you downloaded.
    Make sure that your device shows up in the upper right hand corner. (If this is your first time running the tool, you may be asked to install novacom drivers. These are what the tool uses to communicate with your phone. In that case, just follow the prompts).
    Click on the green plus icon on the right hand side of the window, navigate to the file that you downloaded, and hit select.
    Click the “Install” button, and wait for the tool to install the package. When it is done, the list of files to install will be empty, and you’ll be good to go.
    If you need more detailed information, you can check out the original thread here.

Similar Threads

  1. server's security certificate is not a trusted certificate
    By cswilliams30 in forum webOS Synergy and Synchronization
    Replies: 8
    Last Post: 02/28/2014, 02:48 AM
  2. Persistent Trust Certificate Issues
    By grep123 in forum webOS Discussion Lounge
    Replies: 3
    Last Post: 02/23/2014, 04:23 PM
  3. Website Security Certificate issues
    By mitchgixer6 in forum HP TouchPad
    Replies: 6
    Last Post: 09/23/2011, 11:54 AM
  4. Security Certificate Issues
    By tomjohn in forum HP TouchPad
    Replies: 5
    Last Post: 08/23/2011, 12:23 PM

Posting Permissions