Results 1 to 5 of 5
  1.    #1  
    To make the story short, I was studying abroad this summer and missed out on the ability to install the App Catalog Update. I normally use an iPhone but sold in preparation for the 5S and am using my last phone (Pre) for a week.

    I have used Meta Doctor to upgrade my Pre to 2.1. I have recreated a new Meta Doctor as of today thinking that there might have been an update with the files, but continue to have these issues.

    The phone is activated and attached to my phone number; I can make phone calls and send texts. I continually get the error to enable network data, which is already enabled, and am fine using WiFi. I error I receive says "Your phone could not establish a data connection (67)." Data Roaming is also enabled. Is this problem because my plan includes "Premium Data" that was needed for the iPhone?

    I tried to rollback my date manually to July 1, 2013 and update the root certificate but continually get errors no matter what date I do (I have even tried 2012). My app catalog version is 2.0.20900 and cannot update it either.

    I do not know if both problems are related.

    I have googled like crazy and searched this forum to see if there were any public IPKs of the update or app catalog but found nothing.
    Last edited by DiGG; 09/14/2013 at 01:28 AM.
  2. #2  
    Quote Originally Posted by DiGG View Post
    ...I do not know if both problems are related...
    The root certificate is authentication to access HP servers. It should have NOTHING to do with your cellular data.

    I am under the impression that "special" iPhone data plans from certain carriers are not transferable to devices running a different OS. Check with your carrier for more on that.

    So far as the certificate update goes... Many users have gotten a false negative, an error that the download didn't work when, in fact, it has.

    You can try to manually verify the certificate.

    If you have the Internalz Pro file manager ( you can use it to navigate to the certificate and open it to read the expiry date...

    If you have WOSQI - a.k.a. webOS Quick Install - ( you can use it to pull a copy of the certificate to your computer for examination...

    Here is the relevant location to navigate to/pull from. /etc/ssl/certs/trustedcerts/PalmWebOS.pem

    If your cert is not up to date, try back here or look in the TouchPad forum at the many threads there for tricks getting the cert to install.
    Lumia 1520.3 (the Beastly Unicorn): Windows 10 Mobile

    Windows Central Senior Ambassador

    Mobile Nations Devotee
  3.    #3  
    Yeah, I found that thread while searching and unfortunately, the certification is the old one and expires July 23rd 2013.
    Last edited by DiGG; 09/14/2013 at 05:57 PM.
  4. #4  
    Any luck getting it to update the cert (I assume WiFi is working)???
    Lumia 1520.3 (the Beastly Unicorn): Windows 10 Mobile

    Windows Central Senior Ambassador

    Mobile Nations Devotee
  5.    #5  
    Wifi works but the update still fails to install (and it isn't a false negative).

    I've even used Impostah to spoof my activation date to be before July 23rd also but that didn't solve anything.

Similar Threads

  1. App Catalog Certificate update failed
    By techlover10 in forum HP TouchPad
    Replies: 62
    Last Post: 12/20/2014, 11:34 AM
  2. [HELP] App Catalog Update on webOs 2.0.1
    By Marcelo Velazquez in forum Palm Pre and Pre Plus
    Replies: 4
    Last Post: 06/10/2013, 11:14 AM
  3. App Catalog - Download failed - Pre 3
    By maxmin in forum HP Pre 3
    Replies: 5
    Last Post: 10/03/2012, 07:27 PM
  4. App Catalog error (Update WebOS)
    By nodanero in forum Palm Pre and Pre Plus
    Replies: 2
    Last Post: 04/22/2010, 03:29 PM
  5. WebOS and App Catalog update are coming!
    By ms2474 in forum Palm Pre and Pre Plus
    Replies: 10
    Last Post: 09/09/2009, 02:36 PM

Posting Permissions