Results 1 to 4 of 4
  1. zer0nix's Avatar
    27 Posts
    Global Posts
    29 Global Posts
    i followed the directions from here:
    Application:MetaDoctor - WebOS Internals

    downloaded the verizon pre plus .jar from the wiki and put it here:

    unlocked these features in the makefile:

    and i got to this step where i copied and pasted the following make command for this device:
    make DEVICE=preplus CARRIER=verizonwireless all

    and i got this result:
    You have specified an invalid DEVICE and CARRIER combination make: *** [all] Error 1
    so now i'm kinda stuck... help?

    PS: is the most stable os for this phone? i want to be able to leave this device on for months, either recording videos, making calls, sending videos or recharging on the dock. i intend on handing the device off to a senior citizen, so the more stable it can be, the better.

    PSS: somehow, i was unable to retrieve any files off of the phone. it shows up as 'palm pre'
    ... hey waitaminute. i ordered a pre plus. why is it showing up as a palm pre? is this normal? is there any other way to check the phone's version? it does say verizon on the mirrored backplate that is revealed when the device is slid open... hmm. i'll try opening it up after this is posted.

    PSSS: i'm doing all of this from a usb install of linuxmint 11
  2. #2  
    Meta-Doctor documentation clearly states not to run scripts from Live Boot mode...

    You may not have enough space to complete the build.
    Lumia 1520.3 (the Beastly Unicorn): Windows 10 Mobile

    Windows Central Senior Ambassador

    Mobile Nations Devotee
  3. zer0nix's Avatar
    27 Posts
    Global Posts
    29 Global Posts
    it's not a live boot. linuxmint was installed directly onto the usb drive using a cd.

    also, there is 2gb of ram in the laptop and there should be at least 6gb of the 8gb remaining on the flash drive. i don't know exactly how much space is left but i can check (i'm currently back to using a different os; the linuxmint usb is kind of my backup).


    the phone is definitely a palm pre plus. the label behind the battery says p101eww, which is the corresponding code.

    hmm. i wonder what is going wrong.
    Last edited by zer0nix; 10/18/2012 at 12:01 AM.
  4. zer0nix's Avatar
    27 Posts
    Global Posts
    29 Global Posts
    aw sonova*****!

    i just tried the whole process after installing linuxmint 13 onto the hdd (using wubi) and ended up with the same result:

    make DEVICE=preplus CARRIER=verizonwireless all
    You have specified an invalid DEVICE and CARRIER combination
    make: *** [all] Error 1

    EDIT: 'make clobber' didn't help. looks like i'm stuck.

    EDIT: darnit. i really, really hoped i would have this ready by saturday. could someone plz help?

    EDIT: linuxmint 13 was installed using wubi...

    EDIT: as per a bit of guidance from the webos irc channel, i tried changing the carrier to verizon and got this result:

    make DEVICE=preplus CARRIER=verizon all
    make unpack patch pack
    make[1]: Entering directory `/home/ericl/meta-doctor'
    mkdir -p downloads
    Please download the correct version of the webOS Doctor .jar file
    and then rename and move it to downloads/webosdoctorp101ewwverizonwireless- (i.e. the downloads directory that was just created under the current directory).
    make[1]: *** [downloads/webosdoctorp101ewwverizonwireless-] Error 1
    make[1]: Leaving directory `/home/ericl/meta-doctor'
    make: *** [all] Error 2
    very strange. i've downloaded the ,jar three times now. once on the usb install, once more from the wubi install and even once from firefox. i should be getting the right one:

    Verizon Wireless

    Pre Plus

    P101EWW: P7VE0XXXXXXX (Pre Plus on the Verizon

    EDIT: hmm. tried renaming the ,jar webosdoctorp101ewwverizon.jar on a whim and am getting exactly the same error. that prompted me to check to see if i have java installed and according to this link it seems to be working. i don't know what the problem could be, but i'll try digging through the makefile to see if anything comes up.

    EDIT: after rooting around through the makefile, i found this:
    ifeq (${CARRIER},verizon)
    MODEL = p101eww
    DOCTOR = webosdoctor${MODEL}${CARRIER}wireless-${VERSION}.jar
    that means the correct file name should be ...


    and indeed, the .jar that was in the download folder is misnamed as:


    after correcting the name to include the version number and entering the command once again, it seems like things are working as they should. i'll update with more information if i'm successful or thwarted again.

    so, to summarize, thus far i have discovered 2 errors with the wiki:

    first of all, according to the makefile, the correct carrier name should be 'verizon,' not 'verizonwireless'

    and secondly, the .jar file is misnamed and needs to be appended with a dash followed by the version number.

    EDIT: what does "Using a 2.0 doctor will wipe your usb partition" mean? does that mean all of the files on the usb drive will be deleted or does that mean something more ominous? i ask because i intend on installing 2.2.4 at some point; i'm doctoring now just so i can access the phone and see if everything works. it should have been an easy preliminary step... lol.

    the irony of all this is that a week ago... or more, i don't remember... i actually noticed that the carrier name seemed to be off ... but i presumed that was simply an artifact of the coding and i shouldn't mess with anything, lest i end up with a bricked phone. someone with admin privileges really should edit the wiki so that future users don't encounter this error!

    aw darnit. i was able to get the doctor to run but then i encountered this error:
    also, i had to enable usb mode.

    the battery is 80 percent charged so it can't be that ...

    well, this has proved to be a stultifying experience.

    EDIT: ah, i never disconnected the cable while enabling usb mode. it now seems to be working. god yes it is finally working after so long...

    ps: this is another step which is missing from the wiki: after changing into usb mode, the usb cable needs to be unplugged for the pc to recognize the device.

    EDIT: HUZZAH! i am now using the phone. damn, this is so cool. now, to download the f105 kernel...
    Last edited by zer0nix; 10/26/2012 at 09:28 AM.

Posting Permissions