Results 1 to 5 of 5
  1.    #1  
    With my Sprint Pre- suffering from apparently failing storage, I decided to swap the comm board into a Vzw Pre+. I followed the instructions on WebOS Internals guide, doctoring straight to 2.1. Once the doctor completed (without error), I signed into my Palm Profile.

    A few minutes after signing in to the profile, my data service stopped working. Nothing I do will bring it back. Wi-Fi works just fine, but 3G won't work at all.

    I don't think it's a hardware issue, because when I re-ran the Doctor, I had the exact same symptom. 3G works just long enough to get signed in to the profile, then nothing. ##786# shows the correct ESN, MEID, MDN, and MSID. PRL Version 60679 - same as the Pre- had.

    Anyone have any suggestions? I'm a bit hesitant to call Sprint, since I'm running an unsupported OS on top of an unsupported phone. Would it be a good idea to try doctoring back to 1.4.5, and if so, should I use the original Sprint Pre- doctor, or create a new one using the WebOS Internals guide for swapping a Sprint comm board into a Pre+?
  2. #2  
    You can now use the "stock" webos doctors. I would try going back to 1.4.0, over the air update to 1.4.5, and see if that helps.
    Palm Pre 2 on Sprint
  3.    #3  
    Thanks. The link to the 1.4.0 doctor on the WebOS Internals wiki is dead, but I'll try 1.4.5 then give Sprint a call.
  4.    #4  
    Sorry, this is going to be a bit long. At least nobody's going to be able to accuse me of not trying to solve the problem myself.

    Tried the default Sprint Pre- doctor 1.4.5, but it failed midway through with "Error Updating Modem Firmware!!" and a phone that wouldn't boot. Did a search on that error message which led me to this thread, which led me to this page in the WebOS Internals Wiki.

    In order to get a useable system, I re-ran the 2.1 doctor I had made. I noticed an additional symptom I had forgotten about until it happened again. After the doctor completes, the phone restarts as normal, then goes through the activation and to the palm profile sign-in page. There's no EV icon, and the sign-in fails. I powered off the phone, then started it back up and the EV icon is there. Profile sign-in succeeds, but as described above, EV goes away almost immediately after the sign-in is complete.

    At this point, I do have a useable phone, as described in my original post. Wi-Fi works, but no cellular data. From this point, I follow the modem firmware flash procedure described in the Wiki, and from all apparent signs, it completes successfully. Interestingly enough, the modem firmware contained in the Sprint doctor file is an apparent downgrade, described in one location as version 1.6 and another as 535. The 2.1 meta-doctor had left it at 1.7 and 557. At this point, I'm thinking that perhaps the 1.4.5 doctor was failing because it refused to overwrite a newer modem firmware, and now that the firmware has been downgraded, I'll be able to doctor back to 1.4.5.

    No such luck. The doctor still fails midway through, same "Error Updating Modem Firmware!!" This time, however, instead of booting to the "Please contact Palm Support" screen, I do get as far as the Profile Sign In screen, again with no EV icon, just like I had with 2.1. Power down the phone and restart it, now I've got EV. Sign in to the profile and reboot, and EV seems to be sticking around longer than on 2.1.

    I check Device Info and note that the modem firmware shows CC1.6(535), the downgraded version I flashed on from the Sprint Doctor. I run the quick test and everything passed.

    At this point, I'm still a bit leery, for a couple of reasons. First is the fact that the Sprint Doctor failed with the Modem Firmware Update error. Second, data still seems a bit flaky. The EV icon comes and goes, even when I've got a decent signal. Third, the phone preferences screen is missing the PRL Update button.

    I'd appreciate any insights anyone may have on this mess. But at least at this point, my phone is running a stock OS, so if the troubles persist, I can at least give Sprint a call.
  5.    #5  
    Found the problem!!!

    Several of the threads describing similar situations mentioned the flex cable, so I figured it was worth a shot. Disassembled my old Pre-, salvaged the flex cable, and put it in the Pre+. Had EV icon when I first started it up. I'm installing the default Sprint doctor now, to make sure it works, with plans to re-doctor to 2.1 assuming all goes well.

    A few things make sense now, and a few things are still confusing. I understand why the Sprint Doctor would fail while installing the modem firmware, but I don't understand why every time I used the WebOS Internals Modem Firmware update, it apparently succeeded. The missing PRL Update button makes sense because it's only present on Sprint devices, and all carrier-specific stuff is done after the modem firmware flash. Since the Sprint Doctor was failing on that step, it never ran the carrier-specific stuff. I also don't understand why, after doctoring, I would reliably get EV for just long enough to sign in to the profile.

    Finally, a tip for anyone needing to swap a flex cable: If you're following the tear-down guide on iFixIt, don't remove the keyboard bezel. It's not necessary to take it off if you're just changing the flex cable, and it's a real pain to put back on. Fortunately I disassembled the old Pre- first. I never did get it back on right - can't close the slider - but the rest of the phone is dead so it doesn't matter.

    Final note: in the time I took writing this up, the 1.4.5 doctor completed successfully with a good EV connection after boot. On to 2.1!

Tags for this Thread

Posting Permissions