Results 1 to 9 of 9
  1.    #1  
    My Sprint Pre Minus has started getting stuck in headset mode even when I haven't had earphones plugged in recently. None of the tips I've read about for "fixing" this work consistently. I'm getting pretty sick of it, frankly. No one has been a bigger booster for WebOS than I have over the past two years but is it really too much to ask that my phone be usable as a phone? Being able to hear a call is pretty fundamental to a phone's operation. And not being able to hear the person on the other end when I answer my phone is very, very frustrating.

    I am beginning to feel like this is the last straw. Until recently I swore that if the Pre 3 didn't turn up on Sprint I'd switch carriers to get it. Now I find myself more inclined to consider jumping ship to another platform. It has pained me to see WebOS's natural advantages all frittered away as time was lost and customer loyalty was squandered, but there it is.
  2. Boregardo's Avatar
    16 Posts
    Global Posts
    22 Global Posts

    Have you tried the graphite powder trick from the linked thread? I was in the same boat a while ago. I had tried rubbing alcohol, ghastly headset, and other tricks with no success. Graphite powder worked immediately for me. Didn't even have to go out and buy anything. I just took a pencil to some sandpaper and poured it in.
  3. #3  
    rubbing alcohol dipped qtip swab w most of the cotton removed. I rammed that into the headphone jack a couple times and so far so good.

    or try ghastly headset application
  4. #4  
    Quote Originally Posted by cyberprashant View Post
    rubbing alcohol dipped qtip swab w most of the cotton removed. I rammed that into the headphone jack a couple times and so far so good.

    or try ghastly headset application
    This qtip/alcohol trick has worked for me, too. I tried it a month ago and the problem has never returned.
  5. #5  
    I had this problem on my Pre+. When I contacted Palm about it via online chat, they told me I need to take the Palm standard headphones and plug them in and out of the device 10 times. I asked the tech if they specifically had to be the Palm ear buds and he said they did.

    I tried it and was successful. Good luck!
  6. #6  
    I used to have this problem a lot and what I found works really well is putting in a set of headphones and, here's the trick, pull them out but lean the headphone jack forward towards the front of the screen. I think the mechanism that triggers the phone to recognize a set of headphones is located at the back of the opening. When you pull the headphones out and lean it forward, it kind of hits the mechanism and knocks it out. Another user suggested it a while ago and I started doing it. Every time I put headphones in, I pull them out that way and I haven't had the "stuck in headset mode" problem since. And that was a good 6 or 7 months ago.
  7. #7  
    get ghastly headset app here - install using webos quick install or preware (email it and open in double click it on your phone and preware will install it).
  8. #8  
    I bought a pre + from someone who claimed the earpeice didn't work but speaker phone was fine. Turns out it was stuck in headset mode. I used a qtip and alcohol and it worked instantly and has been fine ever since.
  9. chris42's Avatar
    170 Posts
    Global Posts
    171 Global Posts
    I had the same problem with my Pre2 and send it in for replacement. Now I use a cover for the plug to prevent pocket lint of getting in again.
    You need to cut off the silver piece, but then it works fine.


    P.S.: I would order a few, it is easy to loose. ;-)

Posting Permissions