Results 1 to 11 of 11
  1.    #1  
    I turned my phone on tonight, and it will not establish a data connection. The problem is not Sprint's as I have another phone right next to it which is working perfectly fine. I did not install any apps/patches immediately prior to this.

    I get this error (also see attached image): Your phone could not establish a data connection (67).

    I tried everything I can think of. Device restart. Battery pull. Network Services>Data Usage [on/off]. Homebrew Application called "Data Toggle". Airplane Mode [on/off].

    Is there anything else for me to do other than visit the doctor??? Is there any way for me to confirm if this is hardware or software?
    Attached Images Attached Images
  2. #2  
    Mine did that about a month ago. The radio probably failed. Back everything up before you try anything. Also, without a data connection, you probably shouldn't try to use the doctor. If you have Sprint protection, and are close to a repair facility, they will replace your phone (they had to order one for me, but it came in the next day).
  3. #3  
    I think you can fix it without doing a doctor. Check the phone offline thread.
    Quote Originally Posted by rwhitby View Post
    We always prefer that people donate in response to tangible items they can use today, rather than for intangible promises about the future that may or may not be possible to achieve.
  4.    #4  
    Quote Originally Posted by Jakeeeee View Post
    I think you can fix it without doing a doctor. Check the phone offline thread.
    Can you be a bit more specific? Which thread, which solution?

    EDIT: I found what you mean, it's here:

    I'm reading up on the info now.
  5.    #5  
    The information here ( ModemFW Flash - WebOS Internals ) didn't help my problem. It is not that I don't get any cell connection. I get a few bars of voice, but NO data. Neither EV nor 1X. See the image attached in the OP.

    I also tried restoring my data using ##3282# and my MSL code, but that didn't help either...
  6. #6  
    I got the same problem as you yesterday Apple! The funny thing is that i never had anything like this happen before. EVER. Wifi and EV were both fried!

    Do you overclock your phone by any chance?

    My phone came back and is working again so I will update if i find out what it was
  7.    #7  
    My WiFi is not fried, it's working fine, but my 3G/2G connection is still not back. I am overclocked, but it's been like that for months and months, so I doubt it's got anything to do with that.

    I think I can remember when it happened, but I don't know if it's related. I was rebooting the phone WHILE it was getting back signal from an Airplane Mode switched to ON. So it could be I interfered with the process of bringing the Data back and that's what blew it...
  8. #8  
    Same thing happened to me a few months back. I tried for days, and it never came back and I'm a sprint tech hahaha, you'll probably need to get it replaced like I did.
  9.    #9  
    I just doctored with a fresh "test-meta-sprint-pre-2.1.0 script" and the process went smoothly as far as creating the JAR...

    ...But my phone reboots to an endless spinning wheel on a blue background. I can see the voice signal and the wifi signal, but I see no data signal.

    I don't know what all this means, but I'm giving all the facts here so maybe someone can give me instructions on how to continue.

    Thanks in advance!
  10. #10  
    I say new phone again :/
  11.    #11  
    OK! Saga's over!

    The original problem was with a "slight" change my cellphone agent made on my account, which caused it to need to provision. The provisioning didn't go through properly, but in the 2.1.0 metadoctors for the Sprint Pre the option to trigger a refresh is missing:

    Quote Originally Posted by WebOS 2 Upgrade wiki
    After applying 2.1.0 to a Sprint device using this method, there is currently no known way to update the PRL. There are permissions issues, and the conventional "Update Profile" and "Update PRL" from the Phone options will no longer work. The provisioner service binary from the Sprint 1.4.5 doctor does not work on webOS 2.x, so a version of that service for 2.x is required for this to ever work. It is not expected that this situation will change before Sprint releases another webOS phone running webOS 2.0 or above.
    So I lost my ability to access the internet.

    After that, I decided I need a phone till I straighten this out, so I activated another ESN for the time being.

    This morning I ran to the Doctor, and posted above hat I still couldn't get it to work, BUT THAT WAS BECAUSE I HAD ANOTHER PHONE ACTIVATED, so this one couldn't finish activating!!!

    Now after all's said and done, I am now in the process of restoring all my stuff from the built-in backup and then from my Save/Restore backup.

    It was a roller-coaster and it was all my agent's idea of a "slight" change in my account...

    Anyway, thanks ALL for your help, and I hope this can help others in the future.

    If an Admin/Mod would like to close this thread, that'd be fine.

Posting Permissions