Results 1 to 9 of 9
  1.    #1  
    Hi all,

    Recently moved to a Pre+ after my Droid 1 broke. I used to hack the Droid all the time, so I immediately overclocked. After a few days, I made the leap to 2.1.

    On 1.4.5, my GPS was annoying (had to open VZ Nav to activate it or install the "Enable Verizon aGPS patch), but it worked.

    On 2.1, no location services work at all, unless I'm on a wifi network. I've tried the GPS Fix app like the 2.1 wiki says (in many places, on many different attempts, for up to 30 min in a row), but only ever get "GPS Error: Error occurred." I did Ebag333's QPST hack, and tried both GPS servers, with no luck.

    Every location-based program I open just immediately throws an error ("GPS Permanent Error" is a favorite, no matter whether GPS, Google Services or both are checked. No network location, no GPS. It feels less like a GPS problem, now, and more like the software stack just isn't accessing any location information. Is there something wrong with my 2.1 Meta-Doctor file? I compiled it on both Windows and OSX, with the same results.

    I know on Android we had ADB, which could show a log of everything happening on the phone. Is there something like that for WebOS, where I can try to run a location-based app and see the errors and post a log?

    Any help would be appreciated.

    And yes, to preempt your questions, I've tried it with UberKernel installed and uninstalled, before and after the QPST hack, with just GPS enabled, with just Google Services enabled, with none enabled (just to see if it was opposite-day), and with both enabled.
  2. #2  
    My location services work better than before on my VZW Meta 2.1 Pre+. One thing I noticed is I must have google services and gps enabled in order for the gps to work.
  3. #3  
    From the later posts in EBag's thread, I think the difference is that the Pre2 ships with the standalone GPS firmware enabled.

    I don't think it has anything to do with doctoring your Pre+ to 2.1 though. (the Doctors don't change the GPS firmware, right? that's the whole reason we have to hack it manually) So there shouldn't be a conflict there, in theory.

    When I first performed the Ebag hack on my Pre+, I also got GPS Permanent Errors instead of "Position Unavailable". I went back and disabled the AGPS and AFLT but enabled all of the almanac and autonomous features. After bumbling around for a day outside, eventually the errors went away and my Pre+ was able to get GPS fixes outdoors (but of course it was pitiful indoors).

    A day later, I decided to try the AGPS again, so I performed the hack one more time and used the Verizon-alternate server. It seems to be the same one the Pixi uses (my Pixi+ GPS is working just fine, so I figured it couldn't hurt), and a day later it managed to get consistent fixes and hasn't given me a problem since.

    I think the problem hinges around whether the 2.1 meta-doctors actually change the GPS firmware.

    If they don't, maybe you could try the Ebag hack again and try toggling the AGPS/AFLT options on and off over a day or two.
  4.    #4  
    @peterlemonjello: Yeah, I've noticed that most people say their GPS is markedly improved with 2.1. That's why I'm so confused as to why mine is actually worse.

    @GuyFromNam, twilightomni: I don't think the GPS firmware was changed, since the settings still appeared the same in the QPST client. It feels more like the OS just for some reason isn't correctly accessing location data, though I don't have any good error logs to prove this. Even with dead GPS, I feel like I should get SOME kind of coarse network-based location from the cell towers, right? I mean, it doesn't even pretend to know which hemisphere I'm in—it just errors out immediately every time.

    However, I like the idea of enabling and disabling aGPS just to experiment. I'll try that.
  5. #5  
    The "coarse network-based location from cell towers" is the AFLT (triangulation). If you didn't specifically enable it along with autonomous GPS in the QPST settings, that could explain why it's not working.
  6.    #6  
    I checked all the boxes in the QPST utility like the directions said to, so it should be enabled...
  7. #7  
    I've having the exact same problem. Now GPS only works on wifi! Did you ever figure a fix out?
  8.    #8  
    Funny you should ask, I just had something of a breakthrough.

    It kept not working in Chicago, and I kind of gave up. Nothing would do it, except wifi. I went home for Easter, and joked to myself that "maybe the magical Michigan skies will make it work." I got home, and it did. GPS. Google Location Services. All of them, they all worked.

    Why? I have no idea. Here's what I did:

    1) Turn on wifi to get a location, but can't connect to any networks.
    2) See that I'm getting a rough (100m or so) location lock, don't think anything of it. Turn on GPS for kicks.
    3) Watch my GPS lock on to 3-5m accuracy. Ran all the apps I could to verify, and they all worked.
    4) Turned wifi off, still working. Went all over the city/state, still worked.
    5) Came back to Chicago, broken again... Wait, WHAT?? That's right, I'm back in my apartment, and it's completely borked again. No Google Services, no GPS. I. am. Baffled.

    So I'm going to keep fooling with it, trying it in different parts of the city. Maybe I'll find the magic bullet. Or maybe it's just a sign that I should move back to the Mitten.

    Anyway, try enabling wifi but not connecting to a network to see if that "wakes up" your location services, and then maybe the GPS will follow.

    [Edit: I recently switched from UberKernel to the Harrier AV8B kernel. But it still doesn't work in Chicago regardless of the kernel.]
  9. #9  
    After meta-doctoring my device it does not seem that I can acquire a gps location. I just downloaded NDrive and hoped it would work but with Verizon's terrible GPS system I guess I was wrong. Keep in mind before the meta-doctor my gps was working fine. However each time I would have to open VZ navigator to get a reading.
    1. I have tried to get a location with just gps turned on and google off.
    2. I have tried the GPS fix that is availble and I continue to get either a permanent error or a GPS timeout.

    Does anyone have any suggestions?
    Sent from my Verizon Pre2

Tags for this Thread

Posting Permissions