Results 1 to 8 of 8
  1.    #1  
    Hello everyone,

    This is my very first post, first Palm product and first encounter with webOS. So far I love it, I just have one tiny problem: cannot use it as a phone. Everything else works great, emails, IM, calendar, wifi, data (internet), SMS, etc. however, I somehow managed to render the Phone application unusable.

    First things first:
    0. It's a Pre Plus;
    1. I bought this used, not new;
    2. I am from Romania, but phone was bought & activated on France, SFR carrier as far as I can tell;
    3. The phone was already upgraded to 2.1.0;
    4. I installed Preware on it and installed 40+ apps and patches;
    5. The "ring" switch next to the power button is in the right position (not set to mute);

    1. Cannot dial from the dialpad: I can type, I hit the "green phone button" and absolutely nothing happens. Tried it dozens of time by now, including double click, long click, pinch, punch, whatever :-);
    2. Cannot dial from contacts: according to manual, a click on the phone from a contact should result in an call. On my phone it does not: it results in dialpad popping up and just sitting there doing nothing - no number, no attempt to call, nothing;
    3. Cannot answer calls. Basically, I never see the calls, I can hear the caller ringing, but my phone will not ring. The instant the call is dropped (either cancelled by the user, or "giving up", etc.) my phone will prompt me with a missed call notification. Furthermore, if the screen is black before the call, it will light up or the gesture area blink (so it knows something's going on) but it will NOT show me the call.
    4. Hitting the redial button from the "missed call" notification will just cause that notification go away and that's all. Dialpad will not even show up at all.

    A few minutes ago I was able to further isolate the issue: as it turns out, it is the contacts that are somehow conflicting with the Phone, i.e. if I remove a contact from the list I CAN call it (I still cannot answer calls) by using the dialpad. Which is great.

    Below is the log excerpt from a call with the contact defined:
    2011-03-20T16:47:37.737060Z [713] palm-webos user.crit LunaSysMgr: {LunaSysMgrJS}: Object {"_kind":"com.palm.person:1","_id":"++HTqsfbE+lYy7VM","_rev":1308,"contactIds":["++HTqsfMhd0C3MHL"],"sortKey":"last\tfirst","name":{"familyName":"last","givenName":"first","honorificPrefix":"","honor ificSuffix":"","middleName":""},"names":[{"_id":"51d","familyName":"last","givenName":"first","honorificPrefix":"","honorificSuffix":"","midd leName":""}],"organization":{"department":"","description":"","endDate":"","location":{"country":"","locality":" ","postalCode":"","primary":false,"region":"","streetAddress":"","type":"type_work"},"name":"","star tDate":"","title":"","type":""},"searchTerms":["flast","lastfirst"],"emails":[],"phoneNumbers":[{"_id":"4c4","favoriteData":{},"normalizedValue":"-3172726670---","primary":false,"speedDial":"","type":"type_mobile","value":"0766******"}],"ims":[],"photos":{"accountId":"","bigPhotoId":"","bigPhotoPath":"","contactId":"","listPhotoPath":"","listP hotoSource":"","squarePhotoId":"","squarePhotoP
    2011-03-20T16:47:37.765716Z [713] palm-webos user.crit LunaSysMgr: {LunaSysMgrJS}: at anonymous._formatWithPerson (file:///usr/palm/applications/$400$:$28$) $at$ $anonymous$.&$lt$;$anonymous$&$gt$; ($file$:///$usr$/$palm$/$applications$/$com$.$palm$.$app$.$phone$/$app$/$models$/$CallSynergyContact$.$js$:$367$:$17$) $at$ $Future$.$_maybeDispatch$ ($palmfoundationsVersion1_0$:$132$:$293$) $at$ $Future$.$setResult$ [$as$ $result$] ($palmfoundationsVersion1_0$:$135$:$322$) $at$ $Future$.&$lt$;$anonymous$&$gt$; ($palmfoundationsVersion1_0$:$131$:$426$) $at$ $Future$.$_maybeDispatch$ ($palmfoundationsVersion1_0$:$132$:$293$) $at$ $Future$.&$lt$;$anonymous$&$gt$; ($palmfoundationsVersion1_0$:$130$:$8$) $at$ $dispatch$ ($palmfoundationsVersion1_0$:$140$:$493$), $palmfoundationsVersion1_0$:$133$
    2011-03-20T16:47:37.772033Z [713] palm-webos user.crit LunaSysMgr: {LunaSysMgrJS}: at anonymous._formatWithPerson (file:///usr/palm/applications/$400$:$28$) $at$ $anonymous$.&$lt$;$anonymous$&$gt$; ($file$:///$usr$/$palm$/$applications$/$com$.$palm$.$app$.$phone$/$app$/$models$/$CallSynergyContact$.$js$:$367$:$17$) $at$ $Future$.$_maybeDispatch$ ($palmfoundationsVersion1_0$:$132$:$293$) $at$ $Future$.$setResult$ [$as$ $result$] ($palmfoundationsVersion1_0$:$135$:$322$) $at$ $Future$.&$lt$;$anonymous$&$gt$; ($palmfoundationsVersion1_0$:$131$:$426$) $at$ $Future$.$_maybeDispatch$ ($palmfoundationsVersion1_0$:$132$:$293$) $at$ $Future$.&$lt$;$anonymous$&$gt$; ($palmfoundationsVersion1_0$:$130$:$8$) $at$ $dispatch$ ($palmfoundationsVersion1_0$:$140$:$493$), $palmfoundationsVersion1_0$:$133$
    2011-03-20T16:47:37.773986Z [713] palm-webos user.crit LunaSysMgr: {LunaSysMgrJS}: at anonymous._formatWithPerson (file:///usr/palm/applications/$400$:$28$) $at$ $anonymous$.&$lt$;$anonymous$&$gt$; ($file$:///$usr$/$palm$/$applications$/$com$.$palm$.$app$.$phone$/$app$/$models$/$CallSynergyContact$.$js$:$367$:$17$) $at$ $Future$.$_maybeDispatch$ ($palmfoundationsVersion1_0$:$132$:$293$) $at$ $Future$.$setResult$ [$as$ $result$] ($palmfoundationsVersion1_0$:$135$:$322$) $at$ $Future$.&$lt$;$anonymous$&$gt$; ($palmfoundationsVersion1_0$:$131$:$426$) $at$ $Future$.$_maybeDispatch$ ($palmfoundationsVersion1_0$:$132$:$293$) $at$ $Future$.&$lt$;$anonymous$&$gt$; ($palmfoundationsVersion1_0$:$130$:$8$) $at$ $dispatch$ ($palmfoundationsVersion1_0$:$140$:$493$), $palmfoundationsVersion1_0$:$133$

    What I tried so far:
    1. reboot, with or without the battery off (took the battery off too);
    2. full erase (3 or 4 times already).
    Nothing helped.

    I'm not sure what to do next, if anyone has any ideas, I'd really appreciate it. I really love this device, it's by far the best phone OS I've ever seen.

    Have a really great day everyone,

    Last edited by alexaandru; 03/20/2011 at 01:30 PM. Reason: spelling error
  2.    #2  
    Below are the contents of palm-customization-info, in case this helps:

    # cat palm/palm-customization-info

  3. #3  
    hi alex. Where from romania are you? I would run the webos doctor. I think that will help out a lot.
  4.    #4  

    I'm from Oradea.

    Yes, thought about a full reinstall using the WebOS Doctor, however that has failed too :-(
    I downloaded it from Palm site, everything went great till I reached the "plug in your phone step". I did plug it in, and it never enables the "next" button. It's like it does not recognize the phone. I even put it in "bootloader recovery mode" as explained at webos-internals wiki, Application:MetaDoctor#Once_the_Doctor_is_running,
    hoping that would force it to be recognized, but nothing. It simply won't allow me to go past that step.

    The only thing that I can think of right now is if I could somehow find the previous build (#284) somewhere, so that I can compare each file from the affected applications and see which ones were altered by patches and try to restore them manually. From Palm site however, I can only install the latest WebOS Doctor with the latest build (currently #285).

    Thank you,

  5. #5  
    cool. I like oradea. Been to a handball game there and stayed in the felix international hotel. Hmm sounds messed up. Wish I could help but sorry
  6.    #6  
    What a small world :-) Glad to hear you liked it here :-)

    And yup, it is pretty messed up, I just hope it's recoverable somehow.

    Thanks for trying!

  7. #7  
    Hi I am using Pre3 (ATT) with Malaysia sim card (Maxis). First month, I really enjoy using webos smart phone until I can not make phone call. Other emailing and apps are running great.
    I can not make call with 7 digits and above. 1 to 6 digits is ok but no contact number exist in that range.
    The only time I can make phone call is when someone miss call me and I call back.

    I have tried the following:
    1. Reboot
    2. Full Erase
    3. Webos Doctor #285

    None of the above helps. Any helps or advice will be much appreciated.

    Good days.
  8. #8  
    Quote Originally Posted by alexaandru View Post
    Below are the contents of palm-customization-info, in case this helps:

    # cat palm/palm-customization-info

    Well, I had same situation with my frankenpre2. I believe some of the patches messed it up or combination of patches. If the 2.0.1 or whatever version was already installed I would recommend re-doctoring (that sounded like I'm a doctor) . That fixed my problem. Make sure to save your patches in preware so it's easy to apply them afterwards unless you want to hand pick them and find the bad combination.
    Make backups of the apps dbs with save/restore homebrew app.

    I redoctored mine and all is good but I was trying to install uber calendar after so many patches. No EPR doesn't remove any patches since it says I have none but preware shows them.
    Anyway just remembered that you can save your patch list in preware, run EPR , which will remove all patches and get you to stock doctor. Then reboot and see if you can make calls. That will only prove that patches messed it up but reapplying them might not fix your problem but it might worth a try if you don't want to go the the doc's office
    Good luck.

Tags for this Thread

Posting Permissions