Results 1 to 10 of 10
  1.    #1  
    Ok, so this is what's happening with my Verizon Pre Plus v. 1.4.5:

    I have no media audio, this includes alarms and ringer. Phone audio works fine, and Ghastly Headset indicates that the phonee is correctly switching audio output modes and is NOT stuck in headset mode (i've dealt with that before). I cannot play any media on the phone, youtube and videos both give an "error occurred" message and fail to play. Pandora and streaming audio fail, and the music player skips from track to track and never plays anything. I've rebooted, removed and reinstalled apps and patches, downgraded from uberkernal to standard and back up, pulled the battery, shimmed the headphoe jack, etc etc... It looks like I'm going to have to DR. The phone, but if anyone has any ideas I'd be glad to hear them before I go and wipe my OS. I'm not a coder, but I know my way around the command line and am not afraid of mucking with the linux core, hell worst that could happen is I need to DR my phone right? I'm already as backed up as I can be, but I'm a bit of a nut and just don't want to give up and DR until I've tried everything.

    any ideas? Are we talking driver corruption or maybe a manual prefs edit/repair. NANO is my friend

    edit: after reading some other threads and backtracking my actions I realize this seems to have begun with my fist restart after updating optware's sudo instal. I so rarely restart m phone that I had forgotten that I did that ! I believe these problems are linked to sudo, just not sure how...
    Last edited by Jawzx2; 03/20/2011 at 10:49 AM.
  2. #2  
    pandora uses a different volume control than the music player does. I'm not convinced that you aren't seeing a faulty headset plug (hardware) and possibly some corruption in music files...

    sounds like multiple problems masquerading as one. that would be a great episode of House, btw.
  3.    #3  
    I would buy the hardware error theory, if pandora didn't ALSO fail to PLAY the stream at all, it kicks back a "network connection was not available" error after successfully loading the cover art and song description, and never begns playing the track. Also, phone audio works perfectly. Speaker, earpiece, and headset all behave correctly (though I have no ringer for incoming calls). It seems to me that whatever path/drivers the audio and media use to get to the hardware decoding system are failing. I'm not sure how WebOS handles media, if it treats all media as a stream to an API it could even concievably be some wacked out problem with IPTABLES... I'm willing to dig for this (in the name of SCIENCE!) but I was wondering if anyone has encountered this behavior before...

    ed: ok, new syptom noticed, PDK games do not run. SDK programs that access /media/internal are spotty, some work, some don't... Looks like I've got some weird permissions bug or a corrupted file system perhaps...?
    Last edited by Jawzx2; 03/18/2011 at 05:49 PM.
  4. #4  
    I share your curiosity. I hate doctoring until I know why.
  5. #5  
    I'm sick of doctoring. I think I doctored once, up until 2.1 was released. Since then I've doctored at least 15 times, each time having to redo all my accounts and other crap. Today was a different story, as I got a replacement phone from verizon (which is awesome BTW), so I had to doctor to 2.1 only to find out I have to doctor back to 1.4.5 to delete my backups, which I didn't do and I couldn't do from my old phone because it had signed out of my profile. Then, when I finally got to 2.1, my palm profile was messed up so I had to doctor again.

    Moral of the story: doctoring is a major pain!

    As for the audio problem. I remember finding some files a while back. I'm not sure if or how this file would get corrupted, but it looks like this file is responsible for a buttload of media playback. It would be worth it to at least extract it from the doctor and insert it into your phone.

    Neo Enyo 2.0 Twitter App: NOW AVAILABLE | WON REVIEW
    clearview - clear card app for HP TOUCHPAD
    Wild'n Video Poker - AVAILABLE FOR ALL WEBOS DEVICES! | follow for latest updates - @fxspec06

  6. #6  
    webOS has device diagnostics, which might give you some insight if this is a hardware related issue...

    I believe you get to them from the Device Info app, app menu, Tests, then either quick test, or interactive tests.
  7. #7  
    doctoring is awesome. Why would you want to delete your backups?
  8. #8  
    Quote Originally Posted by Cantaffordit View Post
    doctoring is awesome. Why would you want to delete your backups?
    I had to. Or I thought I had to. I think I used a bad meta-doctor, and it wasn't loading my profile -.- Anyways, I'm starting to think my replacement phone is a bad apple. Strange things are happening. Phone is chugging. I'll give it another few days to see if the kinks get wrinkled out.

    edit: it's probably just my wild imagination
    Last edited by fxspec06; 03/18/2011 at 08:49 PM.
    Neo Enyo 2.0 Twitter App: NOW AVAILABLE | WON REVIEW
    clearview - clear card app for HP TOUCHPAD
    Wild'n Video Poker - AVAILABLE FOR ALL WEBOS DEVICES! | follow for latest updates - @fxspec06

  9. mgmft's Avatar
    199 Posts
    Global Posts
    230 Global Posts
    @Jawzx2: Did you find a solution other than doctoring? I have the same problem with my Pre 2 2.1.0! Another user in a german forum had this problem and did suspect, that MPlayer was the problem. I had installed MPlayer also. Did you have it installed?


  10. lactose's Avatar
    47 Posts
    Global Posts
    480 Global Posts
    I also am having a weird audio problem. The earpiece speaker does not work for calls. But voice navigation, ringtones, and music playback come thru the earpiece speaker (not the back speaker).
    I have tried:
    -inserting corded earpiece jack several times
    -blowing into hole
    -switching between speaker and earpiece while on a call
    -full erase

    If anyone has any ideas I would like to hear them. I would just say the speaker is bad, but it does work, just at the wrong times. I guess it says something that I am still using this limping Pre, when I have a working Droid I could switch back to. Just tryin to make it till someone announces the Pre 3.

    Pre Plus Verizon
    Last edited by lactose; 07/24/2011 at 02:42 AM. Reason: ufo

Posting Permissions