Results 1 to 4 of 4
  1.    #1  

    First of all, I'd like to thank everyone at PreCentral for contributing to such an amazing resource. I've had *tons* of fun with WebOS so far, and I've been browsing the forums and articles pretty much non-stop for the past few days. I'd say everything's perfect... except for this little charging problem. I've searched the forums, of course, but I haven't found a problem that's exactly like mine - forgive me if I've missed something.

    Essentially, what's happening is that (1) my Pre won't recognize being plugged in at all unless the screen is off (this is true for the wall charger and computer USB ports), and (2) if it's been successfully plugged into the wall charger, it doesn't recognize that it's been unplugged (the lightning bolt icon remains over the battery icon).

    In more detail:

    AC Charger Scenario
    - Pre won't recognize that it's plugged in unless the screen is off before I plug in the microUSB cable (icon doesn't change, battery doesn't charge)
    - Pre won't recognize that it's been unplugged
    - The only way, short of a reboot, to get the battery icon to reset is to plug it into my computer's USB port.

    Laptop USB Scenario
    - Pre generally won't recognize that it's plugged in unless screen is off - but it will occasionally work with the screen on. Also, if I plug in the microUSB cable while the screen is on, and then toggle the screen off and back on, the Pre will recognize that it's plugged in when the screen turns on again.
    - I always get the USB Drive/Just Charge option popup.
    - The Pre always recognizes when the cable is unplugged in this scenario.

    What I've tried so far:
    - My roommate has a Pixi, so I've tried his charger/cable with my Pre, and my charger/cable with his Pixi. I get the same problems with his equipment, and his Pixi works fine with mine. So either there are no physical issues with the cable and charger, or the problem exists in both sets and the Pixi just isn't sensitive to them.
    - Pulled the battery, waited, rebooted (did this one many, many times)
    - Used WebOS Doctor to reinstall 1.4.5. The problems remained.
    - Tried plugging/unplugging cables with the battery cover off (In desperation, I wondered if there might be an issue because of the Touchstone-compatible back)
    - Used Dr. Battery to see if the phone was charging when it thought it was. Dr. Battery, at least, seems to know that the phone is unplugged even when the lightning icon remains in the AC Charger Scenario. When the phone is plugged into the wall and the Pre doesn't recognize that, Dr. Battery also doesn't think the phone is charging.

    Sorry for the perhaps overlong post, but I thought that it would be better to put everything I know on the table... and maybe it will help someone smart find an answer. For what it's worth, I've ordered a replacement battery, but I'm not optimistic that that alone will solve the problem. So, I'd really appreciate any advice you folks have, and thanks again!
  2. #2  
    i had the unpluck problem once.
    the charging is controlled by the linux process powerd.
    Dr.Battery doesn't care about any info from the os but only reads info from the battery. So if dr.b says it's chargeing or not then it is.
    I would insstall lumberjack and monitor the logfiles. Look for entries from powerd.
    edit: use original cable and charger.
  3.    #3  
    Thanks for the reply!

    So, I installed Lumberjack - I don't really know what I'm looking for, but setting up a custom log for powerd, all I seem to be seeing is a confirmation of the problem. Powerd only reports a successful recognition of the AC charger/laptop being plugged in in the same scenarios I described. I have absolutely no idea whether this points to a software glitch or an actual hardware problem - any ideas?

    I did some more digging online, and read something where a person fixed their battery charging problems with the Attempt Novacom (Re)installation option in Quick Install - I tried that too, but it doesn't seem to do anything at all (I'm running OSX Leopard, if that matters). Also, I've only ever used the original charger and cable.

    Thanks again for all your help.
  4.    #4  
    One more thing that I just noticed that may help someone help me - when plugged into AC power successfully, the phone *will* recognize that it's unplugged if I unplug the wall unit from the power outlet while the USB cable is still connected - if I unplug the phone from the cable, or the cable from the charger unit, the phone doesn't recognize that it's unplugged.

Posting Permissions