Results 1 to 15 of 15
  1.    #1  
    I am having difficulty diagnosing my sound problem. There is no sound from ringing, notifications, music, videos, games, nothing. I can ssh into the phone and I have root access over ssh. I installed the uberkernel and am over clocking a 1ghz. When I login in and I run aplay, I get the following error:

    kevin@palm-webos-device / $ sudo aplay
    E: socket-client.c: socket(): Address family not supported by protocol
    ALSA lib pulse.c:272pulse_connect) PulseAudio: Unable to connect: Connection refused

    aplay: main:590: audio open error: Connection refused

    Any ideas?
    Last edited by yazmonium; 01/12/2011 at 08:38 AM. Reason: clarification
  2. #2  
    Did you check to see if it's stuck in headset mode?

    Posted from my eVo!
    Sent from my favorite gadget!
  3. #3  
    I don't know aplay. But I don't get this error on running it.
    No idea what it is.
  4. #4  
    do this: go to phone app and dial a number... Do you see a headphone icon in the lower left? If you do it's stuck in headset mode ( restarting sometimes works)
  5.    #5  
    This has nothing to do with the headset issue. I can make calls without a problem. The issue is with the ALSA driver, i think.
  6.    #6  
    Could you please post the results of running aplay?

    sudo aplay
  7. #7  
    Running plain aplay does not give any feedback and does not terminate.

    Calling it on device 0 subdevice 0 plays the sound but the device rebooted after:
    root@palm-webos-device:/# aplay -Dhw:0,0 /usr/palm/sounds/phone.wav
    Playing WAVE '/usr/palm/sounds/phone.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
    Read from remote host palm: Connection reset by peer
    Connection to palm closed.
    Playing a sound through luna works just fine:
    root@palm-webos-device:/# luna-send -n 1 palm:// '{"name":"shutter"}'
    ** Message: serviceResponse Handling: 2, {"returnValue":true}
    EDIT: I was loged in as root. So no sudo
  8. #8  
    Short story is PulseAudio is crippled as of 1.4.5: any command such as "aplay file.wav" will just make the pulseaudio daemon crash with a segmentation violation...

    You may try for yourself:
    stop pulseaudio
    /usr/bin/pulseaudio --system=false -v --log-target=stderr
    then run
    aplay file.wav
    from another window to see it crash.

    But what's really amazing is you can successfully
    pactl upload-sample /usr/palm/sounds/phone.wav test-sample
    pactl play-sample test-sample
    paplay /usr/palm/sounds/phone.wav
    Connection failure: Connection terminated
    Stream errror: Connection terminated
    fails miserably.

    Both "aplay" and "paplay" used to work flawlessly under 1.4.0, though and pulseaudio revision number apparently did not change (0.9.14) since then, so I suspect there is some (socket-based?) inter-communication failing somewhere...
    Palm Pilot Pro -> M505 -> T|X -> (franken) Pre & Pixi -> Pre2 2.2.4 & TP
    Linphone port to webOS (1.4.x -> ...), lately working on NAVIT
  9.    #9  
    I think this has something to do with installing sudo. I ran WebOSDoc to clear the phone then checked it after each optware program I installed. After installing sudo and restarting, the sound stops working. Any ideas what may be causing this issue?
  10. #10  
    I have no idea what it could be because I don't have it installed.
    I use the webosinternals method using ssh with key's to login as root.
  11. #11  
    Quote Originally Posted by Thibaud View Post
    paplay /usr/palm/sounds/phone.wav
    Connection failure: Connection terminated
    Stream errror: Connection terminated
    fails miserably.
    Things get a little better if you specify the device on the command line, though:
    paplay -d pdefaultapp /usr/palm/sounds/phone.wav
    But I still have a hard time getting ALSA running on the command line (aplay)...
    Palm Pilot Pro -> M505 -> T|X -> (franken) Pre & Pixi -> Pre2 2.2.4 & TP
    Linphone port to webOS (1.4.x -> ...), lately working on NAVIT
  12. doconnor's Avatar
    18 Posts
    Global Posts
    19 Global Posts
    I was experimenting with the command line utilities that come with Speech Dispatcher and playing the resultant sound file with paplay and now my Palm Pre sound doesn't work even after uninstalling Speech Dispatcher and rebooting.

    The WebOs sound effect of closing a card doesn't work. Starting pulseaudio from the commend line shows that it crashes with a segmentation fault when using drPodder, Music or Video.

    Is there something in Speech Dispatcher or something else that could corrupt the audio system?
  13. #13  
    having a similar problem, also sems to be related to sudo.

    I have complete failure of pulseaudio, it will not start, paplay, even with device specified fails with:

    E: socket-client.c: socket(): address family not supported by protocol.

    invoking pulseaudio gets a failure of:

    yada yada...
    E: core-util.c: Failed to create secure directory: permission denied

    invoking aplay with device 0 subdevice 0 as somline mentions above plays the sound but the pre becomes unresponsive and eventually reboots.

    using ipkg-opt to remove sudo had no effect. I'm still tying to fix this without a trip to the Doctor, but it seems permissions and/or user levels may have been FUBARed here.

    an one have any ideas?

    edit: also of note, none of my PDK aps will launch, but built in and SDK aps run fine, albeit with no audio what so ever. Also perhaps of note, I have no vibrate on ring, alerts, or alarms... Though some aps that use vibrate seem to work fine... Phone works fine: speaker, headset and earpiece all behave normally.
  14. #14  
    I also had this problem immediately after installing sudo with ipkg-opt. Has anyone discovered the solution here? There is extensive mention of the use of sudo in these forums and on webos-internals, so obxiously not everyone is having this problem. I'm running webOS version on a Verizon Pixi Plus. I get various errors from different programs listed above and also Internalz when trying to open audio files or streams. However, no problems with audio in phone calls. I had the headset issue once before so I never go near that jack anymore, and I'm sure it's not that from the behavior of the phone prgram.

    Possibly unrelated, after installing adduser directly I was not able to successfully run it. I later installed rtorrent, and during its install I was surprised to see it install adduser again. Then I was able to use adduser, setup a new account for non-root ssh, and install/setup sudo. Then, no audio other than phone calls.

    Any thoughts?
  15. #15  
    I had the same problem after I installed sudo using ipkg-opt. After searching I found out that pulseaudio couldn't start because of incorrect permissions on /var and /var/lib directories. I uninstalled sudo and fixed the directory permissions as follows:

    ipkg-opt remove sudo
    chmod 755 /var
    chmod 755 /var/lib

    And finally start pulseaudio or reboot the system
    /sbin/initctl start pulseaudio

    Hope that helps

Posting Permissions