Results 1 to 10 of 10
  1.    #1  
    My O2 Pre Plus is stuck during bootup (at the Palm logo which doesn't glow).

    Before I doctor it, I would like to try to recover palmdatabase.db3. If I put the device into recovery mode, I should be able to mount and view contents somehow, since the doctor manages to read and write in recovery mode. How would I access the files whilst the phone is in recovery mode?


    Additional Info:
    I believe I got it into this state by inserting the sim card whilst the phone was still on. I had the phone on with the SIM removed, and since it didn't regain signal when I slotted it back in, I tried to reboot.
  2. #2  
    The only way I've done it is to be in "just charge" and use Quick Install to copy the palmdatabase.db3

    I'll find a link for you and post it back here...
  3.    #3  
    Thanks for the suggestion Cantaffordit but at the moment, the phone doesn't actually finish booting up. I am not able to get it to the state where it will let me select Just Charge.

    I have just tried using QuickInstall but the program hangs when the device is in Recovery Mode. The device is not detected whilst it is booting up.

    WebOS Repair Utility doesn't seem to help either as I cannot get into the Just Charge state.
  4. #4  
    I am not sure how to get through booting if it is stuck in a loop. If you have left it for 20 minutes and it hasn't completed booting, you may have no choice but to doctor.

    You will have most of your stuff restored, except for things like call logs, txt messages, or anything added since your last backup. The doctor shouldn't wipe anything from the usb storage area. What in particular are you hoping to recover before doctoring? That may help someone smarter than me think of a way for you to get what you are looking for.

    Once you get the phone to boot, this is the link I used to copy the palmdatabase.db3 file to my PC.

    The important info from that thread is: You must be in developer mode, then use WebOS Quick Install, go to Tools, then Receive File and enter:

    /var/luna/data/dbdata/PalmDatabase.db3 and select your save location.

    I know there are ways to do this without QI, but I don't have the Linux knowledge for them. I'm sure someone else will jump in to offer ideas on this if needed.
  5.    #5  
    Thank you for your suggestions.

    I was hoping to be able to recover text messages.

    The phone has been left to boot for over an hour and nothing happened. I understand that I most likely will need to doctor, but I was just hoping there was some way to save SMS messages as well.

    Thanks again for your input.
  6. #6  
    AFIK you can't recover text messages unless you can get that .db3 file before doctoring.

    Anyone else have a suggestion?
  7. #7  
    Use the 'memload' and 'mount' targets from MetaDoctor.

    -- Rod
  8.    #8  
    Hi Rod,

    I get errors when trying 'memload' and 'mount':

    > make DEVICE=preplus CARRIER=wr memload mount
    novacom -w boot mem:// < build/preplus-p101ueu-wr-1.4.5/webOS/nova-installer-image-castle.uImage
    failed to connect to server
    make: *** [memload] Error 1

    I also attempted 'backup':

    > make DEVICE=preplus backup-wr
    novacom -w run file://usr/sbin/lvm.static -- vgscan --ignorelockingfailure 2> /dev/null
    make[1]: *** [mount] Error 1

    Am I making a silly mistake somewhere?

    I have tried this with the phone in recovery mode and stuck at palm logo mode (which at least shows up as /dev/sdb and /dev/sg1). I assume the error is at novacom -w as that tries to wait for the device to show up?

    Many thanks for your help!
  9. #9  
    If it's in vol-up recovery mode, then it should not be showing up as partitions on the host - are you sure it's not in USB drive mode?

    And yes, recovery mode is the right way to run those commands.

    -- Rod
  10.    #10  
    Ahh I realise what my problem was now. Before, I didn't have anything in the build directory because I didn't realise the other make commands would make use of it.

    So in summary here's what I did to backup my phone:
    1) Put webOS device into recovery mode
    2) make DEVICE=preplus all-wr
    3) make DEVICE=preplus CARRIER=wr memload mount
    4) make backup-wr

    Many thanks Rod and Cantaffordit for your help!

Posting Permissions