Results 1 to 13 of 13
  1. Hockey07's Avatar
    8 Posts
    Global Posts
    9 Global Posts
    Starting last night, my Pre started freezing the moment I attached my USB cable to charge it. I had to pull the battery out to reset it. This morning, I had under 20% battery remaining and I tried to charge it but nothing happened when I plugged it in. I tried my car charger, same thing. Nothing.

    So obviously my battery is dead now, and I have no way of charging it. I've been trying again and I get a flickering black screen, and then the giant battery charging image on the screen for a few minutes... but it never leaves that screen, and if I move the cable or phone, it sometimes goes back to the black flickering.

    I'm going to the Sprint store tomorrow, but I don't know what my options will be. Is it possible to still get a replacement? I've had the Pre since launch day, I'm a developer, and I love webOS so much that I don't really want Android phone (although I hear some of them are good, and I'd get one if I had to). I was hoping I could wait until a webOS new phone was announced, but I'm currently phoneless and that's not an option.

    I'm not really sure what to do. Suck it up and get an Android device? Are there any options to fix my Pre? Thanks

  2. bdog421's Avatar
    513 Posts
    Global Posts
    574 Global Posts
    Don't freak out they may be able to replace or repair your pre. And if you have to get an android phone, trust me it's not the end of the world.
  3. Hockey07's Avatar
    8 Posts
    Global Posts
    9 Global Posts
    Yeah I know it's not that big of a deal. I was just hoping to stay with webOS (especially since I won't have a phone to develop with if I choose Android). It's just annoying not having a phone at all today.
  4. #4  
    Did you try charging on a Touchstone?

    -- Sent from my Palm Pre using Forums Beta
    Clicking the Thanks button is a great way to say... well THANKS
    Phone Apps: Church Search, Tap for HELP
    TouchPad Apps: Tap for HELP! HD, webOS Meetups
  5. Hockey07's Avatar
    8 Posts
    Global Posts
    9 Global Posts
    I don't own a Touchstone.

    An update: After an hour of the giant battery-charging-from-dead icon, the phone finally booted up. I'm going to let it charge and see how it goes.
  6. #6  
    How old is the battery? Do you have another one you can swap in place.
  7. #7  
    take it back to the store and see if they will replace the battery for you to see if it works ?
    Here is a direct link to webOS Doc for all carriers
    P.S. if i have helped you and you are thankful please hit the thanks button to the right---->
  8. Hockey07's Avatar
    8 Posts
    Global Posts
    9 Global Posts
    Only have one battery and it's a minimum of 14 months old (probably longer since it was a refurb phone)

    Another update: It's not working anymore I'm hoping it can somehow be fixed, or I can get a new battery that may work, or something... but if not, then I guess it's time to move on (something I was hoping I wouldn't have to say!)

    edit: Yeah I'll be going to the store tomorrow to see what can be done. If not, I'll get a new phone and I'll be happy with that. I was just hoping I wouldn't have a dead phone
  9. #9  
    If your Pre is dead AND Sprint has no more to give you, your options are:

    1: Go to ebay and buy one. They're averaging about $100 last I looked.

    2: Get a new battery, and see if that works.

    3: Risk your Pre 2 and frankenmix the two.

    (FWIW, if your Pre *IS* dead, don't throw it away or let Sprint take it if you can avoid it. I wager you can get a few dollars for it's radio board from upgraded-frantic sprint users.)
    Doug Meerschaert

    Apps: Scratch, GasMath, CheckMath
  10. #10  
    FYI you can also go to the HPalm website and get one.
  11. h-cubed's Avatar
    463 Posts
    Global Posts
    518 Global Posts
    I would be willing to wager that they would just fix it for you. Just take it in, and if it is a battery issue, they most likely will give you a new one.
    Sent from my HTC Evo 4G
  12. #12  
    Hey there H-Cubed what's up today!
  13. #13  
    Not certain from the posting but when you get the big dead battery icon on the screen that it could take up to 15mins for the device to come backup. Otherwise try a different battery.
    Try diplomacy first. You can always conquer them later..., read it, use it, love it, and donate to it.....

Posting Permissions