Results 1 to 9 of 9
  1.    #1  
    Hey, guys. Checked out the forum for similar issues, but most seem to be relating to battery life or not charging to 100% Apologies for the lengthy post...

    My issue is this:

    My Palm Pre was bought unlocked, running WebOS 1.41, which I upgraded to 1.45. Charging was fine for several weeks (daily using both the supplied, i.e. official Palm USB/mains adapter, and USB/PC lead). Nothing out of the ordinary happened (that I know of), however, over the past week, when charging (via mains or via PC), the Pre will charge for a seemingly random amount of time (i.e. the charge could increase by 5% or 30% etc.) before the battery begins discharging again - however, the battery symbol indicates that it is still charging. If I leave it like this, the battery will drain completely and the Pre will switch off. The battery is the stock Pre battery.

    Additional info. / what I have tried / considered:

    1) Removing and reinserting the USB lead sometimes works (i.e. Allows me to charge the battery a little more before it starts discharging again) and sometimes doesn't.

    2) Soft resets (via power button, or ringer-switch toggling, etc.) and removing and reinserting the battery sometimes works (see above) and sometimes doesn't.

    3) Reinstalling WebOS 1.45 via WebOS Doctor seemed to work - from the first charge it charged to 100% normally, but the following day, second charge of the battery, the issue started again.

    4) Tested a new OOTB USB/Mains charger, the problem remained.

    5) Readings from /sys/devices/w1_bus_master1/32-<xxxx>/ :
    getfull40 = 1150.000
    getage = 100.00000

    (1150/100)*100 = 1150

    get capacity = 1149.578

    6) Dr. Battery reports battery health as 100%

    7) Recalibration with Dr. Battery fails (i.e. it stops charging at *some* point)

    8) Device Info > Tests > Interactive Tests > Power > AC Adapter / USB Cable:

    Both tests flash up very briefly (like 1 - 2 seconds), state that the device is charging (and show the current charge), then say the test has completed (i.e. without error)

    9) I have used BatteryMonitor to monitor the charging, over a one hour period at 60-second intervals. Pre charged initially at ~-25% charge/hour, fluctuating slightly for ~20 mins (at this point the percentage battery charge rose by 5%), then the hourly charge rate decreased steadily (~-25% to ~-1% charge/hour) at 58 minutes (the percentage battery charge began decreaseing over this period, falling by ~6% charge over a 30 minute period, while plugged in). I have also tried closing all apps and charging in Aeroplane Mode, all to no avail.

    10) Connected the Pre to a computer as a USB (mass stoorage) device, and transferred a large file and monitored the transfer. It transferred fine, at a constant (and fast) rate.

    11) DIAG Mode (#*USBPASS# or "mpt x" in Terminal) and Dev Mode (Konami Code) both verified as being off

    12) Nothing hogging CPU ("top" in Terminal)

    13) Tried known working (official Palm) spare battery, USB lead and mains adapter

    14) Tried original (official Palm Pre) battery and charger with an known working Palm Pre (including Touchstone charger also) and battery charged fine

    I think that's everything I have tried over the past week - USB cable / Mains adapter seem fine, battery seems healthy. I can't tell whether WebOS is causing the charging to fail (though if so, surely the reinstall of WebOS would have sorted it - after the clean reinstall, and deleting all applications and app data, the only additional apps that were installed were Preware, Terminal, BatteryMonitor and Dr. Battery), or whether it's a hardware issue. The only thing left that I can think of is a replacement Pre, but first, was hoping you guys might have some ideas or suggestions...

    Last edited by d15tortion; 09/14/2010 at 04:46 PM. Reason: Additional Info (#11 - #14)
  2. #2  
    Replace the battery and after three to four discharge, the you can make a better diagnose on the problem.(IMO)
  3. #3  
    replace the battery
  4. #4  
    I would try a new OEM cable, you may have an intermittent connection and plug it in a wall socket to charge. Do you have a touchstone? You could try that.

    You could also try calibrating again with Dr. Battery with phone in airplane mode but I'm thinking it probably won't help in this case.

    Try another battery as others have mentioned.

    Edit: Didn't see this:
    4) Tested a new OOTB USB/Mains charger, the problem remained.
    Was it the whole cable assembly that you tried?

    Edit2: You could try cleaning the battery contacts on the phone and also the battery itself. Maybe use a pencil eraser.
    Last edited by Trekker; 09/10/2010 at 09:41 PM.
  5.    #5  
    Thanks for the suggestions, guys, much appreciated - the common consensus seems to be to replace the battery, which I am now awaiting. I had considered the fact that it may be the battery, but was having doubts, largely since the battery was being reported as being healthy (if I understand correctly, a chip inside the battery itself is doing the monitoring).

    As another option, I was also considering purchasing a spare battery charger (where the battery - removed from the phone - is charger in it's own cradle via mains). This would allow me to eliminate another variable from the mix in the diagnosis - i.e. the Pre itself.
  6.    #6  
    Quote Originally Posted by GuyFromNam View Post
    You mention you bought it unlocked.
    Does that mean it was never locked, or that it was unlocked by the seller?
    If so, DIAG Mode might still be enabled (small chance though).
    Also, do you ever get Phone Offline messages?
    Thanks. The company I bought if from describe it as an Unlocked Palm Pre Smartphone, under their 'SIM-Free Phones' section, but do not give any further information regarding this. I can provide a link to the product I bought, if that'd make much of a difference.

    I've checked in the USB Passthrough Control menu, and DIAG Mode is not enabled on any port. Moreover, this issue only began recently (after several weeks of normal functioning) and I can't attribute it to any specific action that I carried out.

    I have never had any 'Phone Offline' messages. Aside from the device not charging correctly, it's behaving really well and as expected. Battery life isn't great, but it certainly isn't draining abnormally rapidly, or anything else out of the ordinary. For all intent and purposes, if I can manage to get the battery charged, I can get 1 - 2 days of average use out of it. I assume this is a normal battery life.
  7. bugdad's Avatar
    19 Posts
    Global Posts
    23 Global Posts
    I am having the same issue. I wake up to my phone rebooting while on TS to find that it drained. I noticed that if the phone is taken off of TS and back on charging resumes. My thought is that the phone quits charging @ 100 and never picks back up after discharge for a bit.

    I exp both with the TS and reg usb. Irony is batt life is best it has been... Go figure. This did not happen until latest upgrade. I am overclocked UK gov
  8.    #8  
    Quote Originally Posted by Bugdad View Post
    I am having the same issue. I wake up to my phone rebooting while on TS to find that it drained. I noticed that if the phone is taken off of TS and back on charging resumes. My thought is that the phone quits charging @ 100 and never picks back up after discharge for a bit.
    I don't own a Touchstone charger, so it can't be related to that. The first time it'd happened, I put it on charge and awoke to find it had turned itself off and the battery was completely empty. I thought it might be the case that it had charged fully, stopped charging, and never restarted again after partially discharging.

    However, taking today as an example - Battery charge was at 16% upon (me) waking up this morning, so I put it on charge and went about my business. Checking later, it was at 25% charge, so I left it on charge (mains). I checked again 15 minutes later, and the battery icon (top right) indicates that it was still charging, but was still at 25% Checking again 15 minutes later and the charge had dropped to 22% (again, the battery icon indicates it is still charging and I neither moved the Pre, opened any new apps, received and calls, wifi is off, etc.)
  9.    #9  
    Thanks for the suggestions on this one, guys - I am now a little more knowledgeable, yet the problem still remains. I did however try a (known working) battery, USB cable and mains adapter, and the issue persists.

    So, it's looking like an issue with the Pre itself - voltage regulation, perhaps? Either way, I'll be requesting a replacement soon. I'm guessing this is far from being a common issue with the Pre, but perhaps this thread may be useful for anyone else experiencing battery / charging issues in future, since it practically lists every potential method of diagnosing battery / charging problems that I can think of!

    Thanks again!

Posting Permissions