Results 1 to 3 of 3
  1.    #1  
    Ok, I've been going around and around for hours now and I simply cannot get OpenSSH working. I've followed all the instructions on Application:OpenSSH - WebOS Internals (several times!). I followed all the steps in the Generate Keys from WebOS Method, and I've tried using both PuTTY and winSCP to login, but everytime, I get an error message saying "Server refused our key". I get the same message in both PuTTY and winSCP.

    Next, I tried generating the keys using the Windows method, meaning I followed the instructions at Secure Linux/UNIX access with PuTTY and OpenSSH. I thought I had finally found an answer to why it wasn't working when I came across the instructions on this site that state:
    Note - the authorized_keys file must be owned by the user and unreadable/unwritable by anybody else - the OpenSSH server will deny logins if this is not the case.
    I used chmod to change the permissions so the file and the directory match the instructions. Unfortunately, none of that worked. I'm still getting the "server refused our key" error.

    As a final note, I doctored my Pre right before I started this whole frustrating process. I've loaded Preware and used that to install OpenSSH, along with the other four optware packages that OpenSSH needs to run, but other than that, I have made absolutely no other modifications or installed any patches. Prior to doctoring, I had been using the old, deprecated method of getting ssh access by installing the optware packages manually and creating a non-root username with a password. After doctoring, I wanted to set things up the correct, more secure way, but I just can't figure out what I'm doing wrong. I found another thread here where someone else had issues with access, and it turned out his problem was that he had both the old method and the new method installed at the same time. I was pretty sure that between the doctor and the full erase that I did that I had wiped out the old method, but I tried the ipkg-opt remove command just in case, and sure enough, I don't have the old optware installed anymore.

    I've attached a jpg showing the error message I keep getting, and here is the event log from PuTTY:
    2010-06-20 16:05:34 Looking up host ""
    2010-06-20 16:05:34 Connecting to port 22
    2010-06-20 16:05:34 Server version: SSH-2.0-OpenSSH_3.6p1
    2010-06-20 16:05:34 We claim version: SSH-2.0-PuTTY_Release_0.60
    2010-06-20 16:05:34 Using SSH protocol version 2
    2010-06-20 16:05:34 Doing Diffie-Hellman group exchange
    2010-06-20 16:05:35 Doing Diffie-Hellman key exchange with hash SHA-1
    2010-06-20 16:05:52 Host key fingerprint is:
    2010-06-20 16:05:52 ssh-rsa 1024 af:72:d2:4e:05:d6:93:67:2b:87:aa:fd:d8:54:8c:8e
    2010-06-20 16:05:52 Initialised AES-256 CBC client->server encryption
    2010-06-20 16:05:52 Initialised HMAC-SHA1 client->server MAC algorithm
    2010-06-20 16:05:52 Initialised AES-256 CBC server->client encryption
    2010-06-20 16:05:52 Initialised HMAC-SHA1 server->client MAC algorithm
    2010-06-20 16:05:52 Reading private key file "E:\Users\Alisa\Documents\Palm Pre\private-key.ppk"
    2010-06-20 16:05:52 Offered public key
    2010-06-20 16:05:52 Server refused public key
    2010-06-20 16:05:52 Keyboard-interactive authentication refused
    If anyone can give me any clue as to what to try next, I will be forever grateful!
    Attached Images Attached Images
  2.    #2  
    Well, on the bright side, I followed the instructions to allow ssh over evdo, and now it works beautifully. I'm still stumped as to why wi-fi won't work, though, and I'd still be interested if anyone has any thoughts. Thanks!
  3. #3  
    I've had problems w/putty keys if you don't copy and paste out the text directly from puttygen - openssh doesn't like multi-line keys.
    I've decided to become enigmatic.

Posting Permissions