Results 1 to 4 of 4
  1. dreznicek's Avatar
    79 Posts
    Global Posts
    82 Global Posts
    This is pretty crazy, but maybe some other unfortunate soul has this same issue...

    For the past few weeks I've had crazy problems with my Sprint Pre keyboard. Either it wouldn't work at all, then it would for a bit, or it would only work with caps, or special characters, or it would all the sudden repeat a character or random character like 50 times. Sometimes I would even type and then 3 seconds later, the text would show up. I was going nuts. I tried mashing down on my keyboard, bending my phone a bit, everything. What worked sometimes was while the keyboard was out, touching the bottom left of the gesture area. It would work for a few seconds, then no more. I'd even reset the battery and left it unplugged for 30 minutes. Nothing worked consistently.

    I was completely like ***.

    So I was doing the drill, Preware patch backup, Save/Restore, etc getting ready to take it back to Sprint and have them exchange it. Then I thought: I'm gonna try the factory battery and cover...just to see if it might magically work. I've been using the Amzer 2800mah battery for the last several months, so I thought what the heck. Sure enough...

    It freakin worked!

    It worked perfectly, in fact. So it got me thinking of the "why", and I believe it is kind of similar to the battery not fitting snug and people getting the random reboots. I think, in my case with the bigger battery, it was making enough contact to stay on, but the keyboard wouldn't work. So I put the Amzer back in with some pieces of foam and booyah, it works like new!

    So maybe some peoples text repeat problems is actually an issue with the battery not having continuous current? Dunno, but it absolutely-without-a-doubt fixed my problem.
  2. cgibin's Avatar
    50 Posts
    Global Posts
    56 Global Posts
  3. #3  
    I don't really have that problem, but sometimes the whole system seems to hang and while typing it'll attempt to catchup and end up only putting in a few of the letters I typed. Not that big of a deal.
  4. #4  
    I have exactly the symptoms you describe. But I don't have a 3rd party battery. I reseated my battery and wedged it with some folded paper to make sure the connections were firm. At first I thought it was helping, but then the problems came back in full force. Now I think it was just the common scenario of rebooting that sometimes makes it go away for a while.

    I took it to the Sprint store and they replaced the keyboard, and I went out happy because I couldn't reproduce the problem. Then, sadly, after I got home the problem continued. I tried a full erase / reset and the problem is still there. I'm going to go back in and ask them to please just give me a new phone. I wish I knew of another solution.

Posting Permissions