Ive just got a new Pre (german verison, running in Sweden with operator 3).

First time (without sim) it worked fine without phone-capabilities. I even remember going into settings and observing that roaming was turned off.

I inserted my sim > reached "Palm Pofile" > created a new profile > was hit with "Sign-In Failed".

Here I tried "Enter Phone Settings" > put the correct internet apn (but no username or pass since I dont have any such data) > got "Unable to write settings".

Now, someone on this forum said you should have roaming enabled and it will start working. The problem is that Im stuck with this screen each (Palm Profile) each time I turn on the device. Without the sim-card a couple of images show me how I must place a sim into the phone.

So, I cant reach the main menu of webos and thus cant set roaming to enabled.

I tried to reset the phone to its factory settings, without any results.
First with [red button + sym + power] which my phone didnt even react to at all.
Second by installing webosdoctor and resetting the phone.

Is there a way to hard reset the phone so I can reach the settings and turn roaming on?

- I do see my operators logo in the top left corner of the screen.
- I have signal (at least two bars).