I noticed my battery draining a lot more than ususal at some point after the 1.4 update. I can't say it was the DAY after.. But I know I never had this issue prior to the update.

But anyway, now I think I know what started happening. My e-mail pulls from 2 POP3 accounts and and 1 direct exchange account. The exchange account is no issue. It pulls every hour (per my setting), finishes quickly within seconds, and the upper-right-hand corner "spinning circle" stops with the number of e-mails. Just like how my POP3 accounts used to do.

But now, when I go to the inbox of my 2 POP3 accounts, the new e-mail is there...but it just keeps spinning. And it says "last update March 30th, next update 0 hours" if I touch it. I used to have to initiate the "sync" if I went into the inbox. Now, it is like it is constantly running when I bring it up.

So my 2 POP 3 accounts never "finish" downloading and stop! And I guess have not for the last 2 weeks. I have not changed any settings other than playing with the "sync" settings a while ago. But I turned both off and still no joy.

I even tried setting the POP3 accounts to "manual" and it still does the same thing.

Any help appreciated, I have wi-fi off as that stops e-mail sending with my POP3 accounts and drains the battery even more....