Results 1 to 14 of 14
  1.    #1  
    Soooooo maybe you guys can help me.

    I've had my Sprint Pre for about 2 weeks now and I love it. When I'm at home I'm automatically connected to my home wifi. This hasn't been a problem till this morning...

    See, last night I did a full reset on my router-- power down, reset, reconfigure, new password, the whole nine yards. Afterwards, the internet worked fine, even my XBox Live worked speedier and better. And yes, my Pre was connecting fine (although since I updated the security on my router I had to put in a new password on the Pre. I guess it used to have a 4-digit security code that I never had to use to connect; now I have a longer security code and I had to put it in this time. Whatever, it still worked). I got up this morning and things were good.

    Then I noticed later that my weather app wouldn't load. That was odd so I tried my email and it wouldn't refresh my inbox. So I tried to connect to AIM and that wouldn't connect. I looked at the wifi and it was fully connected.

    I turned off wifi and the internet and all related features came through fine (albeit it slowly) over 3G. Turned wifi back on and nothing worked although it said I was fully connected. This includes the YouTube app and even the App Catalog (the app will load but the content won't).

    I'm already noticing the hit to my battery life because the 3G signal isn't great in my house. Being connected to wifi saves the battery but at the same time I'm not connected to the internet/cloud, so that kills a lot of the functionality of this phone...

    I've already tried powering down and back on. I've tried a battery pull. I've tried re-logging in to the wifi. Nothing works.

    I'm becoming very frustrated. Somebody please help!
  2. #2  
    try turning airplane mode on and off. Should reset all the network
  3.    #3  
    Quote Originally Posted by kbastian29 View Post
    try turning airplane mode on and off. Should reset all the network
    Well I tried that just now and it didn't fix it. Thanks though!

    Any other suggestions?
  4. #4  
    if the app for youtube even loads it means you have a connection. How many pc's/consoles are hook to the router? Your signal is bad. Had that prob with cable. They gave me a new modem. I guess they run out of signal and cause outages.
  5. #5  
    unplug/turn off everything from the router except the pre. How fast is your internet? Go to. Homepage of Speakeasy - The Powerful, User-Friendly Computational Software to Solve, Create, Explore and do a speed test.
  6.    #6  
    Hmm. I've got 2 gaming consoles and a PC hooked up to the network. Plus there's an iPhone in the mix, too. So, four devices total. And as far as I know, everything gets a signal except for my phone.

    I think I'll try resetting the router (again) in a bit...
  7. #7  
    Just another thought. I run a Belkin N150 router. My cable modem pushes 27 mbps. I run a PS3, 2 Pre, and a PC. I have to reset my router at least once a month for some reason. But other than that, everything runs at the same time just fine.
  8.    #8  
    First, I'd like to thank you for sticking through this with me. PreCentral is awesome and helpful people like you are the reason why.

    Now, back to business:

    I just reset my router again only this time I left it unsecured. This seems to have fixed my problem and I am now posting in this thread from a wifi-connected Pre. Unsecured wifi isn't ideal, obviously, so now the question becomes: why wouldn't my Pre play nice with my secured wifi?
  9. #9  
    your welcome. Sounds weird....i have no idea what you could do. Good luck.
  10. #10  
    My Pre has worked on my "unsecured" wifi & I have noticed issues when I have been around "secured" networks (family networks) where I have "access" to them....keep trying to connect.....weird...
  11. #11  
    I've had problems on my home wifi too. But for me, it was that the phone preferred going through the cell connection for name resolution. Since my signal at home sucks, this caused problems. It always showed up with the weather channel app. It would stall on load, and never bring up the data.

    so I 'fixed' /etc/resolv.conf to use my network's name server. Voila, no more problems.

    I put all of the code to automate this in another thread. I'm not sure if it would be accepted as a patch, or if it would need to be done another way though. I haven't gotten that far with the community yet. Not sure if this is your problem or not but just changing your resolver is something to try.
  12. #12  
    Gah! This is happening to me now! Same as OP. Come on Pre number 4!

    Unsecuring my network doesn't fix. Any new information on this?
  13. #13  
    are you matching the security on your pre with the security on your router? I notice the Pre as four options open, wpa personal, wep, and enterprise. What security is your router setup for?
  14. #14  
    Well... I never had to do that before, it would always connect to my home network no prob. But I did find that option before posting last night, and yes, they matched. Thanks though!

    grrrrr! Feel like I've tried everything!

Posting Permissions