Results 1 to 4 of 4
  1.    #1  
    I have taken care of my Pre Plus like its a baby, and all of the sudden it has stopped taking care of me. The keyboard completely shut off and wouldn't not register any clicks at all.

    I did a restart and had zero improvement. I then took the battery out and the keyboard worked. Not good though.

    I am actually going to call Verizon tomorrow and see if I can get the phone replaced. Since it is passed 30 days I will bet they will just give me the middle finger. Hopefully not.

    I'll be honest though, I am having some serious buyers remorse, and this is coming from someone that has owned a Palm product consistently since 2001. I love the webOS but the hardware is terrible.

    Oh, I forgot to mention that this is the third Palm Pre Plus I have had since 2/28/10. The first oreo cookied on me literally as I walked out of the store. The second a few days later just turned off and wouldn't turn back on. Now, the third one (the current phone) is having Keyboard issues.

    ...and people wonder why Palm is going under. If I wasn't locked into my 3G plan for two years, I would whip out my Treo 755p again and use that. Heck, that thing worked perfectly for over two years. IF YOU CAN'T TELL I'M TICKED PALM AT YOU!!!
  2. #2  
    I had the exact same thin happened to my wife's Sprint Pre, I did everything short of pulling the battery. Went to the store and the technician pulled the battery out and it started working again. What surprised me though is that he told me that it was a software issue that is happening to lots of people after 1.4! I don't know if I believe him but he deal with these issues more often than I do
  3. #3  
    Shut the phone down, and click each of the keys several times while the phone is off, then press your thumbs down on the keyboard clicking all of the keys many times. Power it back up and it should be fine, this worked when my keyboard stopped working
  4. #4  
    Pulling the battery seemed to work for my friend's pre. Not sure why it froze in the first place, but that fix seemed to work. He also said that restarting the phone did NOT fix the problem. Only removing the battery and reinserting it did. Hope that helps.

Posting Permissions