Results 1 to 19 of 19
  1.    #1  
    Hi guys. I am using a GSM O2 locked Pre with a RSC. I , too , like everyone else ,was facing data connection problems with my Pre after upgrading to OS1.4 . After doing some extensive reading here , I found out that the modem firmware can be downgraded to the version and while I was doing so, I wanted to check my phone's status (I have no clue why) , so I pressed the power button to turn the screen on (while at this exact moment Novaterm was flashing the Pre's bootloader and was at 58%). The process stopped at that very stage and I waited for a while before pulling the usb cable out. Since then my Pre has failed to start.

    I contacted Caj2008 and followed his guide to recover my phone. So while I was successful in downgrading the OS to 1.2 gsm version , as per his guide , the phone would start and be stuck at the clouds - in - the - background and rotating circle screen and an error pops up and says that 'the phone is experiencing a problem that can not be resolved' (so I can't choose a language and can't log in to my profile in order to proceed as per caj2008's next steps) . Caj2008 was unable to decipher the problem.

    I then tried to doctor the phone to (the stable version for RSC Pre's) , but when it reached 58% and then stopped and would say that it can not reset my phone.

    So , can anyone tell me how to (if at all) recover my now dying Pre?
  2.    #2  
    @ Tomi666 , sorry , I meant that firmware only. With that fw , I end up at the activation area where I can't see any language option , just a rotating circle and then the message that my phone is experiencing some problem that can not be resolved
  3.    #3  
    I tried what you said , also changed the usb cord , but nothing works. Tried doctoring to but it reaches 58% and then says that it can't reset my device.
  4.    #4  
    Ok something exciting now! I logged into novaterm while Web doctor was working and tried to check the modem fw status , which returned primarily as failed/unknown . SO , I tried forcing the modem firmware upgrade and it started , but right about then web os doctor stopped , so the process stopped. At the same time , I checked Device Management under Webquickinstall and it finally showed that was loaded but modem fw was UNKNOWN. So what now? Is there a way to log in to novaterm / into the pre while I am in this situation?

    EDIT - Modem fw is shows as (0) when accessing it in novaterm.

    EDIT 2 - Modem is in download mode.
    Last edited by ecksreturns; 03/17/2010 at 11:56 AM.
  5.    #5  
    Already did that as per Caj2008's instructions. I reckon the modem fw is corrupted/messed up.
  6.    #6  
    I am sorry I am just learning these commands. How shall I do that novacom prompt?
  7.    #7  
    Yes I was/am able to get root access into the Pre via cmd > novaterm > connect to local host
  8.    #8  
    Yes I did exactly that , and it started the process and then kept showing :

    $ Open /var/log/modemupdater.log failed

    $ Open Port /dev/tts/modemdiag.log failed

    This kept showing over and over and then it just settles back to root@palm-webos-device
  9.    #9  
    uhm , as per what I read in another thread, I moved the castleumtsfw.tar file to the /tmp folder and then typed in PmModemUpdater -f </tmp/castleumtsfw.tar ... What should I have done?
  10.    #10  
    Tried all of the above and I still keep getting
    $ Open /var/log/modemupdater.log failed

    $ Open Port /dev/tts/modemdiag.log failed
  11.    #11  
    Yep tried that too
  12.    #12  
    Quote Originally Posted by tomi666 View Post
    Pls see : Research Pre GSM Modem - WebOS Internals

    Have a look at the PmLinuxModemCmd.
    where: <Port>:
    /dev/tts/modemdiag - USB Serial to Modem for Diagnostics - DIAG PORT.

    So maybe there's a problem with the "com.palm.usbpassthrough.service"
    I tried other usb ports , no difference.

    Quote Originally Posted by tomi666 View Post
    Another dumb question: did you try the WebOSRepairUtility.jar?
    Trying that now, doubt it will work cuz it needs the phone running normally
  13.    #13  
    Quote Originally Posted by tomi666 View Post
    OK, another idea (just brainstorming here). Not sure at all if this will even get you close to a solution, but you sound like you don't have much to lose:

    Open the original WR 1532 firmware: webosdoctorp100ueu-wr.jar
    (either in Total Commander, or rename the jar to zip).

    Go to the 'resources' folder and open the wr.tar file.

    Here, you'll see a bunch of ipk files.
    Copy the ones below to your /media/internal/
    - palmcustomizationinfo-wr_1.0-148_all.ipk
    - sweatshop-wr-castle_1.0-34_armv7.ipk
    - umtscustomization-row_1.0.0-3_armv7.ipk
    - castleumtsfw_1.0.0-73_armv7.ipk

    Open a novacom terminal and type:
    mount / -oremount,rw
    cd /media/internal
    /usr/bin/ipkg -o /var install ./palmcustomizationinfo-wr_1.0-148_all.ipk
    /usr/bin/ipkg -o /var install ./sweatshop-wr-castle_1.0-34_armv7.ipk
    /usr/bin/ipkg -o /var install ./umtscustomization-row_1.0.0-3_armv7.ipk
    /usr/bin/ipkg -o /var install ./castleumtsfw_1.0.0-73_armv7.ipk

    Again, no idea if this will work, but what the hell.
    If someone feels like correcting any of this, pls feel free.

    Okay trying this now.. Thank you so much for helping me here! Another thing since i cannot access the usb mode on the pre , can I send the files to /media/internal/ via webos quick install? will that suffice?
  14.    #14  
    Tried your suggestion and the errors I got ranged from 'no space left on device' to :

    Unable to open the control file in set_flags_from_control
    Could not open file as no such directory or file exists

    EDIT - Tried WebOs Repair and it found a bunch of files missing , and when it tries to restore them , it says "File open failed"

    EDIT 2 - WebOs repair is working now. Fingers crossed. Files being restored
    Last edited by ecksreturns; 03/17/2010 at 02:29 PM.
  15.    #15  
    Okay so it keeps on restoring files (from the looks of it it is restoring the entire OS) and then somewhere it just stops and says File Open Failed and I have to restart the entire process. Any way to keep this going stably ?
  16.    #16  
    Yeah , the repair utility starts to fail after running for a few mins ... Hope some one knows how to fix this
  17.    #17  
    Okay , so the latest update is that I meta - doctored a 1.4 webos version that by passed the modem firmware update and the palm profile log in and now the phone boots up perfectly fine , BUT , the phone is still in off line mode , confirming my suspicion that the modem is trashed. Wi fi works , but no cellular network at all. When accessing Palm Pre root , modem is still in download mode. What to do now?
  18.    #18  
    Even I don't know what that means. All I know is that the modem of the phone isn't working because I can't flash it or make it work
  19.    #19  
    Nope. Fone works but no connectivity.

Posting Permissions