Page 1 of 2 12 LastLast
Results 1 to 20 of 26
  1.    #1  

    I can't load the Google Maps app. It sits for a while (about 30 seconds) and pops up a card saying that "Google Maps requires and Internet connection".

    I've already updated my "Network Settings" and my PRL. I have a full Ev connection. Yes, I've tried it through Wi-Fi as well. I can search with Google just fine, so DNS is OK.

    Anyone else seeing this issue? It was working fine just yesterday.

    Sprint EvDO
    PRL: 60662

    (Actually I just got an email as I was typing this so I know it has an Internet connection.)

    Last edited by Xanadu73; 03/15/2010 at 08:08 PM. Reason: Changed subject to include "FIXED"
  2.    #2  
    Is nobody else having this issue?
  3. Pigs's Avatar
    4 Posts
    Mine has been like this for at least a week. I still can't figure out how to fix it. I'm planning on just doctoring the phone when I have more free time.
  4. #4  
    Mine is the same way.
  5. #5  
    Quote Originally Posted by dfroelich View Post
    Mine is the same way.
    Oddly enough, I just used mine and it's working great. I have the Pre Plus on VZW
  6. #6  
    Yes I had the same issue the other day, I then closed and reopened the app and it worked on the 2nd try.
  7. #7  
    On mine it usually take about 30 seconds to actual load. I haven't gotten that error before but mine takes a lot longer to load since 1.4.
  8. #8  
    I was having the same issue, and then I tried to go to this link: for google latitude and it opened up and has been working just fine since.
  9. #9  
    I tried that link, but I got the same screen.
  10. #10  
    It is hit and miss for me. I usually have to try to open it 3 times before it works. Funny that I had that happen once at the same time I got an email into my inbox. Guessing that the inet connection was working just fine at that point.

    Google needs to up the ante on this.
  11. #11  
    reporting the same problem here. Oddly happen to me on the 14 which is sunday. Tried it with wifi with same result.
  12. #12  
    working fine here, VZW pre plus in metro MN
  13.    #13  
    To all:

    I ended up making Maps work again. I logged into my Gmail account through the *browser* and it's been working fine since. It still takes 20 - 30 to actually load and show me a map, but that "fixed" the Maps app for me in general.

  14. SiLlY's Avatar
    272 Posts
    Global Posts
    273 Global Posts
    This happened to me today but I figured it was poor signal strength. We'll see..
  15. #15  
    I just did the same thing. I googled maps,clicked the main google maps link,and it prompted me to sigb in with my google account.

    now it works again.

    Too bad I didn't see your post sooner.
  16.    #16  
    You're lucky that it prompted you. I was throwing everything I could thing of at the phone trying to make Maps work. I finally thought "what tge hell..." and went to in the browser and logged in. It's worked fine since!

  17. #17  
    ...and it also fixed my gps. Before, I could only get accurate within ~500ft after 15 minutes in the sun, now within 30seconds, it was 20ft.

    Now that everything is working as it should, lets see about this 600mhz thing...
  18.    #18  
    Cool! Well, if this is working for more people than myself, I'll change the subject to include "FIXED".

  19. ToddK's Avatar
    666 Posts
    Global Posts
    905 Global Posts
    Latitude was "dead" for me as well.

    But just as I was starting to type this message, my friends list "popped up", and it's working again.

    Have no earthly idea how or why. I had tried to get it working all day....
  20. SiLlY's Avatar
    272 Posts
    Global Posts
    273 Global Posts
    Might just be google. Who knows. Seems to be erratic.
Page 1 of 2 12 LastLast

Posting Permissions