Page 1 of 3 123 LastLast
Results 1 to 20 of 55
  1.    #1  
    Here's the steps I used to use the Meta with a Sprint ROM.

    The Meta-Doctor has added numerous features recently, which I will explain in a minute. I must make an important disclaimer first, however, which is that it is ILLEGAL to post (i.e. - distribute) a modified webOS Doctor. This is why this tool was created, so that you have the ability to modify the Doctor to your liking and not break any laws in the process.

    Also... have no fear about bricking your Pre. It is virtually impossible to do such a thing, as you will always be able to force your phone into recovery mode by holding the Volume Up key at boot, until you see the large USB icon. From that point, you will always be able to install any other stock Doctor or Meta'd-Doctor of choice. If, for any reason, you believe that you have really bricked your phone... simply take out the battery, hold vol up, and plug the phone into the AC (wall) adapter, and THEN use the usb cable.


    The Meta-Doctor accomplishes several tasks:

    (1) Bypasses carrier activation (Do NOT use if you ever intend to use the cellular radio).
    (2) Bypasses the First Use app; allows wi-fi creation of Palm Profile to be completed whenever you'd like, instead of right away only over a 3G network.
    (3) Removes the carrier check; allows a newer Doctor for another carrier to be run on your phone, and it also strips the carrier-specific apps (SprintTV, Sprint Navigation, etc.)
    (4) Removes the model check; allows a p100eww Doctor to be run on a p100ueu device and vice-versa (From my understanding, all webOS devices will run a p100eww Doctor, but the p100ueu Doctor is specifically for European devices that run on different UMTS bands; a p100ueu Doctor is required only to make use of those European 3G bands).
    (5) Disables the ForceModemUpdate command; sets the ForceModemUpdate setting to false, in order to save time during frequent Doctors on the same device, yet the modem firmware _will_ be updated if it is newer.
    (6) Disables the upload daemon -- a background process that automatically uploads certain things, like GPS info and application usage, straight to Palm.
    (7) Automatically enables Dev Mode; makes restoring a phone a little bit quicker and less frustrating... especially if you're a real tweaker.
    (8) Automatically activates USB Networking functionality (usbnet drivers are required on host).
    (9) Automatically installs SSH2 Authorized Keys of the *nix desktopOS you're currently using (i.e. - the one inside VirtualBox).
    (10) Remaps QWERTZ phones to QWERTY layout for folks with German Pres that don't actually use Zs all that much.
    (11) Re-partitions filesystem to increase /var limit -- This option is deprecated and may be removed in the future. Use the ext3fs partition size option instead for both Optware and Ubuntu/Debian Chroot usage. Note that emails and attachments are not stored in the /var partition in webOS 2.0+


    (**NOTE**: This example is for use with a 1.4.0 Doctor on a Sprint Pre. PAY ATTENTION and change procedure, accordingly, to your needs!! I have changed some commands so that you can no longer copy & paste them directly, but MUST use the Tab or Space keys when you see this notation: <TAB> or <SPACE>)

    1. If you plan on using a CDMA phone and would like to use your carrier, it might be best if you call them in order to get your MSL. You can also get it thru the online activation page if need be.

    2. If using Windows, Download and Install VirtualBox (ELSE skip to step 8; Mac users who don't know how to already use DarwinPorts can continue to step 3).

    3. Download this 32-bit Ubuntu 11.04 .iso "cd image". If you choose to use a different version of Ubuntu, that's just tough luck.

    4. Install the Ubuntu 11.04 .iso on a virtual disk inside VirtualBox.
    • Click the big "New" button -> "Next". Type "Ubuntu 9.10" as the name, select "Linux" and then "Next", since regular "Ubuntu" should already be selected (NOT 64-bit).
    • Select "Next" five more times, then "Finish".
    • Double click your newly created Virtual Disk, "Ubuntu 11.04", and pay close attention to the HOST KEY that swaps you from your guestOS (11.04) to hostOS (presumably Windows) -- **Right CTRL**. "Next".
    • Now the First Run Wizard pops up. Hit "Next" and select "Image File" at the bottom and then browse to find and select the ubuntu-11.04-desktop-i386.iso that you downloaded earlier. "Finish".
    • Click the checkbox to ignore all color bit messages in the future and select "Continue".
    • Pass thru the language prompt by hitting Enter for the default "English", then select the second menu option, "Install Ubuntu", and hit Enter again.
    • Give it a few minutes and the Ubiquity graphical installer should pop right up (if not, just double-click the "Install" icon). As long as you speak English and use a USA keyboard layout, you can just hit "Forward" four times until you get to the last step. Fill this information out, then hit "Forward" and "Install".

    5. While waiting... press the Right Ctrl key to get back to your hostOS. Create a new folder somewhere on your hostOS to use as a shared folder; let's call this folder "hostOS". Now, in the VirtualBox (VBox) window (the same one that Ubuntu is installing in)... go to "Devices" -> "Shared Folders..." -> click the tiny icon in the top-right corner with the '+' sign -> find and double-click the folder you just created -> "Choose" -> select "Auto-mount" && "Make Permanent" -> "OK" -> "OK".
    • Continue waiting for the installation to complete, then click "Restart Now" when prompted.

    6. Now boot your newly created virtual disk inside of VBox.
    • Since your newly installed OS has finished, just hit "Enter" To restart the virtual machine. (or close the top VBox window and "Power off the machine").
    • [Ignore, uness necessary: The main VBox window will have your new virtual disk "Ubuntu 11.04" right there for you to easily double-click to open, like you did earlier.]

    7. Once you reach the login prompt, login! Open a Terminal (go to "Applications" -> "Accessories" -> "Terminal").

    Don't ever close this terminal! It's good etiquette.
    • NOTE: Simply close the "Update Manager" window when it pops up in a minute.

    8. Now you need to prepare a few things for the Meta-Doctor. Open Firefox and find this post so that you can copy and paste each of these entire command lines (just Google "meta-doctor guide" and it should be the first result after the ads). Each command begins in bold and must be copied, in its entirety, to the terminal.

    (HINT: To paste in Linux, just right-click inside the terminal and select paste.)

    sudo add-apt-repository ppa:ferramroberto/java
    sudo apt-get update
    sudo apt-get install git git-core patch build-essential sun-java6-bin virtualbox-ose-guest-x11
    • Insert password, hit Enter.
    • Agree to Java terms; Use the Tab key to shift to the "OK" button and then Enter to select it, and then select the "Yes" button to finalize the agreement.

    git clone git://
    • For webOS 2 upgrades (esp. Franken Pres), see this webOS-Internals page about the scripts, close the Doctor whenever it opens (the Meta'd-Doctor cannot be run from within the guestOS and must be transferred to the hostOS), then skip to Step 10.

    mkdir ~/meta-doctor/downloads/
    cd ~/meta-doctor/downloads/

    wget -c
    • Rename the file accordingly [with proper model (p100eww or p100ueu), carrier, dash, and then proper version number], as seen at step 10 on the Meta-Doc Wiki or like so, with the 1.4.0 example...

    mv web<TAB> webosdoctorp100ewwsprint-1.4.0.jar
    cd ~/meta-doctor/

    9. Now it's time to actually learn how to use the Meta-Doctor!!
    • This command will open up the nano editor so you can examine the actions of the Makefile.

    nano Makefile
    • Make sure to get the CARRIER string right, as can be seen in the Meta-Doc Wiki.
    • By default, the Meta-Doctor does NOTHING. You must uncomment (OR remove the # from the beginning of these few lines) each specific feature of the Meta-Doctor that you may need from the Makefile.
    • Here's what the beginning of my Makefile looks like ...
      Quote Originally Posted by Makefile


      # Uncomment the features that you wish to enable below:

      # Select "pre", or "pixi".
      DEVICE = pre

      # Select "sprint", "bellmo", "telcel", "verizonwireless" or "wr".
      CARRIER = sprint

    • When you're done, just hit Ctrl+X to exit and 'Y' when it asks to save your changes.

    make unpack patch pack
    • If this isn't working for you, you probly didn't put the file in the proper downloads/ directory, set the CARRIER variable in the Makefile... or it is searching for ssh keys that you don't have.

      ... say, after the next version of webOS is released.
    • NOTE: Each subsequent build will require you to start from scratch. To start fresh:

    make clobber
    • It would also be best to make sure you have the latest version of the Meta-Doctor. To grab the latest version:

    git pull
    • NOTE: I got an error about not being able to merge the developer's Makefile with my own, so I simply deleted my Makefile before running "git pull", since the dev's Makefile is all that matters:

    rm Makefile
    • You can run all of these at once, like so...

    make clobber; rm Makefile; git pull
    • And then simply restart from Step 9.

    10. Once it's finished building, transfer the meta'd-doctor to your shared folder.

    sudo modprobe vboxsf
    mkdir ~/Desktop/guestOS/
    sudo mount -t vboxsf hostOS ~/Desktop/guestOS/

    • If you don't receive any errors, you should be able to copy the file to your guestOS/ shared folder and it will show up in your hostOS/ shared folder (If you DO see errors, then see Step 5 and return here)...

    cp bu<TAB><TAB><TAB><Type out the version that you just created>webos<TAB><SPACE>~/Des<TAB>gue<TAB>

    11. Go back to your hostOS' shared folder, then open your meta'd doctor and let it work its magic on your phone.
    • Make sure you have backed up EVERYTHING, including the /media partition (mass storage with media, etc.). Everything will be gone in just a few seconds.
    • Triple check that you have gotten your MSL from Sprint (or any other CDMA carrier).
    • Make sure the phone is plugged into the USB cable.
    • Restart your device (Opt + Sym + R) and hold the Volume Up button until you see a huge USB symbol on your screen.
    • Now start the meta'd-doctor with a right-click ("Open With..." -> "Java") or just a double-click... whatever works for you. (java -jar webosdoctorp100ewwsprint-1.4.0.jar if necessary).
    • Press "Continue", "Next", and all that junk. Give your meta'd-doctor all the time it needs to work its thing.
    • If for some reason you hit a wall and the last button is not clickable, you more than likely need to [re]install the Novacom drivers on your desktopOS, which can be found here.

    12. Upon restart, Sprint [and other CDMA] users will need to reset the modem's programming. Open the phone app, go to Preferences, select "Update Network Settings". And just in case... here are the instructions from the Meta-Doc Wiki...
    Note: This has only been confirmed to resolve Sprint CDMA issues, YMMV.

    Note 2: You should try to update your profile first. Open the phone app, open the App Menu and select Preferences then select Update Network Settings. If you get an error, then procede with these instructions.

    * 1. Open the Phone App.
    * 2. Enter ##MSL# (MSL= 6 digit lock code. Get this from Sprint.)
    * 3. Verify your MDN and MSID are incorrect. If they are incorrect, continue. If they are correct, this is not your problem and you should not continue.
    * 4. Select Edit.
    * 5. Select the first box (MDN) and enter your 10-digit cellular number.
    * 6. Select the second box (MSID) and enter your 10-digit MSID (Get this from Sprint).
    * 7. Select Save.
    * 8. Backswipe out of the the view.
    * 9. You should now be able to open complete Note 2 above without any errors.
    13. Donate to WebOS Internals at WebOS Internals:Site support - WebOS Internals and leave a nice review on

    14. Play with Ubuntu some more if you're not familiar with it already. Or practice around with ANY operating system that can be installed in VirtualBox. Enjoy!
  2. #2  
    Ubuntu is great, I love it and use it everyday on my machines, but the steps can also be run with a windows machine using java and cygwin with the packages git, patch, make, unzip and zip.

    This could save people the 700mb download for the Ubuntu desktop

    I make this comment not to discourage people, but to make things easier for people that only want to tweak their Pres
  3.    #3  
    Correct... there are a number of ways to get the Meta-Doctor working...

    - VirtualBox, VMWare, etc...
    - Wubi
    - Cygwin
    - DarwinPorts
    - SSH [Putty] into a Linux shell

    ... it's just that the VirtualBox method is consistent across all platforms [for the most part] and I do enjoy the unintended consequence of pushing people across boundaries so that they realize how EASY it is to try ANY operating system of their choice without damaging the main partition on their hard drive. As long as you have 1 GB of RAM... there's no reason people should avoid Ubuntu, IMO, or ANY open-source operating system for that matter.

    Lemme know if you guys could make it even easier. I feel like it's about as close to 100% n00b proof as I can get it, but only you guys could tell me if that's the case.
  4. #4  
    thanks for this information. i am from belgium and i purchased palm pre gsm from o2 germany. my trouble is i can't download software from app catalog.

    i did exactly what is mention on your post. everything went smoothly without error. but still it asks for palm profile. i used O2 germany webosdoctor. i had set my makefile as below.


    nothing from this thing worked by me. i love this phone more then any other phone out there. please help me to access app catalog.
  5.    #5  
    Sorry... I'm not completely sure what it is that Bypass_Activation does. I know that it is relevant to the Palm Profile, and I'm not exactly positive why you'd want to enable the Bypass_Activation feature.

    Without a doubt, tho... with the settings you say you have used... it should not be asking for Palm Profile information (i.e. - the First Run should not be locked in maximized state; it should only be an icon in your launcher).

    If you got no errors during compilation and aren't seeing these results of the Meta-Doctor, then I'd imagine you copied over the original Doctor from the downloads/ directory... instead of the meta'd Doctor, which is found in the build/ directory.
  6. #6  
    bypass activation is for users whom use their phones on different networks.

    aka GSM users unlocking their phones for a different carrier

    and/or CDMA users using their phones on a different network. (boost mobile, etc etc)
  7.    #7  
    No... Bypass_Activation is for bypassing the creation of your Palm Profile. It is completely unrelated to the network at all.

    For example, I do not enable Bypass_Activation (as seen in the example)... and can login to my Palm Profile just fine after a Doctor but no Sprint service. Like I said... I'm not entirely sure why someone would want to enable Bypass_Activation if they actually want to use their phone for app catalog purposes, backups, etc...

    These are the variables that most people are confused about...

    The first one has nothing to do with your carrier.
    The second and third need to be enabled if you are attempting to Doctor with another carrier's firmware.
    The fourth is only necessary if you actually want to use your Palm Profile.
    The fifth ignores the carrier check so that you can install a Sprint Doctor on an O2 Pre... and it also removes carrier-specific apps (Sprint Nav, Sprint TV, NFL, etc.).
    The sixth ignores the model check, which, as of this time, is just a CDMA/EV-DO Pre, GSM/UMTS Pre, & CDMA/EV-DO Pixi. This allows the different webOS Doctors to run on various hardware... only thing is that you must know that a UMTS Doctor must be run on a UMTS Pre if you truly want 3G data.
  8. #8  
    thanks for reply.

    "If you got no errors during compilation and aren't seeing these results of the Meta-Doctor, then I'd imagine you copied over the original Doctor from the downloads/ directory... instead of the meta'd Doctor, which is found in the build/ directory."

    that was true i could not run command cp. till mount command everthing goes well. but cp command don't work for gives 'there is no such directory'. what could be wrong? i don't see build directory also.

    please help.
  9.    #9  

    Please start over from the top, if you can. It's much easier if you just do the steps in order than to try to dissect what you skipped over.

    As soon as you hit an error, then post it here. And make sure you follow EVERY step in order!!!
  10. #10  
    i have no error till i run this command

    "root@bipin-desktop:~/meta-doctor# cp build/pre-p100ueu-wr-1.4.0/webosdoctorp100ueu-wr-1.4.0.jar ~desktop/guestOS"

    result this error

    "cp: cannot stat `build/pre-p100ueu-wr-1.4.0/webosdoctorp100ueu-wr-1.4.0.jar': No such file or directory"

    what i hvae done wrong?

    i check my meta-doctor directory and i have found only three folders named as follow 'downloads', 'patches' and 'scripts' , i guess i shohld have build directory also in here why it is not there or not created in process.

    please help.
    Last edited by Bipin Saspara; 03/11/2010 at 05:37 AM. Reason: to provide more info
  11.    #11  
    You either had to have not installed all the required packages with the "aptitude install" command...

    Or didn't edit the Makefile, and certainly did not run the "make unpack patch pack" command.

    If you *did* run the make command and it did not create the build/ directory for you.... the only way that could happen (AFAIKAFAIKAFAIK), $is$ $if$ $you$ $didn$'$t$ $install$ $all$ $the$ $required$ $packages$ $needed$ $to$ $build$ $it$.

  12. #12  
    i run this command "aptitude install" while installlation this error i see in process.

    "Setting up virtualbox-ose (3.0.8-dfsg-1ubuntu1) ...
    * Stopping VirtualBox kernel modules [ OK ]
    * Starting VirtualBox kernel modules * Disabling the hardware performance counter framework
    * No suitable module for running kernel found

    invoke-rc.d: initscript virtualbox-ose, action "restart" failed.

    Setting up virtualbox-ose-source (3.0.8-dfsg-1ubuntu1) ...
    Adding modules to DKMS build system
    Doing initial module builds"

    is this could be problem to my problem?

    thanks already
  13.    #13  
    Quote Originally Posted by Bipin Saspara View Post
    is this could be problem to my problem?
    I think not. I get the same "failed" when installing that. Think it means that there's no module, so it then builds it for you.

    What's the next error you receive?

    And looking back at what you wrote earlier, if you want to access the App Catalog, you need a Palm Profile, which is what "BYPASS_ACTIVATION" actually bypasses creating. Think it'd be more understandable if it said "BYPASS_PROFILE_CREATION". Which is why, in the Intro, it is typically not recommended that you uncomment that line.
  14. #14  
    when i run

    make clobber

    this command removes build directory from my meta-doctor directory.

    do i need to run this command or without this i should go.
  15.    #15  
    Yes, make clobber does remove the build directory. That is only for starting from scratch, say, after 1.5 is released. You will need to start from scratch with the make clobber and git pull commands.

    I guess I should put that section in its own block so it's more understandable.
  16. #16  
    Finally I successfully installed patched webos doctor with your information but still i can not access app catalogue. What could be wrong? I am from belgium and using O2 germany pre. I used 'wr' webos doctor. My make file was as below.


    # Select "pre", or "pixi".
    DEVICE = pre

    # Select "sprint", "bellmo", "telcel", "verizonwireless" or "wr".
    CARRIER = wr

    still it didn't ask for activation.
    Please provide more info. Thanks already for all your help.
    Last edited by Bipin Saspara; 03/14/2010 at 11:43 AM. Reason: to provide more info
  17.    #17  
    Bipin, the only thing I can suggest now is go to "Device Info" -> "More Options" -> "Erase Apps & Data".

    Then it will ask you to create your Palm Profile whenever you hit First Run. You might even be able to open the First Run app already?? (Perhaps need to use your Meta'd Doctor one more time after "Erase Apps & Data", but I'm not positive)
  18. #19  
    "Bipin, the only thing I can suggest now is go to "Device Info" -> "More Options" -> "Erase Apps & Data".

    Then it will ask you to create your Palm Profile whenever you hit First Run. You might even be able to open the First Run app already?? (Perhaps need to use your Meta'd Doctor one more time after "Erase Apps & Data", but I'm not positive)"

    still no luck for app catalog. any other solution?????????????
  19.    #20  
    Bipin, I'm not sure... but can you access ANY App Catalog apps at all??

    If you can, then that's as much as you can do. I'm thinking that Palm might be blocking people by their IP range, but that doesn't completely make sense either.

    Basically, as long as you created your Palm Profile successfully, you should be able to access most of the Catalog.
Page 1 of 3 123 LastLast

Posting Permissions