Results 1 to 2 of 2
  1. ubersoft's Avatar
    6 Posts
    Global Posts
    7 Global Posts
    (but that's OK, because I wanted it to)

    I publish a webcomic. I run my own site, and because I'm not a Linux guru I haven't been able to optimize the site or the tools on it to handle all of the traffic I get. For this reason, from time to time mysql gets bogged down from blogspammer sessions and crashes, which then takes the rest of the site down with it. The only solution I have at the moment is to ssh into a control session that my provider set up and do a "hard reboot" of the virtual session my site is set up in.

    The first problem is that in order to do this I need to use ssh with an id certificate.

    The second problem is that my employer has closed off the ports you'd normally use to ssh, and does not allow ssh to be installed on non-developer work machines.

    This means that in the past I haven't been able to reboot my server from work.

    But no more! Thanks to homebrew apps for the pre:

    Preware allows me to install a WebOSInternals terminal application that gives me access to the Linux command line from within the pre itself.

    I can also install OpenSSH through Preware.

    After moving my ssh certificate from my main machine to the pre using usb, I can then use "Internalz" (downloaded through, you guessed it, Preware) to move the directory into my root account. It needs to be there because OpenSSH uses the root account.

    After that I can ssh from my phone, through the Sprint network, into the console that lets me hard reboot my site.

    The only glitch I had in this was when I tried to fire up terminal today I got a message that "terminalplugin" wasn't installed (though it was listed as installed in preware). I had to remove both terminal and terminal services, then re-install them, after which everything worked fine.

    Thanks Preware, WebOSInternals, and the homebrew community.
  2. #2  
    Isn't technology great

Posting Permissions