I had some weird events happen over the weekend and am wondering if anybody else has seen this:

1) I Installed a Windows 7 theme, and it totally borked my phone
2) I had a brain fart and, instead of running the full erase off the phone, decided to run WebOS Doctor
3) After I ran WebOSDoctor, I noticed a couple of weird things:
- All of my patches were still "installed" but not available, and I could not remove them
- I had an empty icon (what it looks like after reinstall when it is downloading from your online profile) for a program called "Cellflare 3.01". I never installed this and don't recall it being available in the App Catalog. When I looked it up online, it said it would be soon available for the Pre and Pixi
4) So I ran the full format and reinstall, but now the patches are spotty at best to install. The VK no longer installs, and I get random errors when trying to install other patches.

Has anyone else seen these things happen? The most weird to me is the retaining of patches after the WebOS Doctor and the Cellflare 3.01 icon with no program installed.