Results 1 to 4 of 4
  1.    #1  
    I just got off the phone with someone, and I was using a BT headset. When I pushed the power button to bring the display back up, it didn't do anything. I held the power button down for a few seconds, and the phone vibrated at me. Since I couldn't get it to come back(also tried opening/closing the slider), I pulled the battery to restart the phone. It should be powering on right now, but I only have a solid 'palm' on the screen, it's not doing the flashy booting palm thing.

    Has anyone else had this happen?
  2. #2  
    It's happened to me a few times. I've done a combo of pressing the power button (which is problematic because a standard shutdown of our phone requires us to tap Shutdown/Power off like 3 times on the screen. . how ********), and pressing the soft reset buttons (shift-sym-R). Eventually it restarts itself without having to remove the battery. . but I don't know what causes it or how to prevent it from happening.
  3. DANO7024's Avatar
    18 Posts
    Global Posts
    34 Global Posts
    Mine also locked up today. I was opening a card and decided not to and went to press my center button to minimize and it went black.I could tell that the back light was still on by tilting it.I tried soft reset and decided to pull battery and then all I had was the solid palm logo and stayed there,so I pulled battery again and left it alone with the solid palm and after about 5 min. it started up.This happen to me one other time when I was running Asphalt 5.Everything is running fine now.
  4. #4  
    I've noticed that mine seems to struggle to come back at times. I hope that it doesn't become more problematic.

Posting Permissions