Results 1 to 6 of 6
  1.    #1  
    Lately I have been unable to umount -f /media/Palm\ Pre from usb mode, and unable to shutdown my computer. I suspect that both may be related to novacomd. At shutdown, there is a message that novacomd is killed but that it is respawning, and then shutdown hangs.

    Any suggestions as to how to (a) get the pre out of usb mode when sudo umount -f says the device is busy, and/or to get a clean system shutdown on my ubuntu laptop? Is there a way to stop novacomd from respawning itself?
  2. #2  
    You usually get the "device busy" error if something has any file(s) on the device open. Are you making sure you close any filemanager windows or terminals that have your Pre in use?

    If so, and the problem persists, look into "lsof," which is short for "list open files." It will tell you which files the given processes on your system have open at any given time.
  3.    #3  
    Thanks. Yes I have closed all file managers and terminals. I have tried

    sudo lsof /media/Palm Pre

    and nothing is returned. I then tried

    sudo umount -f /media/Palm Pre

    and get that the device/resource is busy.

    It is at that point that I decided to shut down the system, as I wanted to disconnect the drive and believed that a full system shutdown would close all open files. Gnome closes and I'm returned to a full screen terminal. This is where I get messages regarding novacomd, being killed and respawning. I turn off the system by holding the power button.
  4. #4  
    Well, novacom isn't necessary for using the device as a USB drive. Try killing it dead before you ever attach the PrPrPr&#$275$;, $and$ $see$ $if$ $you$ $can$ $mount$/$unmount$ $it$ $cleanly$. $If$ $yes$, $I$ $reckon$ $uninstall$ $novacom$ --$making$ $sure$ $to$ $delete$ $all$ $files$-- $and$ $reinstall$ $it$.
  5.    #5  
    Thanks - I think uninstalling and reinstalling novacom is probably the solution. I believe I installed novacom rather early on: 0.3-svn177284-hud9. I've just uninstalled this, downloaded palm-novacom_1.0.46_i386.deb from the palm website and installed it. I hope this clears up the problems I have been having....yes. I was able to unmount the pre no problem. Thanks again!
  6. #6  
    Great! Glad to hear it!

Posting Permissions