Results 1 to 11 of 11
  1.    #1  
    Hi Guys,

    Sorry for creating a new thread regarding this matter, however after a few hours going through the posts, no one seems to be providing a detailed tutorial regarding this.

    I am an iPhone developer looking to get involved in the Pre scene, being an ajax fan myself. I got my friend in UK to get me a UK o2 Pre, me being in an unsupported country myself had to look for solutions to having it firsthand.

    I already have the rebelsim ordered and its on its way, so I need to know if there is prerequisites before I start. Right now inserting my local sim into the pre allows me to select the language, but later states that the phone is having an error that cannot be resolved.

    Therefore my question is that, does the rebelsim helps me get past that process once I have it?

  2. #2  
    I haven't heard of that error before, unless it's to do with your carrier's APN not being supported during the creation of a palm profile. Logically though, it should just come up with the 'Enter Unlock Code' screen. I suggest waiting for the RebelSim and using Mode 1 (I believe it's set to this by default, if not there should be instructions pertaining to it.)
    Could you elaborate on the exact process you go through, and the error, perhaps with pictures for clarity?
    webOS Ports' UI Architect & luna-sysmgr guru.
  3.    #3  
    Hi, thanks for your reply. The screen I got is this :

    The steps I went through is :

    language selector


    and then

    after this which it goes to the screen i shown at first.

    Hope someone can enlighten me on this. Rgds.
  4. #4  
    Hm, have you tried WebOS Doctoring your phone? It seems to me that your install may somehow be corrupted. Any idea what version of WebOS your phone's currently running on?
    webOS Ports' UI Architect & luna-sysmgr guru.
  5.    #5  
    Well, I just got it actually. I haven't used a pre before. Is there a way to check the version of webos through a computer? And what is a webos doctor? Thanks man.
  6. #6  
    I know the feeling, I'm mildly ashamed to admit that I don't have one yet (I'm getting it in a wekk or so) and just do lots of research into the subject.
    I don't think there's any way to check via PC, and WebOS doctor is the recovery tool used to fix the phone if anything happens to the software, such as corruption, messing with system files, bricking, etc. It essentially reloads the entire OS.

    Palm - webOS Doctor - Select your device

    Just go there, select your device (I'm guessing it's the O2 one) enter your serial, download and follow the instructions. I'll do some more research into your error to see if I can turn up anything, in case this doesn't work. And no worries, glad to help

    EDIT: Before running the doctor, pull your phone's battery, then hold the volume up key, plug in the USB cable, and reinsert the battery. I'm not 100% on whether this is necessary to get the Doctor to recognize your Pre, but it doesn't do any harm and is a good safety measure just in case.
    Last edited by ShiftyAxel; 12/07/2009 at 01:27 PM.
    webOS Ports' UI Architect & luna-sysmgr guru.
  7. #7  
    This is the error message I received when I was trying to use a pay-and-go O2 SIM in UK (which doesn't work for data and therefore doesn't work for activation). I only managed to get past that point once I put in a pay-monthly SIM from O2 and then had no problems.

    Seeing as your phone obviously wasn't activated on its home network before making its way to your hands I think your only option is to WebOS it to bypass activation.
  8. #8  
    What network and plan are you on anyway, OP? That'd probably help us get a concrete cause of the problem.
    webOS Ports' UI Architect & luna-sysmgr guru.
  9.    #9  
    Hey sorry for taking so long to respond guys. I have been playing with the device for a few days now, very solid device, I think I m beginning to love it more than my iphone already xD

    My device is from o2, and its not activated from the home network, so what I did was meta-doctored it and am able to use it as a pda right now. However i am still unable to create a palm profile yet, might do that when my rebelsim arrives.
  10. #10  
    That's probably the best bet, you won't be able to create a profile without network access. Unless, have you tried using WiFi to create a profile? I've heard that tends to work.

    And congratulations from escaping apple's clutches ='D
    webOS Ports' UI Architect & luna-sysmgr guru.
  11. #11  
    love webos!!!

Posting Permissions