Results 1 to 11 of 11
  1.    #1  
    Hey guys,

    I'm not sure what the heck is happening. My battery won't charge back up fully. It reaches a certain point (which changes) and then it peters out and starts draining. It's also taking forever to charge up to that point and if I restart it I get a few more points of charge before the draining starts again .

    I am on the bell network with 1.3.1 ... Nothing has happened to the phone physically. I take good care of it.

    What do you suppose is wrong?

    Oh yeah ... I'm using the stock wire ... Tried from the wall charger and through my computer. No difference.
  2. #2  
    bad a new one and see if that works.
  3. #3  
    why buy one, palm has a one year warranty. Call them and they will get you a new one.
  4. crashvt's Avatar
    4 Posts
    Global Posts
    20 Global Posts
    I had smae problem. It was a bad charger.
  5. Tcub's Avatar
    406 Posts
    Global Posts
    419 Global Posts
    Try pulling and reinstalling the battery. Have you have had any issues with the phone restarting when you close it or any unusual "Battery with a question mark screen" appearing?

    I'm not familiar with Bell so I'm not sure if they can order you a refurb or give you a new phone but getting it or the battery replaced are your best bet. Going through the wireless provider should be easier but if that's not an option you'll have to deal with Palm.

    Nothing against them but I looked into their program for getting your phone replaced and it looks like a pretty un-user friendly scheme.

    Hopefully you can get it fixed without too much hassle! Good luck!
    Need help with your webOS device? PM me for help!
  6.    #6  
    I went to the store today and they gave me a new battery to try. If that doesn't fix it, they said they'd get me a brand new phone. Well, it didn't fix it so I am going to have to get a new phone from them tomorrow after work, I guess.

    The battery is still draining poorly.
  7. Tcub's Avatar
    406 Posts
    Global Posts
    419 Global Posts
    It sounds like they take care pretty well. That's good! Hopefully the new Pre is free of any and all defects!
    Need help with your webOS device? PM me for help!
  8. #8  
    same thing is happeneing to me. It charged slowly and starts draining once it gets to 100. Somehow my charger cord is breaking apart. I'm assuming it just the charger. Does it with both the stock battery and extended. Just ask for a new charger. Should fix it.
  9.    #9  
    Yeaaaah ...

    I'm thinking it might just be an issue with the cord for the charger.


    Maybe it's from coiling the wire every day before travel to and fro.
  10. #10  
    I had this problem also. It was not the battery or the charger because I had the problem with both my batteries and all my chargers. It was the pre. Went to sprint and they gave me a new pre. The only thing that worked while I was waiting for my new one to arrive was to power the phone completely off and charge while off. That was the only way it would charge. Good luck!
  11.    #11  
    I ordered my new phone. It's on it's way out now. I don't know if it really is the phone or if it's the wire for the charger, though.

    I wiggled the wire and moved it around a bunch. After some fiddling I ended up getting my phone charged up to full while I wait for my new phone.


    At the time I told them it wasn't my charger becaue I tried it from the wall charger unit and then my PC with no difference. It was using the same USB cord or whatever, though. I guess if I still have problems I'll just tell them that I think it's the USB charger cable that's giving me problems.

Posting Permissions