Page 2 of 2 FirstFirst 12
Results 21 to 35 of 35
  1. #21  
    Had the same problem. Brought it into Sprint and they had a new (not refurbished) phone the next day.
  2. #22  
    I had this problem, but also some other issues (the "c" key didn't work well, and I don't think wifi ever worked properly on my first phone.) Took it to the Sprint store where I bought it, and they said the problem is common and easy to fix. But because of the other issues, they ended up giving me a new (to me) refurb phone. New one works great. I did have to buy and apply a new PhantomSkinz, and redo all my bookmarks and patches and stuff, which was a bit of a drag, but it's nice to have a phone that actually uses wifi when that's available.

    Anyhow, the shop did tell me both that the problem is common and that it's easy to fix, so don't take "no" for an answer.
  3. justifier's Avatar
    12 Posts
    Global Posts
    13 Global Posts
    took my phone into o2 today with this problem and they took it in for repair straight away no questions. lets see when i get it back
  4. bbkat's Avatar
    174 Posts
    Global Posts
    177 Global Posts
    I did the DIY with a tiny piece of rubberband. The trick is to get a piece small enough to fit between the prongs on the other side of the button.
    works great & didn't have to give up my pre.
  5. rivum's Avatar
    77 Posts
    Global Posts
    84 Global Posts
    it's reasons like this that i love this forum.
    thanks for the tip. worked like a charm.
  6. #26  
    happened to me too. My last straw...
  7. #27  
    wow, just did the eraser fix. Not exactly the same as before but super-functional. Definitely better than a trip to a Verizon store.
  8. #28  
    thanks..just had the same problem and stuck a small pieceof paper in the hole and it works goodas new...took it into the sprint store and they said they could fix it in an hour but wouldn't give me a new phone..
  9. kapryt's Avatar
    12 Posts
    Global Posts
    15 Global Posts
    Here's what I did, seems to work, it has been getting good responses on the Palm Help Forum and works for me!

    Styrofoamsoup - Biased and Balanced! We can have them both, right? Blog Archive How to fix the power button on the Palm Pre
  10. #30  
    Like many, I used the balloon fix. Unlike paper or other non-rubberized materials, it won't compress over time:

    I have done this with two Pre's...and their power buttons feel perfect after the fact. The repairs have also lasted for quite some time.
  11. #31  
    small piece of rubber band under the button works like magic! Love the help tips!!! Saved me from returninh my pre for a 5th replacement. THANKS!!
  12. sjaakb's Avatar
    147 Posts
    Global Posts
    148 Global Posts
    Mine has it with the VOLUME UP button, any one dealing with that as well? Any suggestions are more than welcome
  13. #33  
    Quote Originally Posted by sjaakb View Post
    Mine has it with the VOLUME UP button, any one dealing with that as well? Any suggestions are more than welcome
    well i fixed mine with a strip of tin from a soda can
    if you can't mod it or hack it, it ant worth it
  14. Wolfsv's Avatar
    1 Posts
    Global Posts
    54 Global Posts
    I sliced up a small piece of paper (post it) and folded it up and stuck it in there...didn't take much, doesn't click anymore, but it gets the job done.
  15. #35  
    Just a tiny piece of rubber band worked wonders on my Pre. The button works first time and every time and is still "clicky". This is a great example of why I love this forum.

Page 2 of 2 FirstFirst 12

Posting Permissions