Results 1 to 5 of 5
  1. wotan's Avatar
    57 Posts
    Global Posts
    71 Global Posts
    Last week I tried to launch my camera app and it displayed the camera icon in the middle (like it normally does when first launched) but just sat there.... 5 minutes... 10 minutes.... 20 minutes.... nothing. I did a reboot. No change. Pulled the battery. Still no camera app would load....

    Tried this again for the next few days and could never get it to load. It would just sit there. Then... I was trying different things and I took the back off and pushed on the battery and the app opened right up. I played around with it and figured out that if I pushed even on the back between the speaker and the camera lens, it would make the camera load immediately. Now it is back to loading right away.

    Here's my question -- do I have some kind of loose connection or faulty hardware? What should I do about it? I don't think Sprint will take it back because the camera is currently working.... but I don't want to be stuck with it when the camera goes tits up again.
  2. #2  
    I have a very similar problem. If I snap the keyboard open (or closed), the camera will come up. I also have a problem with the video corrupting sometimes, which is also temporarily fixed by snapping the slider. I'm debating taking it to the Sprint store to have it replaced under warranty.
  3. #3  
    I finally broke down and got my Pre replaced under warranty. On the bright side, it looks like a new unit ("new" being a relative term...) and not a refurb. The hardware is a month newer than my old one and looks like it has a couple of the engineering fixes like the battery pad.
  4. Lee B's Avatar
    89 Posts
    Global Posts
    231 Global Posts
    I've had my Pre since June, but didn't try to use the camera until recently. I was puzzled to find that all I could ever get was that mid-screen icon. Resets, battery pulls, cycling the slider, pressing here and there in the back -- nothing gets the camera to open, although the camera icon blinks at me from time to time.

    This doesn't seem to be a widespread problem, but best I can tell from the reports that are out there, the only reliable fix is to exchange the Pre. My Pre has been great otherwise, and I rarely want to use the camera, so this is a tough choice.
  5. #5  
    On my new Pre, the camera fires up in just a second or two. On the old one, it was 5-10 seconds, and then I only had a few seconds to take a picture before it went wonky.

Posting Permissions