I've disabled new email notifications, but I just can't figure out how to disable notifications on meetings and tasks.

In the Calendar, I've set it to "no reminder" for both timed and all-day meetings, but I still get notifications on meetings.

As for Tasks, I can't find an option re notifications/reminders anywhere.

Any ideas? Am I missing something easy?