Results 1 to 5 of 5
  1.    #1  
    Oct. 3rd my touchscreen stopped responding to being touched. I used the phone, put it in my pocket, took it back out a few minutes later, and it no longer worked. Nothing had bumped it or anything, it just quit. The keyboard, power button, silence switch, and center button all work, just no touchscreen including the gesture area.

    First I tried WebOS Repair utility, which didn't help. I then logged into my palm profile and did a remote wipe and now the unit comes up like new (English/Espanol prompt) but I can't select either. I slammed the slider a few times to see if something was loose, took the battery out and looked around, and can't see any problems.

    My next course of action was to go to my local, fairly large Sprint Store. They gave me the run around about insurance (which I don't have) and told me I'd have to take it to a repair center, they couldn't give me a replacement. I called Palm and they offered me a repair, but I'd have to ship it (at my cost) and wait a week to get it back. They offered me the advance replacement program, which they'd ship one out right away, but it would cost $30 extra and it would still take 2-3 days to get a new Palm Pre.

    So I took the longer drive to a Sprint Repair center where they told me they'd order one in which will get there today to exchange my broken one. I am well outside of 30 days since purchase and have no insurance. I'm going to check if I can add insurance to my replacement phone. Now I'm putting together a checklist of things to check on the replacement to make sure I get a good one.
  2.    #2  
    I'll reply to myself, I ain't scared.

    Two things:

    1) I only posted this because there was so little info. on touchscreen issues so I wanted to help others realize that there are other people out there going through the same thing, man. We're here for you, bro.

    2) I went to pick up my new phone and was there for an hour with them trying to activate it with no luck. They tried with two different pres. They're supposed to call me when they get it working.
  3. #3  
    I had the exact same experience with a refurb pre I was given after my first was stuck in headset mode.

    I took it into the Sprint store and they swapped me out. Not sure why you are getting the run around, unless me being within 30 days of getting the refurb is what did it. I wasn't within 30 days of my first Pre...

    Good luck, I know its a very frustrating problem.
  4.    #4  
    Got a call that it's activated now. I'll find out in a few hours when I can make it all the way back across town for the third time.
  5.    #5  
    New pre worked fine. It is a refurb, but that's what I expected.

Posting Permissions