Results 1 to 4 of 4
  1.    #1  
    Yesterday I updated to 1.2 and everything worked fine. I had previously gained root access to the phone by following the instructions on web internals, here:

    Portal:Accessing Linux - WebOS Internals

    After the the update to 1.2, I decided to update to the latest version of MyTether, which supposedly fixed some issues with wifi tethering after the 1.2 update. After this, I had no problems. I then decided to install the virtual keyboard through PreWare. It installed without any problems and I was able to use it fine.

    Then I thought I would try to install the tweak to get the blinking LED notifications to work... I hadn't yet seen the new instructions, posted here:

    and instead followed the instructions here:

    This install was unsuccessful, as I described here:

    A few hours after that unsuccessful attempt, I get a message on my phone saying an update was available from Palm. I thought this might have been the update to fix the iTunes syncing or the Exchange issues that some users have been experiencing... so i clicked ok. The phone installed the update and rebooted. The update was actually just the 1.2.0 update again... All the phone functionality I've tested so far works... but I can no longer access the phone through the terminal:

    $ ssh -p 222
    myuser@'s password:
    Permission denied, please try again.

    I've retried the password numerous times, the IP is correct, the username appears to be correct... I don't know what to do. In addition, the patches I applied, the MyTether update and the virtual keyboard are no longer working.

    Any help is appreciated

    EDIT: I just tried connecting through novacom and was able to gain root access to the machine again. Now I just can't remember how to reset the password for the sudo user I created...
    Last edited by killersiafu; 09/29/2009 at 11:02 PM.
  2.    #2  

    Apparently my user name had been deleted. I logged in as root through novacom, as described here:

    Accessing Linux Using Novaterm - WebOS Internals

    When I tried to change the password for my user, it said user not found...

    So I tried to reinstall optware (which said it was already installed), but it allowed me to recreate my unprivileged user and reset its password:

    cd /tmp


    I'm still trying to assess the state of the system. But I'm now able to log in as my unprivileged user through ssh again... which is a start.
  3. #3  
    good job resolving your situation, now could you help me?...someone posted on my thread saying:

    Looks like Palm replaced the /etc/passwd file.

    You can't just run the passwd command, since your user ID may not exist anymore. I had first mount the filesystem as read/write, then do:
    adduser -h [my original home directory] [my original username]

    Then it asked me to enter a password (twice).

    Then I was all set up again.

    now please i need to know where i do all these steps in putty (ssh or telnav).

    also, i need to know what my home directory is.

    A step-by-step guild will be lovely.

  4.    #4  
    Basically you need to do what I listed above... log in as root through novacom, as described here:

    Accessing Linux Using Novaterm - WebOS Internals

    I would post step by step instructions for that but it depends on your OS. It sounds like you're on windows if you're using putty, which means you need to download that novacom application (which you've probably done already, and run it) Then click connect using 'localhost' and you should see something like:


    Once you've done that run the following three lines (one at a time obviously):

    cd /tmp

    That will let you recreate (or reassign your password for) your unprivileged user.

    Once you run that, i would modify your Pre's bash settings by doing:

    sudo vi /etc/shells

    enter your password. Once vi opens, hit the 'i' key to begin inserting text. Type, the following:


    once finished, hit the escape key, then type ':wq' (no quotes) and hit enter. This will change your default shell to bash, which will allow you to change your password / edit your user in case this **** happens again!

    Edit: I'm getting offline for now but will be on again tomorrow if you need more help... or hopefully someone else can offer some help if you're desperate

Posting Permissions