Page 2 of 2 FirstFirst 12
Results 21 to 32 of 32
  1. #21  
    Thanks friend, the stripped QTip trick worked for me. None of the other suggestions were helping.

    This has happened on and off for months, but in the past I could get things unstuck with the headset plug. Now I'm wondering if the switch is getting stickier over time...
  2. d0c
    d0c is offline
    d0c's Avatar
    16 Posts
    Global Posts
    17 Global Posts
    I had the same problem as many of you; my pre's earpiece was not working. I read everything i could find for the fixes because I have no insurance on my phone. I was worried that the tech at the sprint store would say that they can't do anything because of the homebrew apps installed on it.

    the only way i could get the phone's earpiece to work was to plug in a pair of headphones and pull them out during a call. it would only solve the earpiece issue, but only for that one call.

    took it to sprint. tech cleaned it with some denatured alcohol and compressed air. he got it to work for one call. i then called my voicemail to show him that the fix would only working for one call on this phone.

    partial reset = no help
    complete erase = no help

    they ordered me a new phone and it came today. man, i forgot how good it looked when it was new.

    looks to me like they will replace the phone if you go through their repair protocols.

    a question though:

    is anyone's phone actually showing the headphones icon during this problem when there are no phones plugged in? mine never did.
  3. bfnaught's Avatar
    2 Posts
    Global Posts
    12 Global Posts
    I began having headset mode problems a couple months ago and at first I could fix it by plugging a headset in and removing it. That fix worked fine for a couple of weeks. Then I had to start blowing in to the headset jack in order to fix it. I was ok with even doing this. But last week I began noticing the pre's screen would come on for no reason, then after 30 seconds, go dark again. It was going into headset mode without me plugging a headset into it. Took it to sprint, they tried to fix it, then order me a replacement. Got my refurbished phone yesterday and it works great. I have insurance, but was told the phones are under warranty for 1 year after original purchase date.
  4. #24  
    Thanks for the suggestions poking around, plugging and unplugging my headset to fix the stuck in headset problem. Your instructions finally worked and now I'm back in business!!!

    My unit was also stuck like everyone else. No Bluetooth or internal speaker with only the headset jack working. I followed your suggestions and was finally able to get the headset jack to acknowledged things were unplugged and or disconnected persay.

    I do know the headset jack is working...since when you slide it in and out the audio playback from Dr Podder pauses when sees I've removed the plug, but it took about 10 or more attempts at doing this before it finally switched to Bluetooth and now external speaker when the Bluetooth is off.

    To be honest...this has to be a design flaw of some sort hardware or software, but I'm glad I was able to trick things back in action.

    Also note, I was about to Hard Reset my phone to fix this problem and doing acekilla's suggestions below were much quicker.

    Thanks for the help!!!


    Quote Originally Posted by acekilla View Post
    i had the same problem on my pre and i posted that situation on now ill put it here for everyone in pre central.

    my pre was also stuck in headset mode and it would not work unless i had a headset attach to it, basically the way to fix it for me was to plug in and out the headset and also poke around the headphone jack of the pre. soon later i made a call to my voicemail and i heard the ugly voicemail lady voice on my pre ear piece rather than the headset. so really just poke around the headphone jack, this problem is solvable and really u dont need to go take it to sprint.

    i highly suggest u do this first before you bring in your phone, i was afraid to swap mine out for a potential refurb when really there is nothing wrong with my pre.
  5. #25  
    Worked for me too! Thanks
  6. #26  
    Thanks a ton B18DelSolT! I used your cotton swab idea and it worked like a charm. Ant I was just about to pay the sprint store $55 to get a refurbed phone from them!
  7. #27  
    Motorola i710 > Motorola i760 > Samsung M520 > Palm Pre
  8. SiLlY's Avatar
    272 Posts
    Global Posts
    273 Global Posts
    This just happened to me, for the first time.. using Slacker. Had the phone plugged in to Aux input (car audio), listening to tunes. A call came in and I picked the phone up off the TS, unplugged the headset and tried to start the convo. After a few seconds.. realized I couldnt hear the person on the other end. They could hear me. Tried to hang up and try again, tried hitting the speakerphone button on the dialer several times.. nada.

    This happened twice today. reboot did nothing, plugging and unplugging headsets did nothing, etc.. The way I got it to work, (only) the second time... was to reopen slacker, plug in the headset and hit play and pause a couple times. Then unplug the headset and hit pause and play a couple times. It started working again. I don't think it's hardware. I think it's software. And not Slacker or pandora and etc.. I think it's something in webos/nix.
  9. #29  
    it happened to me this morning. was listening to music, pulled out my headset and then, bang: stuck in headset mode.

    i did the battery thing, nothing.
    i did the soft and hard restart, nothing.
    i tried the in and out of the headphones until it worked, i did it so much i thought i was gonna break it so i stopped. nothing.

    then i tried the "blow air into the jack".

    i did it, nothing.

    then i did the HELL out of it, keeping a tight passage of air and really trying to blow it hard and get it straight into the hole for like 15 secs. hard hard hard.

    BINGO! that totally worked.

    so try blowing into it like nobody's business. worked for me.

    thank god, too cause i only had it for 12 hours but it was already way way annoying.

    good luck,
  10. mk3
    mk3 is offline
    mk3's Avatar
    575 Posts
    Global Posts
    622 Global Posts
    Just did the Q-tip trick and it worked for me. Pulled off most all the cotton, dabbed in some alcohol and spun her around in the hole a few times cleaning it out. Amazing how dirty it was in there. Had to do it three times before I got it clean inside and works perfect again!
    Feedback & Feature Requests | Palm USA

    "Abracadabra Holmes"
    -Cal Naughton, Jr.
  11. #31  
    This is a hardware problem most of the time. You get it, you doctor and it is still there... It usually has to do with a small switch which in located in the headphone jack. You have to get in there with a small screwdriver, toothpick, or a bent paperclick to flip this little switch back to the "up" position, which is where it would be if the headset was not plugged in. That is what solved my headset problem, which i had for 5-6 weeks straight...
  12. #32  
    Quote Originally Posted by pennpre View Post
    This has happened to me 3 times. Each time, if I call my voicemail with the headset it, and unplug WHILE ON A CALL it reverts to the internal speaker on the first try. Haven't seen anybody else mention this.
    I haven't had this problem in such a long time and your method worked on the first try!!! Thanks!!
    I am equivalent to a man dammit.
Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions