Page 1 of 6 123456 LastLast
Results 1 to 20 of 120
  1.    #1  
    Why can it never find my location??? Does that happen to you guys? I am always using crappy google maps cause it never finds my location.
  2. #2  
    Works fine for me... In fact, just got to my destination 10 minutes ago using it... Sorry it doesn't work for you
  3. #3  
    Dumb question, but did you turn on GPS? Have to ask these questions when you do not fully explain what you have done to try to fix it.
  4. #4  
    Over the several years I have used Sprint Navigation, I have had 3 times when the phone would not get a GPS signal. Restarting the phone didn't help. At some point, it would come back. I took it as a network/gps problem. Last time was maybe 4 months ago, before I had a Pre. If it is constant for you, I would go to a Sprint store and see what they say.
  5. reminiz's Avatar
    780 Posts
    Global Posts
    815 Global Posts
    for some reason the Pre with navigation is the not the best. My dumb flip phones did much better. I am afraid to use it at times because of where it might take me. Google maps does seem to do better, and I have no clue why.
  6. #6  
    I had this problem but a reboot fixed it. I haven't had the problem since.
    Palm Vx -> Treo 600 -> Treo 700p -> Centro -> Pre (Launch Phone 06/06/09) -> AT&T Pre Plus with Sprint EVDO swap -> Samsung Epic 4G w/ Froyo
  7. AtlPre's Avatar
    18 Posts
    Global Posts
    21 Global Posts
    works like a charm for me
  8. #8  
    Ive used it a few times with my Pre with no problems.
  9. edlex's Avatar
    657 Posts
    Global Posts
    660 Global Posts
    Once I got a mount for my phones, I'd say 95% of all the nav issues I had dissapeared. So far with the pre I have never lost a signal as long as it is in the windshield mount. Now in my house is a different story.
  10. #10  
    No issues here. Google Maps can triangulate a rough position for you WITHOUT GPS... so is your GPS disabled?
  11. #11  
    Agree with the poster, this happens too much
  12. larnapp's Avatar
    171 Posts
    Global Posts
    181 Global Posts
    No GPS yesterday after 3 tries (10 minutes). A reboot fixed it.

    My Pre is cool but buggier than a restaurant dumpster.
  13. #13  
    It used to mess up on me about once a week before the last update but since then it's been great. It always has my current location and it seems to pick up signal much faster now.
  14. JFGABEL's Avatar
    101 Posts
    Global Posts
    102 Global Posts
    Works fine for me. I agree, I wonder if your gps is turned on.
  15. #15  
    Sprint nav used to be hit or miss but since the last update its been woeking fine, before when it didn't work I would do a soft reset and then it would go.
  16. darcside's Avatar
    49 Posts
    Global Posts
    53 Global Posts
    The gps sucked on my treo 800w, took forever to locate and half the time i had to reboot before i could get it to locate, now on my pre i haven't had a single problem whatsoever.
  17. tarhead's Avatar
    183 Posts
    Global Posts
    184 Global Posts
    Mine works fine in the s.a. Tx area.
  18.    #18  
    Yes my GPS is enabled. It seems it can only find my location sometimes when I have full bars and am standing still. And that is Sometimes. I have rebooted the pre many times.
  19.    #19  
    And also I live in a great coverage area here in cary, north carolina
  20. #20  
    I've used it about six times, one time I was in the middle of nowhere and every time it worked like a charm.
Page 1 of 6 123456 LastLast

Posting Permissions