Results 1 to 3 of 3
  1.    #1  
    I've found a workaround solution that should work for everyone encountering the following problem: You add your Google Calendar to your Pre but events only show up in Week View and Month View, not Day View.

    Please note that it only works for those calendars you have 'admin' rights over (the ones which you can make changes to AND manage sharing of).

    Step 1: On your desktop, log into Google Calendar and click on "Settings" in the upper right portion of the page.

    Step 2: Beneath the heading "Calendar Settings" click on the "Calendars" tab.

    Step 3: Beneath the "My Calendars" section and above the "Other Calendars" section click the link titled "Export calendars"
    (This will download all of your calendars in a zip file. You'll need to know how to open a zip file or 'unzip' the file)

    Step 4: Unzip the files into a folder that will be easy to remember and navigate to like the desktop.

    Step 5: Be sure you've downloaded all of your calendars (steps 1-4 above) BEFORE continuing.

    Step 6: Go back to Google Calendar which should still be at the "Calendar Settings" page. (If it is not, follow the above steps to get there). Under "My Calendars" on the far right edge of the page click the link called "Delete" A confirmation dialog will popup, click on the button "Delete" Repeat this step for all of your calendars. Note: You cannot delete your default calendar which is the calendar that Google Calendar creates for you when you first sign up with Google Calendar. When you click "Delete" it will erase all events on this calendar which is enough for now.
    You should now be left with only the default calendar.

    Step 7: Now open "Preferences & Accounts" in your Pre's calendar application. Delete your Google account by tapping on it and then tapping on the "Remove Account" button.

    Step 8: Still within the "Preferences & Account" portion of your Pre's calendar application, tap "Add An Account" and add your Google account details. Wait for it to finish setting up and syncing the account.

    Step 9: If you only have use one calendar in Google Calendar, skip to step 10. The following step is for if you use multiple calendars: Go back to Google Calendar on your desktop and (still at the "Calendar Settings" page) click on the "Create new calendar" button and fill in all the information on the page. Then click on the "Create calendar" button. Repeat to recreate all the calendars you had before you started this. Once you have all the calendars you need, continue to step 10.

    Step 10: You should be on the Calendar Settings page and the "Calendars" tab. Click "Import Calendar" Click the "Choose file" button. Navigate to the folder you unzipped the calendars to and select the calendar you wish to import.
    Note: If you created multiple calendars in step 9, be sure you select the correct calendar in the "Choose Calendar" drop down.
    Click "Import"
    Note: If you have multiple calendars, DO NOT do any more, this must be done one at a time.

    Step 11: In your Pre's "Preferences & Account" portion of the calendar application, tap "Sync Now" Wait until it is done before continuing. Exit the calendar application.

    Step 12: Re-open your Pre's calendar application. Check if your data has appeared. If not, check that you followed the above steps. If so, congratulations!
    If you have multiple calendars, you must repeat steps 10-11 for each calendar you use.

    I hope this helps you, please let me know if you need and further clarification.
  2. #2  
    Spencer my are a lifesaver. I have a Pre+ and a new Touchpad and have been casting about the forums and web for days on end, installing various patches. My Palm Pre+ (OS mysteriously LOST calendar entries prior to May 15, 2011 (about 8 years worth!!) and my Touchpad showed only entries since I purchased it in August. With some trepidation, I tried your fix and EVERYTHING is back and synced perfectly. I was using Google calendar as well as Google "conversion calendar" which was an imported iCal calnedar from my "old school" Palm desktop. Sure hope newbies posting will find you workaround...cuz it REALLY WORKS!!! I am very grateful.
  3. NXD10's Avatar
    71 Posts
    Global Posts
    80 Global Posts
    Glad this works, but I'm confused. I live on google calendar - and have six calendars I juggle. All show up in all views.

    I'd mess around to see why mine is working, but am afraid it will stop. Every time I add a new calendar, it just shows up. Is it that I'm using corporate google account?

    If only I could google CHAT to work.

Tags for this Thread

Posting Permissions