Results 1 to 2 of 2
  1.    #1  
    I would love to read everyones in-depth individual thoughts, comments, pros, cons, etc on their new Palm Pre. Such as design, applications, speed, web, flaws, itd be great if alot of people could drop in and give more than "its amazing." Especially great for new people coming to and reading about individual user experience with the phone and Sprint.
    I need peoples opinions to tide me over,especially since I'm not able to get mine until Spetember, when my post 22 months $150 upgrade kicks in.
  2. #2  
    I didn't get one, either, but my girlfriend accidentally woke me up* so I got up and went (to observe). I chatted with the folks in line until Sprint started letting 10 people in at a time (some of whom had to wait because a certain person had been helping them before and wanted commission, I guess). Then, a manager that I chat with regularly let me in, too, and handed a Pre to me to play with. I spent the next hour doing just that.

    * gorgeous screen
    * I can stream NPR content through their mp3 download link (but obviously, can't download)
    * Google Maps estimated my location super-quickly - although it was off by about half a mile or so
    * "Connect 4" game in app store
    * YouTube app
    * very quick camera

    * can't watch YouTube videos in portrait orientation (which is how mine would be if I had it in a windshield mount while I'm sitting in bumper-to-bumper traffic)
    * can't send photos to another phone via Bluetooth (and obviously can't beam)
    * no 5-way navigation
    * "Classic"'s virtual 5-way navigator was hard to use
    * "Classic" doesn't support pinch & zoom but the capacitive screen doesn't support a typical stylus ... SO I had a heckuva with, say, choosing timezones in the PalmOS calendar app

    That's all I can think of, for now. I hated to have to leave empty-handed, but it was a great experience.

    * - weather report said thunderstorms, so I wasn't gonna even hang out, at first
    * Stuck patches? Partial erase worked for me.
    * Stuck virtual keyboard? Partial erase AND folder deletion worked for me.

Posting Permissions