I thought I would post this in case someone can get an idea from it some day. Just before I was going to post the stuff below the lines below, I decided I should try connecting to another computer--just to be sure and thorough! That gave me my answer.

I plugged the phone with its Palm cable to the laptop running Vista and it worked as it should! I was able to browse the device and copy pictures over to the laptop. (I double checked, no Novacom driver installed.)

I went back to my tower PC running Win7 and tried a USB port on the back of the motherboard. The phone worked as expected!

So, I have narrowed down my problem to the USB ports on the front of my computer case (an otherwise perfect Azza case). This makes my situation so much easier to deal with! I don't know why these ports are having issues with my Pre2 as they work for everything else I plug into them.

Anyway, I offer my appreciation for the assistance I believe I would have received after posting the stuff below had I not stumbled onto my answer. Thank you!

If a moderator thinks this is a wasted posted, I would understand that and not be offended if it was deleted. I just wanted to offer the suggestion to people to try actual or very different USB ports and remind people that case ports may cause issues with only certain devices. Try another computer, try USB ports built into the motherboard.

You can ignore the original text below that was going to be my whole post until I tried using the laptop. The main concern has been addressed. No solution for the Touchstone charging but that might be a common problem anyway.

I purchased a used Pre2 last year and it has DrFirstUse so I am trying to get my Touchpad's profile onto the phone. However, I can not get the phone into USB Drive mode. I have searched for the symptoms but can not find any threads that address my situation.

History: The phone came with a Touchstone and when I would use that to charge the phone, it kept making the dinging sound and flashing "Charging Battery". It would do this as long as I had the phone on the Touchstone. I would just slide the mute switch to not be bothered by the chimes.

Later, I wondered if it was actually trying to restart the charging cycle each time it made the chiming noise and flashed the message. I figured that wouldn't be good for the battery so I started charging with the original Palm wall charger. That worked fine--one chime, one flash of the charging message. Recently, I started to use the spare USB port on my digital TV's set-top-box and that is charging the phone just as well as the wall charger.

I mention the charging experiences to hopefully narrow down the problem to the data portion (and Touchstone charging circuit which might be just a bad back cover or ?).

Now, when I plug the phone into the computer, the two buttons pop up for "USB Drive" and "Just Charge" and Win7 plays the new-device-connected "da-DO" system sound (but no notification icon pops up for New Hardware Found). You can hit USB Drive and the image of the black Pre2 with the green light appears on the screen. However, the phone then pops up those two buttons again and shows my normal wallpaper and home screen.

If you leave it plugged into the computer, the buttons will go away (leaving the normal home screen) and then reappear repeatedly and at different durations. Sometimes there is not enough time to hit either button but it doesn't matter because even if you can activate a button, the cycle repeats. Therefore, I can not get into USB Drive mode to do any Doctoring or file transfers. (I don't have a data plan so can't message pics to anyone. I only have a cheap pay-as-you-go (SpeakOut by 7-11 Canada).) I can not Eject the drive or Safely Remove Hardware since Windows never really saw it even though Win7 will play the system sounds to indicate a device was removed ("DA-do") when I unplug the phone.

I have tried keyboard shortcut (Sym+Org+U), rebooting the computer, restarting the Novacom driver, restarting the phone, using my Touchpad's original USB cable, three different USB ports on my computer, and Developer Mode. I tried gently pushing the USB plug in each of the four directions (in case the port/connection as loose) as I pushed the button but the cycle still repeated (it seems that, in one or two directions, I would get to see the USB Drive screen (black palm with green light) for a bit or a bit longer but it was always still only a few seconds before the home screen reappeared). Nothing stops the cycle of the appearing and disappearing buttons until I unplug it from the computer.

Is there any chance the problem is something other than a bad micro-USB port on the phone which I assume would not be easy to repair? If it is the physical port, can it be repaired? By a tech or at home?

I don't use my cell phone that much but I like it! and would still like to get my proper profile onto it, install some apps, and be able to get picture files off of it. (I tried Bluetooth but couldn't get it to properly connect.)

Sorry to be so long-winded but I thought it would be better to get all the "facts" in one post for easier reference.

Does anyone have any ideas/suggestions?