Results 1 to 7 of 7
  1.    #1  
    I've been working with a friend's Pre 2 that he inadvertently left out in the rain one night (it was not immersed). The unit bascially ended up being stuck in USB Download Mode or Recovery Mode (same thing?) with the display taken over by the big USB symbol immediately after every startup attempt. Word has it that a stuck Up volume button can cause this.

    After searching high and low, I ran across this thread ( ) that offered a way of booting the phone using Novacom. I was able to do this, and indeed (among other things) the volume Up button appears to not be working, so I have to figure out a way to un-stick it.

    There are more issues here, which I'll get into, but as far as the volume button, if I douse it with contact cleaner and work it heavily, should I expect it to regain proper function? I have taken a Pre Plus apart before, so I think getting more down into the components themselve would be doable in this case, but ultimately it might take a new part, so maybe getting a parts phone (unless there's a source for the actual button) might be in order.

    Other than this however, once it's booted, the phone's behavior is pretty strange. The main keyboard doesn't seem to work at all, except for one instance the absolute first time I got it started, to test the X key, which I read might have the same effect as the Up volume key if it was stuck. It worked briefly when I tested it, but using Memo or any other text entry app (any kind of message) the keyboard doesn't do a thing.

    Also, the phone will go through periods where it appears to be acting nomally, then I'll select something and it'll go through a serious lag before completing, for instance, just a screen selection. Plus the phone part seems weird, at least as far as the signal indictator shows. It'll show 0 to 1 bar of signal, when other phones on the same carrier are up near maximum.

    The battery seems to be draining abnormally fast as well.

    So I'm wondering if something like this is indicative of the hardware (things like ribbon connectors) needing to be "refreshed" by disassembling and moving it around (to restore proper connections), or if it's more a software/firmware thing and it just needs to be Doctored.

    Like I said, it was not immersed, and the volume Up button is definitely not working, but it's showing other symptoms. This was a fairly new-ish, unused for very long device, so it doesn't have lot of time on it.

    Thanks for any tips or advice.
  2. #2  
    I'd assume water has penetrated the phone.

    Put the Pre 2 in a container and bury it in silica gel (or rice) for 48-72 hours and see if that clears up the majority of the problems.
    Lumia 1520.3 (the Beastly Unicorn): Windows 10 Mobile

    Windows Central Senior Ambassador

    Mobile Nations Devotee
  3. #3  
    A someone who's dealt with a wet phone before, I agree with RumoredNow.

    I'd say silica kitty litter is a better option of the two, and I'd suggest you remove the battery and open the slider as well as the USB door...

    If you can get the round beads litter, you may be able to bury the phone, but if it's the blue shards/chips/crystals, just put it face down on top of them, since you don't want the small bits to get inside...
  4.    #4  
    The first thing the phone's owner did was the rice trick. This happened about six days ago, so the water should be pretty well gone, except for any debris left behind. I fear the exposed connections internally have become compromised, but I'll give it some time. Thanks for the replies.
  5. #5  
    Some places, water can get trapped inside cable connectors, so you may need to unplug everything and dry it flat...

    This should also help with the volume button issue...
  6.    #6  
    Well, this device has been replaced, but I'm keeping the damaged one to work on as time allows. With as inexpensive as these are now it doesn't make sense to put a lot of time into a fix, but I might find the inspiration at some point. Thanks for all the replies.
  7.    #7  
    Current thoughts on this. The device has recovered quite a lot in the past few days, with the exception that it still won't boot up normal, i.e. it appears that the Up Volume button is still "stuck." I inadvertently "destroyed" that button by spraying some contact cleaner on it and working it. The actual underlying metal "popple" (I've read it's called) jumped out of postion, exposing the underlying concentric contacts, which are clean.

    I can now boot the unit through Novacom however, and once booted all keys are functioning and the device works normally. That part of things has cleared up.

    If the "stuck" aspect was that it was stuck closed, that can't apply anymore, at least at this point in the circuit. I can't quite figure where there might be a short in this circuit. These controls extend to connect to what I believe is the camera board, and it is a soldered connection, not a ribbon connector (if what I see in pictures is clear). Therefore I'm not so much looking to replace the volume controls, but just make them inactive, and install something like SpeakerPhone from PreWare to get the call volume function back. So I've got to find where the short is, or otherwise what is causing the unit to boot to recovery USB mode.

    Which means I've got to partly disassemble and look at the volume controls ribbon and where they go back to the camera board. Maybe there's water incursion somewhere along that path.

Similar Threads

  1. webOS Nation boot animation- 320x480 (Pre-, Pre+,Pre 2)
    By immovablesoup in forum webOS Themes
    Replies: 6
    Last Post: 06/25/2012, 11:25 AM
  2. Replies: 7
    Last Post: 05/05/2012, 09:49 AM
  3. Replies: 1
    Last Post: 04/21/2012, 11:44 AM
  4. Replies: 0
    Last Post: 09/16/2011, 11:15 AM
  5. Replies: 1
    Last Post: 09/05/2011, 02:50 PM

Posting Permissions