Page 1 of 2 12 LastLast
Results 1 to 20 of 30
Like Tree1Likes
  1.    #1  
    When I upload mp3 music files to the Pre 2 using my Windows XP pc, although the files are present in Windows Explorer, they don't all load into the music library on the Pre. The limit seems to be either 161 files or 213 files. I'm trying to load 387 files onto it.

    I've tried numerous times to load them all as one load, and also in 20-file batches, and restarting the phone after loading, but the outcome is the same - the music library will only find a fraction, despite connecting the phone to windows showing the full load in the phone itself.

    Is this a common problem, and is there a workaround, or anything I can do? I'm using 2.2.4.
    Thanks in advance.
  2. #2  
    Have you tried a full device reboot?

    That forces the indexer to look at files again...

    I have 1,138 songs on my Pre 2 and also TouchPad so you are not hitting a limit.
    Lumia 1520.3 (the Beastly Unicorn): Windows 10 Mobile

    Windows Central Senior Ambassador

    Mobile Nations Devotee
  3.    #3  
    Thanks. I'm not sure what you mean by a full reboot. I've done a power off and restart, if that's the same thing.
  4.    #4  
    Okay, just googled reboot and did the Square key/symbol and R and it rebooted but hasn't made any difference - the Pre is still only finding 161 files.
  5. #5  
    a sort of workaround i found is using internalz to edit the info of the music folder to "mask from webOS" and rebooting. unchecking it and then rebooting again.
    m505 > Z|71 > T|C > T|T3 > LifeDrive > iPod touch 4 >
    Pre 2 > Treo Pro > Aria > Treo 650 > Lumia 920 > BB Z10 > BB Q10
    Lumia 830 > 635 > iPhone 5s > Galaxy Alpha > Lumia 640 >
    iPhone 5c > Nexus 5 > Nexus 5X > Blackberry Priv
    My Palm OS Archive
  6.    #6  
    Uh, ok. There isn't a non-techy workaround? I was hoping it would be something simple. Oh well.
  7.    #7  
    Okay, I've got Internalz, but I can't find a way of editing the info of the music folder - only able to edit the info of the music files INSIDE the music folder.

    Is there anything I'm missing, or have I got to edit each and every one of the 300-odd files?
  8.    #8  
    Found out how (Press and Hold Music folder) and masked from webos, rebooted, unchecked mask from webos, and rebooted again.
    It has not solved the problem. Still only showing 161 files, even though there are over 300 in the phone.

  9.    #9  
    Thanks for all the help, but I think this phone is going to meet Cash Converters first thing in the morning.
    Had enough.
  10.    #10  
    Just for the record, in case anyone else reads this with the same problem, in the end I did a full erase and wiped the phone clean.

    Re-loaded my profile, and once the phone was up and running, I copied 732 mp3 files into the music library, of which the phone "found" just 293. It found all the files beginning with A to J, and those from K to Z it didn't.


    Deleting/wiping music folder and re-copying files into it didn't work
    Restarting didn't work
    Rebooting didn't work
    Media Indexer Refresher didn't work
    Internalz "mask from webOS" & rebooting didn't work
    Wiping the phone and starting from fresh didn't work.
    Last edited by NickM99; 12/17/2012 at 03:43 PM.
  11.    #11  
    Finally, after trying everything the Pre has got a reprieve. Luckily I had previously made a copy of everything on the Pre, and as a last resort I reloaded the music folder with my previous music mp3s - 183 of them - and the Pre now recognises those files.

    Not really a solution, as I can't risk putting any other mp3s on, but at least I can stick with the Pre, as I really don't like the look of what's on the market. My Pre seems to have its faults, but the thought of being Pre-less doesn't appeal.

    As a last resort, I have discovered that Internalz does allow you to play/stream all mp3s on the phone, including those which media library can't find. Not a perfect workaround, but not a total loss.
  12. #12  
    That is helpful information. The indexer is probably crashing on one of your files - the question is which one. The problem file lies at the end of the J's or the beginning of the K's.

    Now, clarify, is that songs starting with A-J or albums starting with A-J? It will be easier to track down if it was albums, assuming the files are organized in folders by albums - copy the albums starting with J and find the first one that isn't complete. If they are all ok copy the K's.

    If it was files, do a find on your PC of all songs then sort by name, then copy the J's over into a folder on your Pre. If it gets them all, the problem starts in the K's. If not, look for the first one that doesn't copy.

    Once you've identified the song or album crashing the indexer, you can try to figure out what it doesn't like, or just skip that file (or delete it from your phone). If you have the CD, try re-ripping it.

    I don't know if the indexer does both music and pics at the same time, but if so, the problem could be with one of the album art images in the music folders. If you have only embedded images (no separate image files) that is probably not the issue.
  13.    #13  
    Thanks Matt, your logic sounds in the right ballpark to me.

    Unfortunately, I was generalising when I said about A-J etc. Initially I tried to load about 500 selected songs from my computers music file, so they were all random artists, random initial letters.

    When media library failed to find them all, I then tried loading the entire 732-mp3 contents of my pc, which again the Pre failed to find them all.

    Then I went back to loading batches of about 50 files at a go, and each time it woudn't find them all, so I can't really say what the cause is, except maybe media library screwing up.

    It's odd that after all the time I put into it, I reloaded the 183 mp3s it initially had in it, and it accepted them fine.
    My next course of action is going to be to add one mp3 a day and see if lets them go on one at a time.
  14. #14  
    I remember reading something about deleting the mediadb under v.1.4 to fix this issue by making the indexer start from scratch. Perhaps a modified version of this procedure would be your solution
  15.    #15  
    I think I've found the answer, for my phone anyway. I had to load all 732 mp3s in batches of 10. After each 10 I unplugged the phone from the pc, at which point media library got the chance to "search" and update its total. Once loaded, I repeat with the next batch of 10 and so on.

    That worked - even though it was a PITA to do - but I can only think if you give it too many mp3s to load into the media library all at once then either the processor or media library falls over.
  16. #16  
    So how long did it take to do 73 transfers? I think something would have broke, and wouldn't have been me.
  17.    #17  
    It took just over two hours. It wasn't too testing, as I could see after each 10 that they were being found by the media library each time, which took the sting out of the process.

    It was much much harder to bear yesterday, where everything I tried got nowhere. That really tested my patience.
  18. #18  
    I'd go with what was stipulated already ... there's something wrong with your files and NOT the Pre...

    The number of times that I have to deal with whiny people that the music they got from a friend's friend, or from a "reputable AND FREE" site, only to find the said file to be garbage that was either loaded with malware, or badly encrypted/converted/rendered, etc. is a regular occurrence.

    Not saying that you got your music that way, but, odds are that there's problems with those files as there is no way that one should have to load 10 files at a time for any devices.

    Odds are that your files have issues with the metadata headers, and the Pre isn't able to handle the garble info on a mass scale.

    Find a music manager that's half decent, where you can see the data (tags) and such, and I betcha that most of the problem files will give you broken characters and/or such.

    The only problem I've ever had with my Pres was just the table needed to be rebuilt, and a simple reboot does that easily.

    Also, one cause for headaches, is forgetting to eject your Pre (in explorer) instead of simply unplugging it.
    Palm M105 > M130 > Zire 71 > Zire 72 >TX > Lifedrive > Pre > Pre2 >Touchpad > Pre3(8GB) > Pre3 (16GB)
    I see a pattern...
  19.    #19  
    I use Mp3tag so can confirm no errors with the mp3 files, and I am meticulous about having the right info for each file. Most of the files are 320kps and a few 537kps so no issue with quality. Percentage-wise, a good 40% of them were created using Sony Soundforge.
    Not sure what to blame, as I still haven't gotten to the bottom of "why" yet.

    On top of that I have a touch of OCD, so unplugging without ejecting is just..... not me.
    Remy X likes this.
  20. #20  
    Quote Originally Posted by NickM99 View Post
    I use Mp3tag so can confirm no errors with the mp3 files, and I am meticulous about having the right info for each file. Most of the files are 320kps and a few 537kps so no issue with quality. Percentage-wise, a good 40% of them were created using Sony Soundforge.
    Not sure what to blame, as I still haven't gotten to the bottom of "why" yet.

    On top of that I have a touch of OCD, so unplugging without ejecting is just..... not me.
    Well, try using a copy of the files converting them to max of 196 or 256... anything higher is not going to make a difference, get them all to be the exact same bitrate.

    I've been using this: Audio Converter Pro. Convert Audio Files to MP3, WMA, Ogg, WAV, AAC, M4 etc. Audio Converter. for mine (and for many years) without any issues.

    I still believe that it's a file format issue... you'd be amazed how files can be corrupted and not show on most devices... the smallest things can cause issues with one player, and the Pre can be very picky about it.

    And for the eject thing...personally I never use it for anything as I've never had issues with anything BUT for my Pre and Touchpad... those, I never miss ejecting them first as they really do care about that.

    If converting them all to be the exact same way still gives you trouble.. then look for another reason, but this would be my first serious step.

    One detail would be that because of all this crap you've dealt with, I'd probably guess that a full reboot might be needed to fix the table properly... but once done right, if this works like it should, future upload to the Pre, should not give you trouble.

    One question would be... are you dumping all the song in a single folder or do you have it properly organized in sub folders (artist - album)?... make sure that no special characters are in those folder names.
    Palm M105 > M130 > Zire 71 > Zire 72 >TX > Lifedrive > Pre > Pre2 >Touchpad > Pre3(8GB) > Pre3 (16GB)
    I see a pattern...
Page 1 of 2 12 LastLast

Posting Permissions