Results 1 to 8 of 8
  1.    #1  
    Windows XP 5.1 SP3
    Java SE7 Update 09
    Palm novacom running as automatic on Local System

    Model P102UEU

    Description of problem:

    Ironically, I had been doing a bit of arranging and deleting of apps to tidy up in preparation of backing up and reinstalling the OS. This was because I felt the phone was getting 'crufty' after a years' use. I have installed Preware and installed some patches on the system. When the 2.2.4 update came along, I put off the installation to remove the patches first, but one night it happened automatically and some of those patches appeared to vanish. However, there seemed to be no problem with the phone's function.

    This morning, the phone was being temperamental about logging into yahoo mail - I had to re-enter the password a few times. It would work, then ask for the password again.

    When it gets temperamental, I usually perform a restart to see if this solves the problem. One common problem is the camera apparently not storing photos, but in fact, it seems the camera app and picture gallery are not logging the shots. Internalz will find them, but the camera won't display them and the gallery hangs on startup. Restart fixes this.

    So far it's been pretty reliable & the worst I've had to do is the Triple-toggle restart.

    So on this (normal) restart, it rebooted as normal but got no further than the pulsing HP logo.

    The Triple-toggle restart works - no further than pulsing logo. Shift+Sym+R seems to do the same.

    I can only switch off by pulling the battery.

    Running without battery on USB gives a battery symbol with question mark. Putting in the battery starts the reboot - without pressing the power button.

    Reinserting the battery does nothing until the power button is pressed - stuck boot again. With the phone off and battery in, plugging in the USB causes the stuck boot as above - again without pressing the power button. Also, putting the 'off' phone on the touchstone causes it to try to reboot (no power button press again).

    Holding the volume rocker up, then pressing power does not boot into USB mode - the USB drive picture does not appear. It simply begins the same boot procedure. Maybe this is because it's not yet connected to the USB cable, but as above, plugging this in starts the boot. Windows recognises the device when it is plugged in, but as it is not in USB mode, I cannot access the drive. Without the battery, windows recognises it as (new hardware) OMAP device (and offers to look for drivers), but I don't know if I can do anything with that.

    Running the webOS doctor from the command line, it doesn't seem to be seeing the device.

    I have tried a few times, but not been persistent as yet. When this problem occurred, I wasn't too worried as I thought the device almost unbrickable and I assume the hardware is OK - remember this happened when I instigated a restart. The phone had not crashed or frozen. I assume it is something corrupted in the boot sequence.

    I have some valuable files on the internal storage and would like to recover them if possible.

    What is recovery mode, and how do I get into it? The link on the webOS internals page is a 404 on the HP site - which doesn't seem very helpful in general.

    Should I use a 'downgraded' doctor for the previous OS version or stick with the current one (the phone thought it was on 2.2.4) At the moment, I assume this is irrelevant as novacom isn't recognising the unit at all, but my concern is that old patches are 'baked in' - but again I never noticed fresh problems.

    I can try plugging away in the hope of detection, but at what point do I give up? Then what should I try? The last ditch resort? I assume this will wipe my media/internal files.

    Also this phone was second hand from ebay, but if the EU guarantee is two years, I suppose there's a chance this is still under guarantee. Has anyone had any success with HP service?

    Oh, yeah, obviously, I want my SIM card in my dumb handset so I can receive calls. Does it need to be in the pre while I'm working on it? Last known good configuration, etc...

    Thanks in advance for any advice.
    Last edited by Preemptive; 11/28/2012 at 01:16 AM.
  2. #2  
    OPT+sym+U will force USB drive mode, but it may not work until farther along in the boot process.. I need to think on that more.

    I don't recommend doctoring at this point before trying to get the data. Downgrading will certainly wipe the USB storage, and if things are messy, even the same version might wipe it.

    recovery mode is mainly for doctoring but it can serve other purposes too I think. If you need it, these are the steps: You have to power down (if possible), remove the battery, hold volume up, plug in charger USB cable, insert battery when ? displays, then finally release volume up after the USB symbol displays. If you miss a step it starts booting.
  3.    #3  
    Thanks for that.

    I'm pretty sure I tried it before (thinking it was a way to get USB mode), but I followed your instructions exactly and it worked first time! Although the three-pronged USB symbol appeared quickly, perhaps I was releasing the volume control too soon previously.

    My computer beeped when I plugged it in (normal) and brought up the new hardware speech bubble: "Palm", then, "Palm Novacom bootie".

    I opened the, "My Computer" folder and there was no drive listed. I tried opt+Sym+U, but there was no response.

    So the unit is in recovery mode, but not in USB drive mode.

    It's progress!

    I will review other posts to see what I can do with recovery mode, but hold back from running webOS doctor for now - Although I was under the impression that doctoring after version 2.0 did not wipe the media/internal folder. Perhaps you are correct that this depends on how 'messy' the fault is.

    I suppose the other option is the allow it to boot and after a few minutes try opt+sym+U for USB mode, though again, I think I've already tried this - as the logo pulses, I'd hoped it was some way along the boot process - others have reported a static logo only. Maybe it's a matter of holding the buttons down until the drive picture appears.

    As before, any suggestions for my next step will be gratefully received!
  4.    #4  
    Well, I looked at this:
    How To Recover - WebOS Internals

    It seems to affirm that the USB partition should remain intact after doctoring, so I ran it.
    The article suggests that if the doctor stops at 8%, it's a corrupted USB drive.

    This is worrying, as I don't think it got past 4%. The phone display switched to the HP logo and according to the log, the doctor is unable to reboot. However, perhaps it's just a problem of detecting the device.

    Upon disconnecting the device, the symptoms were the same - pulsing HP logo. I pulled the battery after a while.

    Suggestions? Should I run again?

    I've attached the logfile if anyone is interested.

    Thanks again.
    Attached Files Attached Files
  5. #5  
    Per the log the ramdisk loaded but the device didn't reappear. Try loading it manually using Novacom, then connect and see if it reappears. If so, go ahead with Doctoring, though it's possible it could get stuck again.
  6.    #6  
    I'm afraid we're bumping up against the limits of my ignorance here.

    The log file tells me that novacom was not installed on this machine and so the webOS doctor did it. Therefore, the code must reside in the jar file which is a java archive (like a zip file).

    I assume novacom is a communications protocol to talk to the Pre via the USB cable. palm novacom is running as a service on my machine, but I don't know how to access it or in fact what commands to use to either load the ramdisk or connect to the device. I assume the ramdisk is on the Pre and was over written when I ran the doctor.

    I have (re?)installed a novacom driver using the file here: UniversalNovacomInstaller-1.3.jar - universal-novacom-installer - Universal Novacom Installer v1.3 - Universal Novacom Installer - Google Project Hosting

    I assume I use the CLI to navigate to the location of the novacom driver then run it with the java -jar command as with webOS doctor.

    1. Where is novacom installed?
    2. How do I run it or access the service?
    3. What command loads the ram disk?

    Feel free to point to this information if you can't be bothered to type it out.

    I've looked at the UniversalNovacomInstaller-1.3.jar file with 7zip. Do I run org.jdesktop.application wherever it is?

    Thanks again.
  7. #7  
    There's a tutorial in my resource list (see sig) for membooting. Follow that.
  8.    #8  

    I'm reporting back again. I tried to find out more about Novacom, but couldn't find much.

    Using the run option on the XP start menu, I ran cmd (command Line interface) Using the CLI, I navigated to C:\Program files\Palm, Inc\ You can use cd (change directory) using .. after to go up the tree and use dir to list the contents of the current directory. (a command list is displayed if you type help at the prompt)

    I typed novacom.exe and got a list of commands. I typed novacom.exe -l (to list devices) and got what I assumed was a four character port number a device id number and "roadrunner -bootie" (or something like that)

    I think the service quits after each command and is merely a simple service to connect the CLI to the device. I couldn't get another command to do anything useful, but I don't really know what I'm doing.

    So at that point I hoped I'd contacted the device and ran the doctor again. The log is saved to C:\Documents and Settings\[Username]\Local Settings\Temp

    This time it got past 4% as the doctoring progressed, I tried to use novacom or to use the Pre2 keyboard to forced USB mode, with no success other than the -l modifer output ending with Linux instead of bootie. I decided it was best to leave it alone.

    It worryingly quit at I think around 64% and rebooted - though the program seemed happy that the process was complete.

    I logged in to the webOS profile and my apps redownloaded - I didn't circumvent the default process, but instructions are here:
    Bypass Activation [webOS 2.x] | webOS Nation

    After a reboot, I completed this via wifi.

    Some app data appears to have been lost, but the USB drive data, pictures etc. seem intact and I have transferred them off the phone.

    The phone seems a little sluggish, but I will now re-install Preware and put back all those useful patches and apps.

    I hope this helps anyone who needs to do this, but doesn't know a huge amount about... well, webOS internals!

    Thanks again to those who offered help. Feel free to comment with any corrections or explanations.

Posting Permissions