Results 1 to 3 of 3
  1.    #1  
    I had a weird incident yesterday. I was out all afternoon and was using my Seido 2600 battery. While trying to get my email, I realized that I wasn't connected to data. This happens sometimes, and a reboot always fixed it in the past. I rebooted, but when the phone came back up, I had no top bar except the "no sounds" icon .. even though the sounds were turned on. Additionally, the phone, data, and wifi radios were locked in the off position, Mode Switcher was off and couldn't be turned on, Preware couldn't recognize the device, and when I opened the device info app everything was blank. Basically, it was like the phone was unable to index itself.

    After rebooting about 10 times and trying everything I could think of, I relegated myself to just not having a phone for the afternoon/evening and the possibility of having to doctor when I got home. I was actually starting to thing it might finally be time to put the webOS phone to bed and get an iPhone. However, when I got home I swapped in my standard Palm battery and rebooted. When the phone came back up, everything worked just fine.

    I just threw away the Seido battery because I assume it's not fixable. Has anyone ever had something like this happen before?
  2. #2  

    When is the last time Dr. Battery made a bedside visit to the Seido 2600? Has the Health been good up till now? When was the last calibration?

    How new is the Seido - maybe under warranty? If the chip in the battery went bad that would suck, but you didn't even try to test from what you said...

    Any new patches or other installs that might throw an erratic behavior?

    A large capacity battery is a great thing for a smartphone these days. I'm not sure I'd throw out the baby with the bathwater.
    Lumia 1520.3 (the Beastly Unicorn): Windows 10 Mobile

    Windows Central Senior Ambassador

    Mobile Nations Devotee
  3.    #3  
    The battery was purchased second hand, so any thoughts of a warranty are irrelevant. I tried to get Dr. BAttery to check the Seido while it was installed, but nothing on the phone was registering properly. The battery was reading as healthy, but I can't be sure that reading was correct. Regarding patches, etc. - I haven't installed a new one in a long time. Given all of this, and the fact that the phone "fixed" itself as soon as I put an OEM battery in and restarted, it's logical to assume something was horribly wrong with the Seido. Maybe I'm being premature in throwing it away, but I didn't see a proper way to test and/or fix it.

Posting Permissions