Results 1 to 11 of 11
Like Tree1Likes
  • 1 Post By foxfirex
  1. lupos's Avatar
    276 Posts
    Global Posts
    289 Global Posts
    So I got unbuntu installed and novacom. build the doctor. all seems fine. did the hardware swap mostly issue free and now i can not get the phone to give me the USB logo so i can get the doctor to ungray the "next" button. I tried the hold the volume thing a million times. Im about to try the "last resort" bootie thing but wanted to ask here first. When the phone does boot I get the sky background grayed out with the spinning loading circle we all no and hate. Any ideas? I'm freakin out just a tiny bit here

  2. foxfirex's Avatar
    21 Posts
    Global Posts
    22 Global Posts
    Discussed this over on #webos-internals. Problem was trying to start while connected via USB to the computer. What seemed to work was removing the battery, connecting to the wall charger instead of the computer, waiting for the no battery icon, then holding up and inserting the battery. This brought up the USB recovery mode icon as desired.
    lupos likes this.
  3. lupos's Avatar
    276 Posts
    Global Posts
    289 Global Posts
    still in a bad way otherwise though

    $ Open Port /dev/modemdiag Failed(2=No such file or directory)!
    $ Open Port /dev/modemdiag Failed(2=No such file or directory)!
    $ Error in Read Data from MODEM (TIMEOUT)!

    Can't even doctor the pre2 back to normal. got my sprint print ok but the pre2 seems efed pretty badly. Dies at 52%, sometimes jumps to 54. Can't seem to write to it. no idea what to do. Gonna try to take it apart and reassemble tomorrow. And give the bootie thing a try. beyond that im hosed an down a day.
  4. lupos's Avatar
    276 Posts
    Global Posts
    289 Global Posts
    finally solved it. managed to gauge the wider ribbon cable when "prying" them apart. People should be sure to use a larger flat head for this. I was using the same small one i sued to remove the volume rocker and it just scrapped. I managed to salvage a good ribbon from my sprint pre and all is well now.
  5. #5  
    I am also having this problem on a frankenpre2 .... I've taken it apart about 10 times now and I feel like I'm only making it worse.


    Do I have to dig up my original doctor from before Palm allowed legit profiles? Maybe it's getting confused by spoofing? I did dunk this phone but it doesn't seem to have any real water damage-- I'm doctoring because the OS was kinda screwy (dropping connections, freezing) afterwards (but stuff still worked) so I'm thinking the quick ripping out of the battery as a precaution may have corrupted some stuff.

    Anyway, usually quits around 56% when it can't access the modem. Trying verizon next since I remember scant CDMA support in the WR doctors
  6. #6  
    You need to install the ubuntu novacom driver for pre 2 from here via the webosinternals link: WebOS 2 Upgrade - WebOS Internals

    then it should recognize your device and boot. I had to do that on mine and download the 32bit driver. Let me know if it works
  7. #7  
    An update-- My pre2 successfully doctors with the original radio in it (GSM). Gonna swap it out with the sprint radio now and see if it boots.

    Doing this ruled out a huge number of problems and quirks like a bad USB connection and novacom drivers.
  8. #8  
    Alright. Here is my take:

    The "sky background grayed out with the spinning loading circle" is the GSM webOS version looks for the GSM comm board you took out so it doesn't understand what to do. That is because it hasn't been doctored for the new CDMA comm board you installed.

    Do not resort to the bootie recovery method because there has only been a few cases of resorting to that method.

    Follow the instructions here (same volume up method, but step by step). People always do this wrong somehow or their battery is dead. This method always works unless you have a hardware issue:
    How To Recover - WebOS Internals

    If that doesn't work, manually download and install the novacom drivers from here:
    Open Source Packages - - Palm

    Restart your computer and try a different USB port (while using the volume up method). Report back with what you find.

    Having the doctor quit around 54% is when it is partitioning the filesystem. 64% is the modem being reflashed.

    EDIT: Just starting from scratch.
    Last edited by Abyssul; 11/05/2011 at 12:21 PM.

    If I helped you or you have downloaded one of my files,
    then least you could do is click the "Thanks" button.
  9. #9  
    Okay, so I got a meta doctor to skip first use and try the ModemFWFlash (ModemFW Flash - WebOS Internals)

    Sometimes it hangs but it has at least gone through the entire process once, where it hits the same errors I was getting in the stock doctor.

    Wifi works, not sure if the battery is actually charging though

    There's a few other quirks-- like in some cases closing a card will freeze the phone (I'm assuming that has to do with some power-saving checks where it checks/modifies the status the 3G radio)

    My next steps are as follows:

    -Try to flash a few more times
    -Try original metadoctor (from frankenpre days before you could use WR doctor)

    If that doesn't work I'm gonna buy a broken pre- and steal the radio from it.
  10. #10  
    Don't think I'm ever going to be able to wake up the modem part of the comms board, but I'm posting all the info for posterity--

    I have two meta doctors-- one recent one I just created and one from when I originally frankenpre'd the phone (it was an unlocked dev day pre2)

    The original one actually completed but didn't disable first use and the modem still wasn't working so it was stuck on the sky screen.

    The new one also completes and since it skips first use app it doesn't hang. The phone is useable in wifi mode for internet etc.

    I tried doing the ModemFW flash through novaterm and it was still unable to access the modem (/dev/modemdiag not found). Tried a few different versions, the only one that really "worked" was the CDMA firmware from the verizon doctor. The WR doctor HAS a cdma firmware file but it is empty (0Kb filesize) so I extracted it from the verizon doctor instead.

    Also tried the sprint firmware from their pre- doctor but that didn't work at all. I think whatever moisture got in didn't JUST scramble the firmware, it caused actual permanent hardware damage (probably a soft short, since nothing really exploded when I turned the phone on after the drying period but the battery drained very quickly)

    I also swapped the cable with the pre- one (the pre2 one was a bit damaged looking) but it didn't change anything

    My only question, then, is if it's worth it to try for a new comms board-- given the other things that are working (wifi for instance), is it possible the problem is NOT the comms board but other connective tissue? I think that this shouldn't be the case (since the ATT comms board does show up when I plug it in) but I'm curious if there are any other opinions on that
  11. #11  
    Ended up with an android phone... sorry webOS. But when my last touchpad order was finally canceled it was a sign. On the bright side, I think I have a ship-shape GSM Pre2 that I will be gifting to my sister.

    Still, probably the best phones I will ever have owned.

Posting Permissions