Results 1 to 8 of 8
  1.    #1  
    EDIT: UPDATE! IT WORKS! YAY! You will apparently need to remove the user-agent spoof if you are using it, but once you do that and follow this guide you have hulu on your 2.1 pre.

    We were talking about a recent fix that got Hulu working over on the touchpads, and it seems to me the same thing -should- get hulu working on any 2.1.0 pre.

    I figured I'd toss it here if anyone wanted to give it a shot - I'm still rocking a pre- on 1.4.5 so I can't do it myself.


    Before you do anything - remove the user-agent spoof if you have one on your phone.

    First, ensure you are in DEV MODE.

    Plug the pre into the computer.

    Go into webOS quick install on your home pc.

    Run webOS quick install, select the TOOLS tab, and pick LINUX COMMANDLINE. Make sure your web browser is closed on the pre.

    You should now be in a terminal at a command line looking at your pre.

    Now type or copy and paste the following lines into the terminal window. Hit enter after each line:

    cd /usr/lib/BrowserServerPlugins


    sed -i 's/WEB 10/WIN 10/'


    If you run into any issues related to your pre regarding it being in Read Only mode, you can fix it by typing the following:

    mount -o remount,rw /

    Then hit enter, and perform the steps listed above.

    That should be it - Hulu should now -theoretically- work on your pre 2...

    Want to reverse the process? Simply type (ALL ONE LINE):
    cp /usr/lib/BrowserServerPlugins/ /usr/lib/BrowserServerPlugins/

    If anyone would care to give it a shot and report back it might be nice to know that it works . Might even give me a reason to finally try and hodgepodge my old pre- into the 2.1.0 world.

    It may not work if the 2.1.0 pre uses a different identifier in the flash file (the touchpad uses WEB 10, the pre might use something else). Would love to hear one way or the other .
    Last edited by ncinerate; 08/26/2011 at 02:21 AM.
  2. #2  
    Hey guess what? IT WORKS!!! I had to remove the "change-user-agent" spoof because it thought I was an iphone. After that... Rocking me some hulu on a Frankenpre2! Thanks, working on my brand new TP too. Make sure to post the part about the spoof change removal in your instructions or it won't work.
  3.    #3  
    Thanks for testing it. Had a feeling it'd work on the Pre as well. Happy to see that it is . Should also fix BBC iplayer radio, and possibly ESPN.

    Fun fun.
  4. #4  
    I wodner if this could be made a patch...
  5. #5  
    I was wodnering the same thing (he he). So far I get the ads, then a black screen with the x in the bottom right corner and a back arrow in the bottom left. It might just take a long time to load and I'm impatient, or maybe it's not actually showing the programs. Either way it's an improvement as the ads wouldn't even load before. Progress has been made. I'll have some time to test this out over the next few days and post back here. ESPN definitely works, BBC iplayer does not, hulu runs ads then black so far.
    Last edited by matteebee13; 08/27/2011 at 12:43 AM.
  6. #6  
    Ok, not so fast... I can run the ads, then a black screen (hulu). I swear last night I watched an SNL clip. Tonight... Blackness after the ads. Can't quite confirm this yet. You may want to edit that this is a work in progress, unstable results, yada yada. I will test some more, but 3G is def nil & wifi spotty. Not exactly fully featured & usable like the TP, but like I said above, progress
    Last edited by matteebee13; 08/27/2011 at 12:43 AM.
  7. #7  
    tried it.. first time big X in bottom right with back button and black screen with loading video message. then i tried loading a clip and it said device not supported. ESPN works for me too.
  8. #8  
    it still isn't working on my vzw pre2, but it works great on my touchpad. What am I doi g work g?

Posting Permissions